aboutsummaryrefslogtreecommitdiff
path: root/graphics/luminance
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-07-04 18:51:09 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-07-04 18:51:09 +0000
commit05c1ff9b93ca66c22da646713a51812c6b338b32 (patch)
tree81d97df097ee524af47071b5f5f521dc012d34d7 /graphics/luminance
parent5be1617d019a08640418c9fd98350458b8f64380 (diff)
downloadports-05c1ff9b93ca66c22da646713a51812c6b338b32.tar.gz
ports-05c1ff9b93ca66c22da646713a51812c6b338b32.zip
Notes
Diffstat (limited to 'graphics/luminance')
-rw-r--r--graphics/luminance/Makefile65
-rw-r--r--graphics/luminance/distinfo6
-rw-r--r--graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp10
-rw-r--r--graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp13
-rw-r--r--graphics/luminance/pkg-plist28
5 files changed, 75 insertions, 47 deletions
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index df1311b0ec89..c88ae4f9490f 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -6,54 +6,55 @@
#
PORTNAME= qtpfsgui
-PORTVERSION= 1.9.1
-PORTREVISION= 2
+PORTVERSION= 1.9.2
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A graphical user interface that provides a workflow for HDR imaging
+BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
LIB_DEPENDS= exiv2.3:${PORTSDIR}/graphics/exiv2 \
- fftw3f.4:${PORTSDIR}/math/fftw3-float \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.9:${PORTSDIR}/graphics/jpeg
-BUILD_DEPENDS= qmake-qt4:${PORTSDIR}/devel/qmake4 \
- uic-qt4:${PORTSDIR}/devel/qt4-uic \
- rcc:${PORTSDIR}/devel/qt4-rcc \
- moc-qt4:${PORTSDIR}/devel/qt4-moc \
- lrelease-qt4:${PORTSDIR}/devel/qt4-linguist \
- ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
+ fftw3f.4:${PORTSDIR}/math/fftw3-float
USE_QT_VER= 4
-QT_COMPONENTS= corelib gui imageformats
+QT_COMPONENTS= corelib gui imageformats \
+ linguist_build moc_build qmake_build rcc_build uic_build
+INSTALLS_ICONS= yes
LRELEASE= ${QT_PREFIX}/bin/lrelease-qt4
-INSTALL_TARGET= install_target install_menu install_icon
-.if !defined(WITHOUT_NLS)
-PLIST_SUB+= NLS=""
-INSTALL_TARGET+=install_i18n
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET+=install_docs install_htmls
-.endif
-
post-patch:
- ${REINPLACE_CMD} -e 's|PREFIX = /usr/local|PREFIX = ${PREFIX}|g' \
- ${WRKSRC}/project.pro
-
-pre-build:
- @${LRELEASE} ${BUILD_WRKSRC}/project.pro
- @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
+ @${REINPLACE_CMD} -e '/^QMAKE_CXXFLAGS/d ; \
+ s|PREFIX =.*$$|PREFIX = ${PREFIX}|g ; \
+ /^INSTALLS/s|docs||g' ${WRKSRC}/project.pro
+.for file in src/MainWindow/mainWindow.cpp \
+ src/Preferences/preferencesDialog.cpp \
+ src/TransplantExif/transplant.cpp
+ @${REINPLACE_CMD} -e 's|/usr/local/share/qtpfsgui/|${DATADIR}/|g' \
+ ${WRKSRC}/${file}
+.endfor
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '316s|htmls||' ${WRKSRC}/project.pro
+.endif
-.include <bsd.port.pre.mk>
+do-configure:
+ @${LRELEASE} ${WRKSRC}/project.pro
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile (compiler segfault)
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/qtpfsgui
+ ${INSTALL} -d ${PREFIX}/share/icons/hicolor/48x48/apps
+ @${LN} -sf ${PREFIX}/share/pixmaps/qtpfsgui.png \
+ ${PREFIX}/share/icons/hicolor/48x48/apps/qtpfsgui.png
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc_file in AUTHORS Changelog README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${doc_file} ${DOCSDIR}
+.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/luminance/distinfo b/graphics/luminance/distinfo
index cb9640f1c886..5dab1867c1ab 100644
--- a/graphics/luminance/distinfo
+++ b/graphics/luminance/distinfo
@@ -1,3 +1,3 @@
-MD5 (qtpfsgui-1.9.1.tar.gz) = ab95c404992a666681434ae57983b295
-SHA256 (qtpfsgui-1.9.1.tar.gz) = 8d94afd824b005959a7222ab6c7ca371167b2a61fbbc3282b6a20f97ea63645c
-SIZE (qtpfsgui-1.9.1.tar.gz) = 1178024
+MD5 (qtpfsgui-1.9.2.tar.gz) = 8a037c1dc75f04752dc36a59e7237fc4
+SHA256 (qtpfsgui-1.9.2.tar.gz) = 4462ec3ea8cf17db7b1ebe624d378bf4e239b80e0de2b2c6bbdf8c00cce16c8e
+SIZE (qtpfsgui-1.9.2.tar.gz) = 1181880
diff --git a/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp b/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
new file mode 100644
index 000000000000..288384e31068
--- /dev/null
+++ b/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
@@ -0,0 +1,10 @@
+--- src/HdrCreation/HdrCreationManager.cpp.prig 2008-04-29 01:18:04.000000000 +0900
++++ src/HdrCreation/HdrCreationManager.cpp 2008-07-02 03:26:00.000000000 +0900
+@@ -28,6 +28,7 @@
+ #include "../Exif/exif_operations.h"
+ #include "mtb_alignment.h"
+ #include "../Threads/hdrInputLoader.h"
++#include "../arch/freebsd/math.h"
+
+ HdrCreationManager::HdrCreationManager() {
+ qtpfsgui_options=QtpfsguiOptions::getInstance();
diff --git a/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp b/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp
new file mode 100644
index 000000000000..a15b211d9f5b
--- /dev/null
+++ b/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp
@@ -0,0 +1,13 @@
+--- src/TM_operators/mantiuk06/contrast_domain.cpp.orig 2008-04-28 18:15:22.000000000 +0200
++++ src/TM_operators/mantiuk06/contrast_domain.cpp 2008-07-04 12:49:16.000000000 +0200
+@@ -41,8 +41,8 @@
+ #include <string.h>
+ #include <math.h>
+
+-#ifdef WIN32
+-#define exp10f( x ) exp( x * log (10))
++#if defined(WIN32) || defined(__FreeBSD__)
++#define exp10f(x) exp( (x) * log (10))
+ #endif
+
+ #include "contrast_domain.h"
diff --git a/graphics/luminance/pkg-plist b/graphics/luminance/pkg-plist
index 610300edb670..8b4c9224abfa 100644
--- a/graphics/luminance/pkg-plist
+++ b/graphics/luminance/pkg-plist
@@ -1,11 +1,11 @@
bin/qtpfsgui
share/applications/qtpfsgui.desktop
share/pixmaps/qtpfsgui.png
+share/icons/hicolor/48x48/apps/qtpfsgui.png
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/Changelog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/html/dcraw.html
%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
%%PORTDOCS%%%%DOCSDIR%%/html/hints.html
@@ -21,16 +21,20 @@ share/pixmaps/qtpfsgui.png
%%PORTDOCS%%%%DOCSDIR%%/html/images/tonemapdialog.jpeg
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/manual.html
-%%NLS%%%%DATADIR%%/i18n/lang_de.qm
-%%NLS%%%%DATADIR%%/i18n/lang_es.qm
-%%NLS%%%%DATADIR%%/i18n/lang_it.qm
-%%NLS%%%%DATADIR%%/i18n/lang_fr.qm
-%%NLS%%%%DATADIR%%/i18n/lang_pl.qm
-%%NLS%%%%DATADIR%%/i18n/lang_tr.qm
-%%NLS%%%%DATADIR%%/i18n/lang_ru.qm
-%%NLS%%%%DATADIR%%/i18n/lang_cs.qm
-%%NLS%%@dirrm %%DATADIR%%/i18n
-%%NLS%%@dirrm %%DATADIR%%
+%%DATADIR%%/i18n/lang_cs.qm
+%%DATADIR%%/i18n/lang_de.qm
+%%DATADIR%%/i18n/lang_es.qm
+%%DATADIR%%/i18n/lang_fr.qm
+%%DATADIR%%/i18n/lang_it.qm
+%%DATADIR%%/i18n/lang_pl.qm
+%%DATADIR%%/i18n/lang_ru.qm
+%%DATADIR%%/i18n/lang_tr.qm
+@dirrm %%DATADIR%%/i18n
+@dirrm %%DATADIR%%
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%