aboutsummaryrefslogtreecommitdiff
path: root/graphics/luminance
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2014-04-10 07:47:18 +0000
committerLars Engels <lme@FreeBSD.org>2014-04-10 07:47:18 +0000
commit30795292b1b19f5279ddb7eb7d32e25779060d4a (patch)
tree6ea26355a889886aa26e653402f7b6089d38f632 /graphics/luminance
parente31805bc78e4cbbd09e98168c382868b8b2603ec (diff)
downloadports-30795292b1b19f5279ddb7eb7d32e25779060d4a.tar.gz
ports-30795292b1b19f5279ddb7eb7d32e25779060d4a.zip
Notes
Diffstat (limited to 'graphics/luminance')
-rw-r--r--graphics/luminance/Makefile40
-rw-r--r--graphics/luminance/distinfo4
-rw-r--r--graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp11
-rw-r--r--graphics/luminance/pkg-plist30
4 files changed, 45 insertions, 40 deletions
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index 7ae2e827fc95..b044186986b4 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= luminance-hdr
-DISTVERSION= 2.3.0
-PORTREVISION= 6
+DISTVERSION= 2.3.1
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
@@ -13,21 +12,20 @@ COMMENT= Complete open source solution for HDR photography
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
-LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float \
- exiv2:${PORTSDIR}/graphics/exiv2 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- IlmImf:${PORTSDIR}/graphics/OpenEXR \
- tiff:${PORTSDIR}/graphics/tiff \
- gsl:${PORTSDIR}/math/gsl \
- raw_r:${PORTSDIR}/graphics/libraw
-
-USE_BZIP2= yes
-USES= cmake
+LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float \
+ libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libgsl.so:${PORTSDIR}/math/gsl \
+ libraw_r.so:${PORTSDIR}/graphics/libraw \
+ libboost_system.so:${PORTSDIR}/devel/boost-libs
+
+USES= cmake tar:bzip2
USE_QT4= gui sql webkit xml linguist_build moc_build qmake_build \
rcc_build uic_build imageformats_run
INSTALLS_ICONS= yes
-NO_STAGE= yes
post-patch:
# Do not install yet another copy of GPL (we use license framework instead)
# and fix installation path for docs (but not for internal help files)
@@ -45,4 +43,20 @@ post-patch:
's,@GIT_SHA1@,be5409f2ed028b0a509d3f4cd44a970a09d2ef6c,' \
${WRKSRC}/src/Common/GitSHA1.cpp.in
+# Include <string> in addition to <string.h> where necessary, as this
+# is required for building with libc++
+ @${REINPLACE_CMD} -E '1s|^|#include \<string\>|;' \
+ ${WRKSRC}/src/TonemappingOperators/drago03/pfstmo_drago03.cpp \
+ ${WRKSRC}/src/TonemappingOperators/reinhard02/pfstmo_reinhard02.cpp \
+ ${WRKSRC}/src/TonemappingOperators/reinhard05/pfstmo_reinhard05.cpp \
+ ${WRKSRC}/src/TonemappingOperators/mantiuk08/display_function.cpp \
+ ${WRKSRC}/src/TonemappingOperators/mantiuk08/display_size.cpp \
+ ${WRKSRC}/src/TonemappingOperators/mantiuk08/pfstmo_mantiuk08.cpp \
+ ${WRKSRC}/src/TonemappingOperators/fattal02/pfstmo_fattal02.cpp \
+ ${WRKSRC}/src/TonemappingOperators/durand02/pfstmo_durand02.cpp \
+ ${WRKSRC}/src/TonemappingOperators/pattanaik00/pfstmo_pattanaik00.cpp \
+ ${WRKSRC}/src/Libpfs/io/pfsreader.cpp \
+ ${WRKSRC}/src/Libpfs/io/rgbereader.cpp \
+ ${WRKSRC}/src/Libpfs/colorspace/colorspace.cpp
+
.include <bsd.port.mk>
diff --git a/graphics/luminance/distinfo b/graphics/luminance/distinfo
index b0706ea9581a..b4336118da63 100644
--- a/graphics/luminance/distinfo
+++ b/graphics/luminance/distinfo
@@ -1,2 +1,2 @@
-SHA256 (luminance-hdr-2.3.0.tar.bz2) = dada0795b58843912bcb57ce61dcd615bcb9f9437b610a37ff813ad2c899c676
-SIZE (luminance-hdr-2.3.0.tar.bz2) = 5398576
+SHA256 (luminance-hdr-2.3.1.tar.bz2) = c2a4764986bf8860d448530f3c8d76143d7504cebb07b3e58e37eb0db5347722
+SIZE (luminance-hdr-2.3.1.tar.bz2) = 10323806
diff --git a/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp b/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp
deleted file mode 100644
index 7a57e9231987..000000000000
--- a/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/HelpBrowser/LuminancePaths.cpp.orig
-+++ ./src/HelpBrowser/LuminancePaths.cpp
-@@ -35,8 +35,6 @@ QString LuminancePaths::HelpDir()
- hf = LocalizedDirPath(QApplication::applicationDirPath() + dirsep + "../Resources/help/en" + dirsep);
- #elif _WIN32
- hf = LocalizedDirPath(QApplication::applicationDirPath() + dirsep + "help" + dirsep);
--#elif __FreeBSD__
-- hf = LocalizedDirPath("/usr/local/share/doc/luminance-hdr/");
- #else
- // hf = LocalizedDirPath( PREFIX + dirsep + "share" + dirsep + "fontmatrix" + dirsep + "help" + dirsep );
- //hf = LocalizedDirPath("usr" + dirsep + "share" + dirsep + "luminance-hdr" + dirsep + "help" + dirsep);
diff --git a/graphics/luminance/pkg-plist b/graphics/luminance/pkg-plist
index 6f7de1691408..9c52d3b5d244 100644
--- a/graphics/luminance/pkg-plist
+++ b/graphics/luminance/pkg-plist
@@ -1,6 +1,9 @@
-bin/luminance-hdr
-bin/luminance-hdr-cli
+%%QT_BINDIR%%/luminance-hdr
+%%QT_BINDIR%%/luminance-hdr-cli
share/applications/luminance-hdr.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/README
share/icons/hicolor/48x48/apps/luminance-hdr.png
%%DATADIR%%/help/en/README
%%DATADIR%%/help/en/additional.html
@@ -60,13 +63,8 @@ share/icons/hicolor/48x48/apps/luminance-hdr.png
%%DATADIR%%/help/en/tonemapping_cli.html
%%DATADIR%%/help/en/tonemapping_interactive.html
%%DATADIR%%/help/en/workflow.html
-%%DATADIR%%/help/js/jquery.js
-%%DATADIR%%/help/js/jquery.jtabs.pack.js
-@dirrm %%DATADIR%%/help/js
-@dirrm %%DATADIR%%/help/en/images
-@dirrm %%DATADIR%%/help/en
-@dirrm %%DATADIR%%/help
%%DATADIR%%/i18n/lang_cs.qm
+%%DATADIR%%/i18n/lang_da.qm
%%DATADIR%%/i18n/lang_de.qm
%%DATADIR%%/i18n/lang_es.qm
%%DATADIR%%/i18n/lang_fi.qm
@@ -93,9 +91,13 @@ share/icons/hicolor/48x48/apps/luminance-hdr.png
%%DATADIR%%/i18n/qt_ru.qm
%%DATADIR%%/i18n/qt_tr.qm
%%DATADIR%%/i18n/qt_zh.qm
-@dirrm %%DATADIR%%/i18n
-@dirrm %%DATADIR%%
-%%DOCSDIR%%/AUTHORS
-%%DOCSDIR%%/Changelog
-%%DOCSDIR%%/README
-@dirrm %%DOCSDIR%%
+@dirrmtry %%DATADIR%%/i18n
+@dirrmtry %%DATADIR%%/help/en/images
+@dirrmtry %%DATADIR%%/help/en
+@dirrmtry %%DATADIR%%/help
+@dirrmtry %%DATADIR%%
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+%%PORTDOCS%%@dirrm %%DOCSDIR%%