aboutsummaryrefslogtreecommitdiff
path: root/graphics/luminance
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-11-12 12:25:34 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-11-12 12:25:34 +0000
commitaf4473d7da8dc2f879e1aae7ffaf340ba855aeb8 (patch)
tree285b03200023a5561333482b0c2d9bedda277162 /graphics/luminance
parentd755873a61a0e1046866946ded6f940488892c5a (diff)
downloadports-af4473d7da8dc2f879e1aae7ffaf340ba855aeb8.tar.gz
ports-af4473d7da8dc2f879e1aae7ffaf340ba855aeb8.zip
Notes
Diffstat (limited to 'graphics/luminance')
-rw-r--r--graphics/luminance/Makefile69
-rw-r--r--graphics/luminance/distinfo5
-rw-r--r--graphics/luminance/files/patch-src__Exif__ExifOperations.cpp10
-rw-r--r--graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp16
-rw-r--r--graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp11
-rw-r--r--graphics/luminance/pkg-descr6
-rw-r--r--graphics/luminance/pkg-plist84
7 files changed, 118 insertions, 83 deletions
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index 0f34bcc3f121..dbbc91387c7c 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -5,13 +5,13 @@
# $FreeBSD$
#
-PORTNAME= qtpfsgui
-PORTVERSION= 1.9.3
-PORTREVISION= 5
+PORTNAME= luminance
+DISTVERSION= 2.0.1-1
CATEGORIES= graphics
-MASTER_SITES= SF
+MASTER_SITES= SF/qtpfsgui/luminance/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-v${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= goffredo@gmail.com
COMMENT= A graphical user interface that provides a workflow for HDR imaging
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
@@ -19,55 +19,36 @@ LIB_DEPENDS= exiv2.9:${PORTSDIR}/graphics/exiv2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
tiff.4:${PORTSDIR}/graphics/tiff \
- fftw3f.5:${PORTSDIR}/math/fftw3-float
+ fftw3f.5:${PORTSDIR}/math/fftw3-float \
+ gsl.15:${PORTSDIR}/math/gsl
USE_QT_VER= 4
-QT_COMPONENTS= corelib gui imageformats \
- linguist_build moc_build qmake_build rcc_build uic_build
-MAKE_ENV+= LOCALSOFT=${LOCALBASE}
+QT_COMPONENTS= gui xml webkit imageformats_run linguist_build \
+ moc_build qmake_build rcc_build uic_build
+QMAKE_ARGS= PREFIX=${PREFIX} DOCDIR=${DOCSDIR} I18NDIR=${DATADIR}/i18n
MAKE_JOBS_SAFE= yes
-INSTALL_TARGET= install_target install_menu install_icon install_i18n
INSTALLS_ICONS= yes
LRELEASE= ${QT_PREFIX}/bin/lrelease-qt4
-.if !defined(NOPORTOOCS)
-INSTALL_TARGET+=install_htmls
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e '/^QMAKE_CXXFLAGS/d ; \
- s|PREFIX =.*$$|PREFIX = ${PREFIX}|g' ${WRKSRC}/project.pro
-.for file in src/MainWindow/mainWindow.cpp \
- src/Preferences/preferencesDialog.cpp \
- src/TransplantExif/transplant.cpp
- @${REINPLACE_CMD} -e 's|/usr/share/qtpfsgui|${DOCSDIR}|g ; \
- s|/usr/local/share/qtpfsgui|${DATADIR}|g' ${WRKSRC}/${file}
-.endfor
+ cd ${WRKSRC}/src && ${REINPLACE_CMD} \
+ -e 's|/usr/share/luminance|${DOCSDIR}|g' \
+ -e 's|/usr/local/share/luminance|${DATADIR}|g' \
+ MainWindow/MainWindow.cpp \
+ Preferences/PreferencesDialog.cpp \
+ TonemappingWindow/TonemappingWindow.cpp \
+ TransplantExif/TransplantExifDialog.cpp
+ ${REINPLACE_CMD} -e 's|%%HELPDIR%%|${DOCSDIR}|g' \
+ ${WRKSRC}/src/HelpBrowser/LuminancePaths.cpp
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e '/INSTALL/s,help,,' \
+ -e '/INSTALL/s,docs,,' \
+ ${WRKSRC}/project.pro
+.endif
do-configure:
@${LRELEASE} ${WRKSRC}/project.pro
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/qtpfsgui ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/qtpfsgui.desktop ${PREFIX}/share/applications
- @${MKDIR} ${PREFIX}/share/icons/hicolor/32x32/apps
- ${INSTALL_DATA} ${WRKSRC}/images/qtpfsgui.png \
- ${PREFIX}/share/icons/hicolor/32x32/apps
- @${LN} -sf ${PREFIX}/share/icons/hicolor/32x32/apps/qtpfsgui.png \
- ${PREFIX}/share/pixmaps/qtpfsgui.png
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DATADIR}
- @${MKDIR} ${DATADIR}/i18n
- ${INSTALL_DATA} ${WRKSRC}/i18n/*.qm ${DATADIR}/i18n
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for doc_file in AUTHORS Changelog README TODO
- ${INSTALL_DATA} ${WRKSRC}/${doc_file} ${DOCSDIR}
-.endfor
- @(cd ${WRKSRC}; ${COPYTREE_SHARE} html ${DOCSDIR})
-.endif
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKE_ARGS} ${QMAKEFLAGS}
.include <bsd.port.mk>
diff --git a/graphics/luminance/distinfo b/graphics/luminance/distinfo
index 63a027cfaad8..a16419cbfd7e 100644
--- a/graphics/luminance/distinfo
+++ b/graphics/luminance/distinfo
@@ -1,3 +1,2 @@
-MD5 (qtpfsgui-1.9.3.tar.gz) = 5a6421391e373c912e4a793e131151c8
-SHA256 (qtpfsgui-1.9.3.tar.gz) = 016aaa339ede405bfa55d531069bd64f45fd6139836b6ea9b4d655e2734b8fd6
-SIZE (qtpfsgui-1.9.3.tar.gz) = 1356731
+SHA256 (luminance-v2.0.1-1.tar.gz) = 16ddead236f7b8d81fc67cbd7d8f384e51ebe5263c3a11afa6046821fb02e922
+SIZE (luminance-v2.0.1-1.tar.gz) = 2435362
diff --git a/graphics/luminance/files/patch-src__Exif__ExifOperations.cpp b/graphics/luminance/files/patch-src__Exif__ExifOperations.cpp
new file mode 100644
index 000000000000..5f8387ff4d14
--- /dev/null
+++ b/graphics/luminance/files/patch-src__Exif__ExifOperations.cpp
@@ -0,0 +1,10 @@
+--- ./src/Exif/ExifOperations.cpp.orig 2010-04-12 20:58:25.000000000 +0400
++++ ./src/Exif/ExifOperations.cpp 2010-11-12 14:20:53.446299319 +0300
+@@ -23,6 +23,7 @@
+
+ #include <image.hpp>
+ #include <cmath>
++#include "../arch/freebsd/math.h"
+
+ #include "ExifOperations.h"
+
diff --git a/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp b/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
index 288384e31068..8be3507718a3 100644
--- a/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
+++ b/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
@@ -1,10 +1,10 @@
---- src/HdrCreation/HdrCreationManager.cpp.prig 2008-04-29 01:18:04.000000000 +0900
-+++ src/HdrCreation/HdrCreationManager.cpp 2008-07-02 03:26:00.000000000 +0900
-@@ -28,6 +28,7 @@
- #include "../Exif/exif_operations.h"
- #include "mtb_alignment.h"
- #include "../Threads/hdrInputLoader.h"
+--- ./src/HdrCreation/HdrCreationManager.cpp.orig 2010-05-20 21:46:40.000000000 +0400
++++ ./src/HdrCreation/HdrCreationManager.cpp 2010-11-12 14:20:53.448299319 +0300
+@@ -23,6 +23,7 @@
+
+ #include <QApplication>
+ #include <QFileInfo>
+#include "../arch/freebsd/math.h"
- HdrCreationManager::HdrCreationManager() {
- qtpfsgui_options=QtpfsguiOptions::getInstance();
+ #include "Fileformat/pfstiff.h"
+ #include "Exif/ExifOperations.h"
diff --git a/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp b/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp
new file mode 100644
index 000000000000..92b49708b84d
--- /dev/null
+++ b/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp
@@ -0,0 +1,11 @@
+--- ./src/HelpBrowser/LuminancePaths.cpp.orig 2009-12-05 19:28:52.000000000 +0300
++++ ./src/HelpBrowser/LuminancePaths.cpp 2010-11-12 14:20:53.460402688 +0300
+@@ -35,7 +35,7 @@
+ hf = LocalizedDirPath(QApplication::applicationDirPath() + dirsep + "help" + dirsep );
+ #else
+ // hf = LocalizedDirPath( PREFIX + dirsep + "share" + dirsep + "fontmatrix" + dirsep + "help" + dirsep );
+- hf = LocalizedDirPath( "/usr" + dirsep + "share" + dirsep + "luminance" + dirsep + "help" + dirsep );
++ hf = LocalizedDirPath( "%%HELPDIR%%/" );
+ #endif
+ getThis()->LuminancePathsDB["HelpDir"] = hf;
+
diff --git a/graphics/luminance/pkg-descr b/graphics/luminance/pkg-descr
index a0b6587f4ee9..90b35a15417d 100644
--- a/graphics/luminance/pkg-descr
+++ b/graphics/luminance/pkg-descr
@@ -1,4 +1,4 @@
-Qtpfsgui is a graphical user interface (based on trolltech's Qt4)
-that provides a workflow for HDR imaging.
+Luminance HDR is an open source graphical user interface
+application that aims to provide a workflow for HDR imaging.
-WWW: http://qtpfsgui.sourceforge.net/
+WWW: http://qtpfsgui.sourceforge.net/
diff --git a/graphics/luminance/pkg-plist b/graphics/luminance/pkg-plist
index 8133f9c26ea5..63ee59f60676 100644
--- a/graphics/luminance/pkg-plist
+++ b/graphics/luminance/pkg-plist
@@ -1,33 +1,64 @@
-bin/qtpfsgui
-share/applications/qtpfsgui.desktop
-share/pixmaps/qtpfsgui.png
-share/icons/hicolor/32x32/apps/qtpfsgui.png
+bin/luminance
+share/applications/luminance.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/html/dcraw.html
-%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
-%%PORTDOCS%%%%DOCSDIR%%/html/hints.html
-%%PORTDOCS%%%%DOCSDIR%%/html/images/batch-1.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/copy_exif.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/mainwin.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/projectiveTransformationDialog.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/raw_conversion.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/resize.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_4.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_5.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_6.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/tonemapdialog.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/manual.html
-%%DATADIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/help/en/README
+%%PORTDOCS%%%%DOCSDIR%%/help/en/additional.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/basics.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing_donating.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing_programming.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing_testing.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing_translating.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/copying_exif.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/creating_hdr.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/creating_hdr_cli.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/creating_hdr_interactive.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/dcraw.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/editing_hdr.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/external.png
+%%PORTDOCS%%%%DOCSDIR%%/help/en/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/features.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/hints.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/images/batch-tmo.png
+%%PORTDOCS%%%%DOCSDIR%%/help/en/images/copy-exif.png
+%%PORTDOCS%%%%DOCSDIR%%/help/en/images/mainwin.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/help/en/images/not-translated-menu-item.png
+%%PORTDOCS%%%%DOCSDIR%%/help/en/images/projectiveTransformationDialog.png
+%%PORTDOCS%%%%DOCSDIR%%/help/en/images/resize.png
+%%PORTDOCS%%%%DOCSDIR%%/help/en/images/tonemapdialog.jpg
+%%PORTDOCS%%%%DOCSDIR%%/help/en/images/translated-menu-item.png
+%%PORTDOCS%%%%DOCSDIR%%/help/en/index.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/menu.xml
+%%PORTDOCS%%%%DOCSDIR%%/help/en/news.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs_hdr.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs_tonemapping.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs_tools.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs_ui.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/projective_transformation.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/style.css
+%%PORTDOCS%%%%DOCSDIR%%/help/en/tmap_ref.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/tmap_ref_drago.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/tmap_ref_durand.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/tmap_ref_mantiuk06.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/tonemapping.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/tonemapping_batch.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/tonemapping_cli.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/tonemapping_interactive.html
+%%PORTDOCS%%%%DOCSDIR%%/help/en/workflow.html
+%%PORTDOCS%%%%DOCSDIR%%/help/js/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/help/js/jquery.jtabs.pack.js
+share/icons/hicolor/32x32/apps/luminance.png
%%DATADIR%%/i18n/lang_cs.qm
%%DATADIR%%/i18n/lang_de.qm
%%DATADIR%%/i18n/lang_es.qm
%%DATADIR%%/i18n/lang_fr.qm
-%%DATADIR%%/i18n/lang_hu.qm
-%%DATADIR%%/i18n/lang_id.qm
%%DATADIR%%/i18n/lang_it.qm
%%DATADIR%%/i18n/lang_pl.qm
%%DATADIR%%/i18n/lang_ru.qm
@@ -38,7 +69,10 @@ share/icons/hicolor/32x32/apps/qtpfsgui.png
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/js
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/img
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/en/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/en
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/help
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications