aboutsummaryrefslogtreecommitdiff
path: root/graphics/luminance
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-03-17 17:55:18 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-03-17 17:55:18 +0000
commit600f4cfc42f12d207df4c9749c4c24fc5115d960 (patch)
tree353c1b3dc9fef6444764761302ce317f9c7e6f88 /graphics/luminance
parent0aa7e4d0c360b0f4f15a2c65cd3ae2118bf345db (diff)
downloadports-600f4cfc42f12d207df4c9749c4c24fc5115d960.tar.gz
ports-600f4cfc42f12d207df4c9749c4c24fc5115d960.zip
Notes
Diffstat (limited to 'graphics/luminance')
-rw-r--r--graphics/luminance/Makefile9
-rw-r--r--graphics/luminance/distinfo6
-rw-r--r--graphics/luminance/files/patch-project.pro35
-rw-r--r--graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp10
-rw-r--r--graphics/luminance/pkg-plist12
5 files changed, 43 insertions, 29 deletions
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index 2ddc7753ab80..50928c1e81c0 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qtpfsgui
-DISTVERSION= 1.8.10
-PORTREVISION= 2
+PORTVERSION= 1.9.1
CATEGORIES= graphics
MASTER_SITES= SF
@@ -39,9 +38,13 @@ INSTALL_TARGET+=install_i18n
PLIST_SUB+= NLS="@comment "
.endif
.if !defined(NOPORTDOCS)
-INSTALL_TARGET+=install_docs
+INSTALL_TARGET+=install_docs install_htmls
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|PREFIX = /usr/local|PREFIX = ${PREFIX}|g' \
+ ${WRKSRC}/project.pro
+
pre-build:
@${LRELEASE} ${BUILD_WRKSRC}/project.pro
@cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
diff --git a/graphics/luminance/distinfo b/graphics/luminance/distinfo
index a33b5da40b91..cb9640f1c886 100644
--- a/graphics/luminance/distinfo
+++ b/graphics/luminance/distinfo
@@ -1,3 +1,3 @@
-MD5 (qtpfsgui-1.8.10.tar.gz) = 909cf32d90f2c7561d92877575742bd8
-SHA256 (qtpfsgui-1.8.10.tar.gz) = 0cb2f9186dd1f32ca1d64340055fb9d71da786a9a5cb3ebe346251d551200e95
-SIZE (qtpfsgui-1.8.10.tar.gz) = 1080221
+MD5 (qtpfsgui-1.9.1.tar.gz) = ab95c404992a666681434ae57983b295
+SHA256 (qtpfsgui-1.9.1.tar.gz) = 8d94afd824b005959a7222ab6c7ca371167b2a61fbbc3282b6a20f97ea63645c
+SIZE (qtpfsgui-1.9.1.tar.gz) = 1178024
diff --git a/graphics/luminance/files/patch-project.pro b/graphics/luminance/files/patch-project.pro
index c92b55b377e6..cb4d0d736df3 100644
--- a/graphics/luminance/files/patch-project.pro
+++ b/graphics/luminance/files/patch-project.pro
@@ -1,29 +1,28 @@
---- project.pro.orig Sat Jul 14 21:44:28 2007
-+++ project.pro Sun Sep 9 21:54:27 2007
-@@ -171,13 +171,13 @@
+--- project.pro.orig 2008-02-16 11:43:24.000000000 +0100
++++ project.pro 2008-03-17 17:18:14.000000000 +0100
+@@ -298,13 +298,13 @@
menu.files = qtpfsgui.desktop
menu.path = $${PREFIX}/share/applications
icon.files = images/qtpfsgui.png
-icon.path = $${PREFIX}/share/icons/hicolor/48x48/apps
--htmls.files = html
++icon.path = $${PREFIX}/share/pixmaps
+ htmls.files = html
-htmls.path = $${PREFIX}/share/qtpfsgui
-+icon.path = $${PREFIX}/share/pixmaps
-+docs.files = AUTHORS COPYING Changelog INSTALL NEWS README TODO html
-+docs.path = $${PREFIX}/share/doc/qtpfsgui
- i18n.files = i18n/lang_de.qm i18n/lang_es.qm i18n/lang_it.qm i18n/lang_fr.qm i18n/lang_pl.qm i18n/lang_tr.qm
++htmls.path = $${PREFIX}/share/doc/qtpfsgui
+ i18n.files = i18n/lang_de.qm i18n/lang_es.qm i18n/lang_it.qm i18n/lang_fr.qm i18n/lang_pl.qm i18n/lang_tr.qm i18n/lang_ru.qm i18n/lang_cs.qm
i18n.path = $$I18NDIR
+ docs.files = README LICENSE AUTHORS INSTALL Changelog
+-docs.path = $${PREFIX}/share/qtpfsgui
++docs.path = $${PREFIX}/share/doc/qtpfsgui
--INSTALLS += target menu icon htmls i18n
-+INSTALLS += target menu icon docs i18n
+ INSTALLS += target menu icon htmls i18n docs
message ( "" )
- message ("********************************************************************")
- message ("Installation PREFIX=$$PREFIX")
-@@ -191,7 +191,7 @@
- message ("qtpfsgui ==> $$target.path")
+@@ -320,7 +320,7 @@
+ message ("qtpfsgui ==> $$target.path")
message ("qtpfsgui.desktop ==> $$menu.path")
- message ("qtpfsgui.png ==> $$icon.path")
--message ("html directory ==> $$htmls.path")
-+message ("doc directory ==> $$docs.path")
- message ("i18n messages ==> $$i18n.path")
+ message ("qtpfsgui.png ==> $$icon.path")
+-message ("html and docs ==> $$htmls.path")
++message ("html ==> $$docs.path")
+ message ("i18n messages ==> $$i18n.path")
message ("********************************************************************")
diff --git a/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp b/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp
new file mode 100644
index 000000000000..3e8dec9913bb
--- /dev/null
+++ b/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp
@@ -0,0 +1,10 @@
+--- src/HdrCreation/mtb_alignment.cpp.orig 2008-03-17 15:55:26.000000000 +0100
++++ src/HdrCreation/mtb_alignment.cpp 2008-03-17 15:57:21.000000000 +0100
+@@ -27,6 +27,7 @@
+ #include <cassert>
+ #include <QVector>
+ #include "mtb_alignment.h"
++#include "../arch/freebsd/math.h"
+
+ QImage* shiftQImage(const QImage *in, int dx, int dy)
+ {
diff --git a/graphics/luminance/pkg-plist b/graphics/luminance/pkg-plist
index d4c3973d5673..610300edb670 100644
--- a/graphics/luminance/pkg-plist
+++ b/graphics/luminance/pkg-plist
@@ -2,19 +2,19 @@ bin/qtpfsgui
share/applications/qtpfsgui.desktop
share/pixmaps/qtpfsgui.png
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/Changelog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/html/dcraw.html
%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
%%PORTDOCS%%%%DOCSDIR%%/html/hints.html
%%PORTDOCS%%%%DOCSDIR%%/html/images/batch-1.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/images/copy_exif.jpeg
%%PORTDOCS%%%%DOCSDIR%%/html/images/mainwin.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/projectiveTransformationDialog.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/raw_conversion.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/images/resize.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_3.jpeg
%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_4.jpeg
%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_5.jpeg
%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_6.jpeg
@@ -23,10 +23,12 @@ share/pixmaps/qtpfsgui.png
%%PORTDOCS%%%%DOCSDIR%%/html/manual.html
%%NLS%%%%DATADIR%%/i18n/lang_de.qm
%%NLS%%%%DATADIR%%/i18n/lang_es.qm
-%%NLS%%%%DATADIR%%/i18n/lang_fr.qm
%%NLS%%%%DATADIR%%/i18n/lang_it.qm
+%%NLS%%%%DATADIR%%/i18n/lang_fr.qm
%%NLS%%%%DATADIR%%/i18n/lang_pl.qm
%%NLS%%%%DATADIR%%/i18n/lang_tr.qm
+%%NLS%%%%DATADIR%%/i18n/lang_ru.qm
+%%NLS%%%%DATADIR%%/i18n/lang_cs.qm
%%NLS%%@dirrm %%DATADIR%%/i18n
%%NLS%%@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/images