aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapnik/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-05-24 23:53:38 +0000
committerWen Heping <wen@FreeBSD.org>2011-05-24 23:53:38 +0000
commit46f52d615399fe552282ad941e54c242eae4ef6e (patch)
tree3cfa6239e069fd75619c0a8129105a8f128c0f97 /graphics/mapnik/Makefile
parentefa15d92b5e876d654b707f1ecc2abfbcb604f13 (diff)
downloadports-46f52d615399fe552282ad941e54c242eae4ef6e.tar.gz
ports-46f52d615399fe552282ad941e54c242eae4ef6e.zip
Notes
Diffstat (limited to 'graphics/mapnik/Makefile')
-rw-r--r--graphics/mapnik/Makefile40
1 files changed, 29 insertions, 11 deletions
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 46e6536ebf6b..8a3f03b5890a 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -6,43 +6,61 @@
#
PORTNAME= mapnik
-PORTVERSION= 0.6.1
-PORTREVISION= 5
+PORTVERSION= 0.7.1
CATEGORIES= graphics geography
MASTER_SITES= ${MASTER_SITE_BERLIOS}/${PORTNAME}/
MAINTAINER= wenheping@gmail.com
COMMENT= A Free Toolkit For Developing Mapping Applications
-LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
- proj:${PORTSDIR}/graphics/proj \
+LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj \
png:${PORTSDIR}/graphics/png \
tiff:${PORTSDIR}/graphics/tiff \
- cairo.2:${PORTSDIR}/graphics/cairo \
- iconv:${PORTSDIR}/converters/libiconv
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ icuuc:${PORTSDIR}/devel/icu \
+ boost_system:${PORTSDIR}/devel/boost-libs
BUILD_DEPENDS= ${LOCALBASE}/bin/freetype-config:${PORTSDIR}/print/freetype2 \
+ icu>=4.1.4:${PORTSDIR}/devel/icu \
${PYTHON_PKGNAMEPREFIX}icu>=0.8.1:${PORTSDIR}/devel/py-icu \
- ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:${PORTSDIR}/graphics/py-cairo \
- ${LOCALBASE}/include/cairomm-1.0/cairomm/cairomm.h:${PORTSDIR}/graphics/cairomm \
+ boost-libs>1.41:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/boost/python.hpp:${PORTSDIR}/devel/boost-python-libs
-BROKEN= Does not build with boost-1.41
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
USE_PGSQL= yes
USE_BZIP2= yes
-NO_BUILD= yes
USE_PYTHON= 2.5+
USE_LDCONFIG= yes
+USE_SCONS= yes
USE_AUTOTOOLS= libltdl
+USE_GNOME= pkgconfig libxml2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+OPTIONS= CAIRO "Enable cairo rendering" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_CAIRO)
+SCONS_ARGS+= CAIRO=False
+.else
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo \
+ cairomm-1.0:${PORTSDIR}/graphics/cairomm
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:${PORTSDIR}/graphics/py-cairo
+.endif
+
.include <bsd.port.pre.mk>
+.if defined (MAKE_JOBS_NUMBER)
+SCONS_ARGS+= JOBS=${MAKE_JOBS_NUMBER}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
${WRKSRC}/SConstruct
do-install:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} scons/scons.py install
+ @cd ${INSTALL_WRKSRC} && ${SETENV} ${SCONS_BUILDENV} ${SCONS_BIN} \
+ ${SCONS_INSTALL_TARGET}
.include <bsd.port.post.mk>