aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapnik/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-16 22:40:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-16 22:40:39 +0000
commit48050b5f23b54023fd587dad4cf3bd3ea36606dc (patch)
tree789583e974de655d41d1134a23045fa68df46372 /graphics/mapnik/Makefile
parent6a4287ed040f4cad70eba54845c854fa3b8ad5d0 (diff)
downloadports-48050b5f23b54023fd587dad4cf3bd3ea36606dc.tar.gz
ports-48050b5f23b54023fd587dad4cf3bd3ea36606dc.zip
Notes
Diffstat (limited to 'graphics/mapnik/Makefile')
-rw-r--r--graphics/mapnik/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 7a1e56744a71..a41d79446334 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= mapnik
-PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTVERSION= 0.6.0
CATEGORIES= graphics geography
MASTER_SITES= ${MASTER_SITE_BERLIOS}/${PORTNAME}/
-DISTNAME= mapnik_src-${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= A Free Toolkit For Developing Mapping Applications
@@ -20,10 +18,16 @@ LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
ltdl:${PORTSDIR}/devel/libltdl15 \
png:${PORTSDIR}/graphics/png \
tiff:${PORTSDIR}/graphics/tiff \
+ cairo.2:${PORTSDIR}/graphics/cairo \
iconv:${PORTSDIR}/converters/libiconv
BUILD_DEPENDS= ${LOCALBASE}/bin/freetype-config:${PORTSDIR}/print/freetype2 \
+ ${PYTHON_PKGNAMEPREFIX}icu>=0.8.1:${PORTSDIR}/devel/py-icu \
+ ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:${PORTSDIR}/graphics/py-cairo \
+ ${LOCALBASE}/include/cairomm-1.0/cairomm/cairomm.h:${PORTSDIR}/graphics/cairomm \
${LOCALBASE}/include/boost/python.hpp:${PORTSDIR}/devel/boost-python
+USE_PGSQL= yes
+USE_BZIP2= yes
NO_BUILD= yes
USE_PYTHON= 2.4+
USE_LDCONFIG= yes