aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapnik
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-10-25 20:47:23 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-10-25 20:47:23 +0000
commit86c3152156e732b14f36fb6bbf85589ee6cb534f (patch)
treea5f0c1e48beaabb299131278d972b2dbe17eecaf /graphics/mapnik
parent339aa6e578417185cb9f0f1d83e8e1d742385c5b (diff)
downloadports-86c3152156e732b14f36fb6bbf85589ee6cb534f.tar.gz
ports-86c3152156e732b14f36fb6bbf85589ee6cb534f.zip
Notes
Diffstat (limited to 'graphics/mapnik')
-rw-r--r--graphics/mapnik/Makefile110
-rw-r--r--graphics/mapnik/distinfo4
-rw-r--r--graphics/mapnik/files/patch-src-build.py65
-rw-r--r--graphics/mapnik/pkg-plist237
4 files changed, 242 insertions, 174 deletions
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 6d13ec4f594d..3dfcd86d046f 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: mapnik
-# Date created: Nov 10, 2008
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= mapnik
-PORTVERSION= 2.0.1
-PORTREVISION= 3
+PORTVERSION= 2.1.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics geography
MASTER_SITES= http://cloud.github.com/downloads/${PORTNAME}/${PORTNAME}/
@@ -27,7 +22,7 @@ LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj \
BUILD_DEPENDS= ${LOCALBASE}/bin/freetype-config:${PORTSDIR}/print/freetype2 \
icu>=4.2:${PORTSDIR}/devel/icu \
${PYTHON_PKGNAMEPREFIX}icu>=0.8.1:${PORTSDIR}/devel/py-icu \
- boost-libs>=1.45:${PORTSDIR}/devel/boost-libs \
+ boost-libs>=1.47:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/boost/python.hpp:${PORTSDIR}/devel/boost-python-libs
USE_BZIP2= yes
@@ -37,35 +32,43 @@ USE_SCONS= yes
USE_AUTOTOOLS= libltdl
USE_GNOME= pkgconfig libxml2
MAKE_JOBS_SAFE= yes
+WARNING_CXXFLAGS?= -w
-INPUT_PLUGINS= raster shape
+CONFICTS= svg2png*
-OPTIONS= CAIRO "Enable cairo rendering" on \
- SQLITE "SQLite input plugin" on \
- OGR "ogr input plugin" on \
- GDAL "gdal input plugin" on \
- POSTGIS "Postgis input plugin" on \
- OSM "OSM input plugin" off
+INPUT_PLUGINS= geojson python raster shape
+
+OPTIONS_DEFINE= CAIRO CSV GDAL GEOS OGR OSM POSTGIS SQLITE3
+OPTIONS_DEFAULT= CAIRO CSV GDAL OGR OSM POSTGIS SQLITE3
+
+CAIRO_DESC= Enable cairo rendering
+CSV_DESC= CSV input plugin
+GDAL_DESC= GDAL input plugin
+GEOS_DESC= GEOS input plugin
+OGR_DESC= OGR input plugin
+OSM_DESC= OSM input plugin
+POSTGIS_DESC= PostGIS input plugin
+SQLITE3_DESC= SQLite input plugin
.include <bsd.port.options.mk>
-.if defined(WITHOUT_CAIRO)
-SCONS_ARGS+= CAIRO=False
+.if ${PORT_OPTIONS:MCAIRO}
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo \
+ cairomm-1:${PORTSDIR}/graphics/cairomm
+BUILD_DEPENDS+= cairomm>=1.8.0:${PORTSDIR}/graphics/cairomm \
+ ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:${PORTSDIR}/graphics/py-cairo
.else
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo \
- cairomm-1.0:${PORTSDIR}/graphics/cairomm
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:${PORTSDIR}/graphics/py-cairo
+SCONS_ARGS+= CAIRO=False
.endif
-.if !defined(WITHOUT_POSTGIS)
-INPUT_PLUGINS+= postgis
-USE_PGSQL= yes
-PLIST_SUB+= POSTGIS=""
+.if ${PORT_OPTIONS:MCSV}
+INPUT_PLUGINS+= csv
+PLIST_SUB+= CSV=""
.else
-PLIST_SUB+= POSTGIS="@comment "
+PLIST_SUB+= CSV="@comment "
.endif
-.if !defined(WITHOUT_GDAL)
+.if ${PORT_OPTIONS:MGDAL}
INPUT_PLUGINS+= gdal
LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
PLIST_SUB+= GDAL=""
@@ -73,7 +76,15 @@ PLIST_SUB+= GDAL=""
PLIST_SUB+= GDAL="@comment "
.endif
-.if !defined(WITHOUT_OGR)
+.if ${PORT_OPTIONS:MGEOS}
+INPUT_PLUGINS+= geos
+LIB_DEPENDS+= geos:${PORTSDIR}/graphics/geos
+PLIST_SUB+= GEOS=""
+.else
+PLIST_SUB+= GEOS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MOGR}
INPUT_PLUGINS+= ogr
LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
PLIST_SUB+= OGR=""
@@ -81,23 +92,30 @@ PLIST_SUB+= OGR=""
PLIST_SUB+= OGR="@comment "
.endif
-.if !defined(WITHOUT_SQLITE)
-INPUT_PLUGINS+= sqlite
-LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
-PLIST_SUB+= SQLITE=""
-.else
-PLIST_SUB+= SQLITE="@comment "
-.endif
-
-.if defined(WITH_OSM)
+.if ${PORT_OPTIONS:MOSM}
INPUT_PLUGINS+= osm
-LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
PLIST_SUB+= OSM=""
.else
PLIST_SUB+= OSM="@comment "
.endif
-SCONS_ENV+= INPUT_PLUGINS="`${ECHO} ${INPUT_PLUGINS} | ${TR} ' ' ,`"
+.if ${PORT_OPTIONS:MPOSTGIS}
+INPUT_PLUGINS+= postgis
+USE_PGSQL= yes
+PLIST_SUB+= POSTGIS=""
+.else
+PLIST_SUB+= POSTGIS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE3}
+INPUT_PLUGINS+= sqlite
+LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
+BUILD_DEPENDS+= sqlite3>=3.7.12:${PORTSDIR}/databases/sqlite3
+PLIST_SUB+= SQLITE=""
+.else
+PLIST_SUB+= SQLITE="@comment "
+.endif
.include <bsd.port.pre.mk>
@@ -105,8 +123,22 @@ SCONS_ENV+= INPUT_PLUGINS="`${ECHO} ${INPUT_PLUGINS} | ${TR} ' ' ,`"
IGNORE= does not install: runs out of virtual memory
.endif
+SCONS_ARGS+= WARNING_CXXFLAGS=${WARNING_CXXFLAGS}
+SCONS_ARGS+= INPUT_PLUGINS="`${ECHO} ${INPUT_PLUGINS} | ${TR} ' ' ,`"
+
.if defined (MAKE_JOBS_NUMBER)
-SCONS_ENV+= JOBS=${MAKE_JOBS_NUMBER}
+SCONS_ARGS+= JOBS=${MAKE_JOBS_NUMBER}
+.endif
+
+pre-configure:
+.if ${PORT_OPTIONS:MSQLITE3}
+ @if ! ${LOCALBASE}/bin/sqlite3 :memory: 'create virtual table foo using rtree(pkid, xmin, xmax, ymin, ymax)' > /dev/null 2>&1; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "The SQLite plugin requires libsqlite3 built with RTREE support"; \
+ ${ECHO_MSG} "Please, reinstall 'databases/sqlite3' port with R*Tree module enabled"; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
.endif
post-patch:
diff --git a/graphics/mapnik/distinfo b/graphics/mapnik/distinfo
index 4ffa42f384de..4e0616e36126 100644
--- a/graphics/mapnik/distinfo
+++ b/graphics/mapnik/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mapnik-v2.0.1.tar.bz2) = fe3da0b1adbb48f55ebd01ab0e95e5183f512154249f1d407b7e59aa9176ba8c
-SIZE (mapnik-v2.0.1.tar.bz2) = 12018783
+SHA256 (mapnik-v2.1.0.tar.bz2) = d5fcbaaea00359613b707eacaaa2109a0b5696e2baa35c02e4436e8a823b7160
+SIZE (mapnik-v2.1.0.tar.bz2) = 17441565
diff --git a/graphics/mapnik/files/patch-src-build.py b/graphics/mapnik/files/patch-src-build.py
index b0ec4be25e64..e7a238b0e638 100644
--- a/graphics/mapnik/files/patch-src-build.py
+++ b/graphics/mapnik/files/patch-src-build.py
@@ -1,48 +1,31 @@
---- src/build.py.orig 2012-04-11 14:29:19.000000000 +0400
-+++ src/build.py 2012-04-11 14:34:13.000000000 +0400
-@@ -80,6 +80,8 @@
-
- if env['PLATFORM'] == 'Darwin':
- mapnik_libname = 'libmapnik.dylib'
-+elif env['PLATFORM'] == 'FreeBSD':
-+ mapnik_libname = 'libmapnik.so.' + ("%d" % int(ABI_VERSION[0]))
- else:
- mapnik_libname = 'libmapnik.so.' + ("%d.%d" % (int(ABI_VERSION[0]),int(ABI_VERSION[1])))
-
-@@ -326,8 +328,12 @@
- os.symlink(os.path.basename(src), trgt)
+--- src/build.py.orig 2012-08-24 01:57:06.000000000 +0400
++++ src/build.py 2012-09-16 19:38:43.000000000 +0400
+@@ -357,7 +357,11 @@
major, minor, micro = ABI_VERSION
--
-- soFile = "%s.%d.%d.%d" % (os.path.basename(str(mapnik[0])), int(major), int(minor), int(micro))
-+
+
+- soFile = "%s.%d.%d.%d" % (os.path.basename(env.subst(env['MAPNIK_LIB_NAME'])), int(major), int(minor), int(micro))
+ if env['PLATFORM'] == 'FreeBSD':
-+ soFile = "%s.%d" % (os.path.basename(str(mapnik[0])), int(major))
++ soFile = "%s.%d.%d" % (os.path.basename(env.subst(env['MAPNIK_LIB_NAME'])), int(major), int(minor))
+ else:
-+ soFile = "%s.%d.%d.%d" % (os.path.basename(str(mapnik[0])), int(major), int(minor), int(micro))
-+
++ soFile = "%s.%d.%d.%d" % (os.path.basename(env.subst(env['MAPNIK_LIB_NAME'])), int(major), int(minor), int(micro))
++
target = os.path.join(env['MAPNIK_LIB_BASE_DEST'], soFile)
-
- if 'uninstall' not in COMMAND_LINE_TARGETS:
-@@ -342,13 +348,17 @@
- target2 = os.path.join(env['MAPNIK_LIB_BASE_DEST'], os.path.basename(str(mapnik[0])))
+
if 'uninstall' not in COMMAND_LINE_TARGETS:
- if 'install' in COMMAND_LINE_TARGETS:
-- link1 = env.Command(target1, target, symlink)
-- env.Alias(target='install', source=link1)
-- link2 = env.Command(target2, target1, symlink)
-+ if env['PLATFORM'] == 'FreeBSD':
-+ link2 = env.Command(target2, target, symlink)
-+ else:
-+ link1 = env.Command(target1, target, symlink)
-+ env.Alias(target='install', source=link1)
-+ link2 = env.Command(target2, target1, symlink)
- env.Alias(target='install', source=link2)
- # delete in reverse order..
- env['create_uninstall_target'](env, target2)
-- env['create_uninstall_target'](env, target1)
-+ if env['PLATFORM'] != 'FreeBSD':
-+ env['create_uninstall_target'](env, target1)
- env['create_uninstall_target'](env, target)
+@@ -372,8 +376,13 @@
+
- else:
+ # Install symlinks
+- target1 = os.path.join(env['MAPNIK_LIB_BASE_DEST'], "%s.%d.%d" % \
+- (os.path.basename(env.subst(env['MAPNIK_LIB_NAME'])),int(major), int(minor)))
++ if env['PLATFORM'] == 'FreeBSD':
++ target1 = os.path.join(env['MAPNIK_LIB_BASE_DEST'], "%s.%d" % \
++ (os.path.basename(env.subst(env['MAPNIK_LIB_NAME'])),int(major)))
++ else:
++ target1 = os.path.join(env['MAPNIK_LIB_BASE_DEST'], "%s.%d.%d" % \
++ (os.path.basename(env.subst(env['MAPNIK_LIB_NAME'])),int(major), int(minor)))
++
+ target2 = os.path.join(env['MAPNIK_LIB_BASE_DEST'], os.path.basename(env.subst(env['MAPNIK_LIB_NAME'])))
+ if 'uninstall' not in COMMAND_LINE_TARGETS:
+ link1 = env.Command(target1, target, symlink)
diff --git a/graphics/mapnik/pkg-plist b/graphics/mapnik/pkg-plist
index 65f9606e3512..51424e279106 100644
--- a/graphics/mapnik/pkg-plist
+++ b/graphics/mapnik/pkg-plist
@@ -1,107 +1,65 @@
bin/mapnik-config
bin/mapnik-speed-check
bin/shapeindex
+bin/svg2png
bin/upgrade_map_xml.py
-include/mapnik/font_set.hpp
-include/mapnik/cairo_renderer.hpp
-include/mapnik/version.hpp
-include/mapnik/wkb.hpp
-include/mapnik/coord.hpp
-include/mapnik/utils.hpp
-include/mapnik/pool.hpp
-include/mapnik/image_util.hpp
-include/mapnik/rule.hpp
-include/mapnik/load_map.hpp
-include/mapnik/datasource_cache.hpp
-include/mapnik/text_path.hpp
-include/mapnik/arrow.hpp
-include/mapnik/memory_datasource.hpp
-include/mapnik/query.hpp
-include/mapnik/filter_factory.hpp
-include/mapnik/label_collision_detector.hpp
-include/mapnik/fill.hpp
-include/mapnik/geometry.hpp
-include/mapnik/filter_featureset.hpp
+include/mapnik/agg_helpers.hpp
+include/mapnik/agg_pattern_source.hpp
+include/mapnik/agg_rasterizer.hpp
+include/mapnik/agg_renderer.hpp
include/mapnik/attribute.hpp
-include/mapnik/line_pattern_symbolizer.hpp
-include/mapnik/point_symbolizer.hpp
-include/mapnik/params.hpp
-include/mapnik/libxml2_loader.hpp
-include/mapnik/image_view.hpp
-include/mapnik/feature_factory.hpp
-include/mapnik/style_factory.hpp
include/mapnik/attribute_collector.hpp
-include/mapnik/text_symbolizer.hpp
-include/mapnik/line_symbolizer.hpp
-include/mapnik/raster.hpp
-include/mapnik/polygon_symbolizer.hpp
-include/mapnik/geom_util.hpp
-include/mapnik/image_reader.hpp
-include/mapnik/config_error.hpp
-include/mapnik/polygon_pattern_symbolizer.hpp
-include/mapnik/image_data.hpp
-include/mapnik/octree.hpp
-include/mapnik/ellipsoid.hpp
-include/mapnik/raster_symbolizer.hpp
-include/mapnik/vertex.hpp
-include/mapnik/scale_denominator.hpp
-include/mapnik/stroke.hpp
-include/mapnik/value.hpp
-include/mapnik/datasource.hpp
-include/mapnik/map.hpp
-include/mapnik/placement_finder.hpp
-include/mapnik/unicode.hpp
-include/mapnik/coord_array.hpp
-include/mapnik/factory.hpp
-include/mapnik/graphics.hpp
-include/mapnik/jpeg_io.hpp
-include/mapnik/color_factory.hpp
-include/mapnik/plugin.hpp
-include/mapnik/gamma.hpp
-include/mapnik/feature.hpp
-include/mapnik/hextree.hpp
-include/mapnik/hit_test_filter.hpp
-include/mapnik/symbolizer.hpp
-include/mapnik/png_io.hpp
-include/mapnik/feature_layer_desc.hpp
-include/mapnik/layer.hpp
-include/mapnik/label_placement.hpp
-include/mapnik/font_engine_freetype.hpp
-include/mapnik/quad_tree.hpp
-include/mapnik/enumeration.hpp
-include/mapnik/memory_featureset.hpp
-include/mapnik/agg_renderer.hpp
-include/mapnik/feature_style_processor.hpp
include/mapnik/attribute_descriptor.hpp
-include/mapnik/projection.hpp
-include/mapnik/feature_type_style.hpp
-include/mapnik/ptree_helpers.hpp
-include/mapnik/global.hpp
+include/mapnik/boolean.hpp
+include/mapnik/box2d.hpp
+include/mapnik/building_symbolizer.hpp
+include/mapnik/cairo_renderer.hpp
+include/mapnik/char_info.hpp
+include/mapnik/color.hpp
+include/mapnik/color_factory.hpp
include/mapnik/config.hpp
+include/mapnik/config_error.hpp
+include/mapnik/coord.hpp
+include/mapnik/coord_array.hpp
+include/mapnik/css_color_grammar.hpp
include/mapnik/ctrans.hpp
-include/mapnik/color.hpp
-include/mapnik/vertex_transform.hpp
-include/mapnik/vertex_vector.hpp
-include/mapnik/markers_symbolizer.hpp
-include/mapnik/save_map.hpp
-include/mapnik/shield_symbolizer.hpp
-include/mapnik/memory.hpp
-include/mapnik/proj_transform.hpp
+include/mapnik/datasource.hpp
+include/mapnik/datasource_cache.hpp
+include/mapnik/debug.hpp
include/mapnik/distance.hpp
-include/mapnik/agg_pattern_source.hpp
-include/mapnik/agg_rasterizer.hpp
-include/mapnik/box2d.hpp
-include/mapnik/css_color_grammar.hpp
-include/mapnik/css_color_grammar_deprecated.hpp
+include/mapnik/ellipsoid.hpp
+include/mapnik/enumeration.hpp
include/mapnik/expression.hpp
include/mapnik/expression_evaluator.hpp
include/mapnik/expression_grammar.hpp
include/mapnik/expression_node.hpp
include/mapnik/expression_string.hpp
+include/mapnik/factory.hpp
include/mapnik/fastmath.hpp
-include/mapnik/glyph_symbolizer.hpp
+include/mapnik/feature.hpp
+include/mapnik/feature_factory.hpp
+include/mapnik/feature_kv_iterator.hpp
+include/mapnik/feature_layer_desc.hpp
+include/mapnik/feature_style_processor.hpp
+include/mapnik/feature_type_style.hpp
+include/mapnik/filter_factory.hpp
+include/mapnik/filter_featureset.hpp
+include/mapnik/font_engine_freetype.hpp
+include/mapnik/font_set.hpp
+include/mapnik/formatting/base.hpp
+include/mapnik/formatting/expression.hpp
+include/mapnik/formatting/format.hpp
+include/mapnik/formatting/list.hpp
+include/mapnik/formatting/registry.hpp
+include/mapnik/formatting/text.hpp
+include/mapnik/gamma_method.hpp
+include/mapnik/geom_util.hpp
+include/mapnik/geometry.hpp
+include/mapnik/global.hpp
include/mapnik/gradient.hpp
+include/mapnik/graphics.hpp
include/mapnik/grid/grid.hpp
+include/mapnik/grid/grid_marker_helpers.hpp
include/mapnik/grid/grid_pixel.hpp
include/mapnik/grid/grid_pixfmt.hpp
include/mapnik/grid/grid_rasterizer.hpp
@@ -109,21 +67,73 @@ include/mapnik/grid/grid_renderer.hpp
include/mapnik/grid/grid_rendering_buffer.hpp
include/mapnik/grid/grid_util.hpp
include/mapnik/grid/grid_view.hpp
+include/mapnik/hextree.hpp
+include/mapnik/hit_test_filter.hpp
include/mapnik/image_compositing.hpp
+include/mapnik/image_data.hpp
+include/mapnik/image_filter.hpp
+include/mapnik/image_filter_grammar.hpp
+include/mapnik/image_filter_types.hpp
+include/mapnik/image_reader.hpp
+include/mapnik/image_scaling.hpp
+include/mapnik/image_util.hpp
+include/mapnik/image_view.hpp
+include/mapnik/jpeg_io.hpp
+include/mapnik/json/feature_collection_grammar.hpp
+include/mapnik/json/feature_collection_parser.hpp
+include/mapnik/json/feature_generator_grammar.hpp
+include/mapnik/json/feature_grammar.hpp
+include/mapnik/json/geojson_generator.hpp
+include/mapnik/json/geometry_generator_grammar.hpp
+include/mapnik/json/geometry_grammar.hpp
+include/mapnik/json/geometry_parser.hpp
+include/mapnik/label_collision_detector.hpp
+include/mapnik/layer.hpp
+include/mapnik/line_pattern_symbolizer.hpp
+include/mapnik/line_symbolizer.hpp
+include/mapnik/load_map.hpp
+include/mapnik/map.hpp
include/mapnik/mapped_memory_cache.hpp
include/mapnik/marker.hpp
include/mapnik/marker_cache.hpp
+include/mapnik/marker_helpers.hpp
include/mapnik/markers_placement.hpp
-include/mapnik/metawriter.hpp
-include/mapnik/metawriter_factory.hpp
-include/mapnik/metawriter_inmem.hpp
-include/mapnik/metawriter_json.hpp
+include/mapnik/markers_symbolizer.hpp
+include/mapnik/memory.hpp
+include/mapnik/memory_datasource.hpp
+include/mapnik/memory_featureset.hpp
+include/mapnik/octree.hpp
+include/mapnik/offset_converter.hpp
include/mapnik/palette.hpp
+include/mapnik/params.hpp
include/mapnik/parse_path.hpp
+include/mapnik/parse_transform.hpp
include/mapnik/path_expression_grammar.hpp
+include/mapnik/pixel_position.hpp
+include/mapnik/placement_finder.hpp
+include/mapnik/plugin.hpp
+include/mapnik/png_io.hpp
+include/mapnik/point_symbolizer.hpp
+include/mapnik/polygon_pattern_symbolizer.hpp
+include/mapnik/polygon_symbolizer.hpp
+include/mapnik/pool.hpp
+include/mapnik/processed_text.hpp
+include/mapnik/proj_transform.hpp
+include/mapnik/projection.hpp
+include/mapnik/ptree_helpers.hpp
+include/mapnik/quad_tree.hpp
+include/mapnik/query.hpp
+include/mapnik/raster.hpp
include/mapnik/raster_colorizer.hpp
+include/mapnik/raster_symbolizer.hpp
+include/mapnik/rule.hpp
+include/mapnik/save_map.hpp
+include/mapnik/scale_denominator.hpp
include/mapnik/segment.hpp
+include/mapnik/shield_symbolizer.hpp
+include/mapnik/span_image_filter.hpp
include/mapnik/sql_utils.hpp
+include/mapnik/stroke.hpp
include/mapnik/svg/svg_converter.hpp
include/mapnik/svg/svg_generator.hpp
include/mapnik/svg/svg_output_attributes.hpp
@@ -140,19 +150,58 @@ include/mapnik/svg/svg_renderer.hpp
include/mapnik/svg/svg_storage.hpp
include/mapnik/svg/svg_transform_grammar.hpp
include/mapnik/svg_renderer.hpp
-include/mapnik/text_placements.hpp
-include/mapnik/text_placements_simple.hpp
+include/mapnik/symbolizer.hpp
+include/mapnik/symbolizer_helpers.hpp
+include/mapnik/text_path.hpp
+include/mapnik/text_placements/base.hpp
+include/mapnik/text_placements/dummy.hpp
+include/mapnik/text_placements/list.hpp
+include/mapnik/text_placements/registry.hpp
+include/mapnik/text_placements/simple.hpp
+include/mapnik/text_properties.hpp
+include/mapnik/text_symbolizer.hpp
+include/mapnik/tiff_io.hpp
include/mapnik/timer.hpp
+include/mapnik/transform_expression.hpp
+include/mapnik/transform_expression_grammar.hpp
+include/mapnik/transform_processor.hpp
+include/mapnik/unicode.hpp
+include/mapnik/util/container_adapter.hpp
+include/mapnik/util/conversions.hpp
+include/mapnik/util/dasharray_parser.hpp
+include/mapnik/util/deepcopy.hpp
+include/mapnik/util/geometry_svg_generator.hpp
+include/mapnik/util/geometry_to_ds_type.hpp
+include/mapnik/util/geometry_to_svg.hpp
+include/mapnik/util/geometry_to_wkb.hpp
+include/mapnik/util/geometry_to_wkt.hpp
+include/mapnik/util/geometry_wkt_generator.hpp
+include/mapnik/util/vertex_iterator.hpp
+include/mapnik/utils.hpp
+include/mapnik/value.hpp
include/mapnik/value_error.hpp
+include/mapnik/version.hpp
+include/mapnik/vertex.hpp
+include/mapnik/vertex_converters.hpp
+include/mapnik/vertex_vector.hpp
include/mapnik/warp.hpp
+include/mapnik/wkb.hpp
include/mapnik/wkt/wkt_factory.hpp
include/mapnik/wkt/wkt_grammar.hpp
+include/mapnik/xml_loader.hpp
+include/mapnik/xml_node.hpp
+include/mapnik/xml_tree.hpp
lib/libmapnik.so
lib/libmapnik.so.2
+lib/libmapnik.so.2.1
+%%CSV%%lib/mapnik/input/csv.input
%%GDAL%%lib/mapnik/input/gdal.input
+lib/mapnik/input/geojson.input
+%%GEOS%%lib/mapnik/input/geos.input
%%OGR%%lib/mapnik/input/ogr.input
%%OSM%%lib/mapnik/input/osm.input
%%POSTGIS%%lib/mapnik/input/postgis.input
+lib/mapnik/input/python.input
lib/mapnik/input/raster.input
lib/mapnik/input/shape.input
%%SQLITE%%lib/mapnik/input/sqlite.input
@@ -188,7 +237,11 @@ lib/mapnik/fonts/DejaVuSansMono.ttf
@dirrm lib/mapnik/input
@dirrm lib/mapnik/fonts
@dirrm lib/mapnik
+@dirrm include/mapnik/formatting
@dirrm include/mapnik/grid
+@dirrm include/mapnik/json
@dirrm include/mapnik/svg
+@dirrm include/mapnik/text_placements
+@dirrm include/mapnik/util
@dirrm include/mapnik/wkt
@dirrm include/mapnik