aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapserver/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-12 15:09:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-12 15:09:21 +0000
commit2dbf892c19a9a6eb7adf9a50db2bdbdcef5c72d0 (patch)
tree61e7c0a106b5eff1819e334f66c6d7994b0e5889 /graphics/mapserver/Makefile
parent5125ba17546ffbc9b0bd1f61177310e87cf741b9 (diff)
Notes
Diffstat (limited to 'graphics/mapserver/Makefile')
-rw-r--r--graphics/mapserver/Makefile40
1 files changed, 33 insertions, 7 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 28fb876e6651..a311c80a727f 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mapserver
PORTVERSION= 4.0.2
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= graphics www misc
MASTER_SITES= http://cvs.gis.umn.edu/dist/
@@ -22,9 +22,23 @@ CONFIGURE_ARGS= --enable-runpath \
--with-gd=${LOCALBASE} \
--with-proj=${LOCALBASE}
+OPTIONS= TIFF "Support for TIFF (but not GeoTIFF) files" off \
+ MING "Support for Macromedia Flash output" off \
+ PDF "Support for PDF output via pdflib" off \
+ GDAL "Support for a number of input raster formats" off \
+ POSTGRESQL "Support for PostgreSQL" off \
+ PHP "Support for MapScript/PHP" off \
+ WMS "Support for web map service server and client" off \
+ WFS "Support for web feature service" off \
+ DEBUG "Enable debugging output" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_TIFF)
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --with-tiff=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-tiff
.endif
.if defined(WITH_MING)
@@ -33,18 +47,25 @@ CONFIGURE_ARGS+= --with-ming=${LOCALBASE}
.endif
.if defined(WITH_PDF)
-LIB_DEPENDS+= pdf.6:${PORTSDIR}/graphics/pdflib
+LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
.endif
.if defined(WITH_WMS)
-LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --wmsclient
+WITH_CURL= YES
+CONFIGURE_ARGS+= --with-wms --with-wmsclient
+.endif
+
+.if defined(WITH_WFS)
+WITH_CURL= YES
+WITH_GDAL= YES
+CONFIGURE_ARGS+= --with-wfs --with-wfsclient
.endif
.if defined(WITH_GDAL)
-LIB_DEPENDS+= gdal.1.1:${PORTSDIR}/graphics/gdal
-CONFIGURE_ARGS+= --with-gdal=${LOCALBASE}
+BUILD_DEPENDS+= gdal-config:${PORTSDIR}/graphics/gdal
+CONFIGURE_ARGS+= --with-gdal=${LOCALBASE}/bin/gdal-config \
+ --with-ogr=${LOCALBASE}/bin/gdal-config
.endif
.if defined(WITH_POSTGRESQL)
@@ -58,6 +79,11 @@ BUILD_DEPENDS+= mod_php4:${PORTSDIR}/www/mod_php4:
CONFIGURE_ARGS+= --with-php=${LOCALBASE}
.endif
+.if defined(WITH_CURL)
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --with-curl=${LOCALBASE}
+.endif
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -70,4 +96,4 @@ do-install:
.endfor
${INSTALL_SCRIPT} ${WRKSRC}/shp2mysql.pl ${LOCALBASE}/bin/shp2mysql
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>