aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapserver
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-11-12 01:54:43 +0000
committerWen Heping <wen@FreeBSD.org>2010-11-12 01:54:43 +0000
commit146bade235b2e4b9de0087a9a3d760928675b607 (patch)
tree05c289ea15973e6ecd48f7bc831b6cc87ae168c2 /graphics/mapserver
parent2bca0228ef9d510a540ea0a16bfe0a1add700477 (diff)
downloadports-146bade235b2e4b9de0087a9a3d760928675b607.tar.gz
ports-146bade235b2e4b9de0087a9a3d760928675b607.zip
Notes
Diffstat (limited to 'graphics/mapserver')
-rw-r--r--graphics/mapserver/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 8a4a76f77ee0..cb9d844c0ef2 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mapserver
PORTVERSION= 5.6.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics www geography
MASTER_SITES= http://download.osgeo.org/mapserver/
@@ -26,10 +26,11 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS= AGG "Support for AGG image rendering (req: FreeType)" off \
TIFF "Support for TIFF (but not GeoTIFF) files" off \
- MING "Support for Macromedia Flash output" off \
PDF "Support for PDF output via pdflib" off \
GDAL "Support for a number of input raster formats" off \
GEOS "Use GEOS engine where possible" off \
+ MING "Support for Macromedia Flash output" off \
+ MYGIS "Support for MyGIS" off \
POSTGIS "Support for PostGIS" off \
PHP "Support for MapScript/PHP" off \
PERL "Support for MapScript/PERL" off \
@@ -90,6 +91,11 @@ LIB_DEPENDS+= geos.0:${PORTSDIR}/graphics/geos
CONFIGURE_ARGS+= --with-geos=${LOCALBASE}/bin/geos-config
.endif
+.if defined(WITH_MYGIS)
+USE_MYSQL= YES
+CONFIGURE_ARGS+= --with-mygis=${LOCALBASE}/bin/mysql_config
+.endif
+
.if defined(WITH_POSTGIS)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpgport.a:${PORTSDIR}/databases/postgresql82-server
CONFIGURE_ARGS+= --with-postgis=${LOCALBASE}/bin/pg_config
@@ -146,6 +152,12 @@ CONFIGURE_ARGS+= --enable-debug
PROG_FILES= legend scalebar shp2img shp2pdf shptree shptreetst shptreevis sortshp
+post-patch:
+.if defined(WITH_MING)
+ ${REINPLACE_CMD} -e 's#with_ming/include#with_ming/include/ming#g' \
+ ${WRKSRC}/configure
+.endif
+
post-build:
.if defined(WITH_PERL)
(cd ${WRKSRC}/mapscript/perl && ${PERL5} Makefile.PL && make)