aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapserver
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-05-18 08:29:34 +0000
committerWen Heping <wen@FreeBSD.org>2011-05-18 08:29:34 +0000
commitc008736b194a16e02efa1452c4cc5a134f409456 (patch)
tree8f1a22cea399d15059b7a9b219b51c7facb489e2 /graphics/mapserver
parentb0cf11b5677ae92c508c406f3ac61ed15a7e0175 (diff)
downloadports-c008736b194a16e02efa1452c4cc5a134f409456.tar.gz
ports-c008736b194a16e02efa1452c4cc5a134f409456.zip
Notes
Diffstat (limited to 'graphics/mapserver')
-rw-r--r--graphics/mapserver/Makefile22
-rw-r--r--graphics/mapserver/distinfo4
-rw-r--r--graphics/mapserver/files/patch-mapunion.c29
-rw-r--r--graphics/mapserver/pkg-plist1
4 files changed, 44 insertions, 12 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 7c2adbb6fbe0..207475b40d7c 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mapserver
-PORTVERSION= 5.6.6
-PORTREVISION= 3
+PORTVERSION= 6.0.0
CATEGORIES= graphics www geography
MASTER_SITES= http://download.osgeo.org/mapserver/
@@ -15,20 +14,26 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= System for developing web-based GIS applications
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
- proj.6:${PORTSDIR}/graphics/proj
+ proj.6:${PORTSDIR}/graphics/proj \
+ png.6:${PORTSDIR}/graphics/png \
+ jpeg.11:${PORTSDIR}/graphics/jpeg \
+ gif.5:${PORTSDIR}/graphics/giflib
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-runpath \
--with-gd=${LOCALBASE} \
+ --with-png=${LOCALBASE} \
+ --with-jpeg=${LOCALBASE} \
+ --with-gif=${LOCALBASE} \
--with-proj=${LOCALBASE}
MAKE_JOBS_UNSAFE= yes
OPTIONS= AGG "Support for AGG image rendering (req: FreeType)" off \
TIFF "Support for TIFF (but not GeoTIFF) files" off \
PDF "Support for PDF output via pdflib" off \
- GDAL "Support for a number of input raster formats" off \
- GEOS "Use GEOS engine where possible" off \
+ GDAL "Support for a number of input raster formats" on \
+ GEOS "Use GEOS engine where possible" on \
MING "Support for Macromedia Flash output" off \
MYGIS "Support for MyGIS" off \
POSTGIS "Support for PostGIS" off \
@@ -64,7 +69,6 @@ CONFIGURE_ARGS+= --with-ming=${LOCALBASE}
.if defined(WITH_PDF)
LIB_DEPENDS+= pdf.8:${PORTSDIR}/print/pdflib \
- png.6:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE} --with-tiff=${LOCALBASE} --with-png=${LOCALBASE}
.endif
@@ -80,13 +84,13 @@ WITH_GDAL= YES
CONFIGURE_ARGS+= --with-wfs --with-wfsclient
.endif
-.if defined(WITH_GDAL)
+.if !defined(WITHOUT_GDAL)
LIB_DEPENDS+= gdal.16:${PORTSDIR}/graphics/gdal
CONFIGURE_ARGS+= --with-gdal=${LOCALBASE}/bin/gdal-config \
--with-ogr=${LOCALBASE}/bin/gdal-config
.endif
-.if defined(WITH_GEOS)
+.if !defined(WITHOUT_GEOS)
LIB_DEPENDS+= geos.0:${PORTSDIR}/graphics/geos
CONFIGURE_ARGS+= --with-geos=${LOCALBASE}/bin/geos-config
.endif
@@ -156,7 +160,7 @@ CONFIGURE_ARGS+= --with-fastcgi=${LOCALBASE}
CONFIGURE_ARGS+= --enable-debug
.endif
-PROG_FILES= legend scalebar shp2img shp2pdf shptree shptreetst shptreevis sortshp
+PROG_FILES= legend scalebar shp2img shptree shptreetst shptreevis sortshp
post-patch:
.if defined(WITH_MING)
diff --git a/graphics/mapserver/distinfo b/graphics/mapserver/distinfo
index 68e2ee78c4cf..f9f15719a085 100644
--- a/graphics/mapserver/distinfo
+++ b/graphics/mapserver/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mapserver-5.6.6.tar.gz) = e5d00321456791cebcbf0b0cb3fa1b69c5cd8bfa8d6003ad05480682465684f6
-SIZE (mapserver-5.6.6.tar.gz) = 2326652
+SHA256 (mapserver-6.0.0.tar.gz) = 92709333665c4784f69b18d1a8e78dd80f87a66b5d490fd0e49ef2ba616bd9af
+SIZE (mapserver-6.0.0.tar.gz) = 2435310
diff --git a/graphics/mapserver/files/patch-mapunion.c b/graphics/mapserver/files/patch-mapunion.c
new file mode 100644
index 000000000000..2c95347fbcc6
--- /dev/null
+++ b/graphics/mapserver/files/patch-mapunion.c
@@ -0,0 +1,29 @@
+--- mapunion.c.orig 2011-05-17 10:23:51.000000000 +0800
++++ mapunion.c 2011-05-17 10:24:57.000000000 +0800
+@@ -311,7 +311,7 @@
+ {
+ /* get items requested by the union layer plus the required items */
+ msLayerSetProcessingKey(srclayer, "ITEMS", itemlist);
+- if (msLayerWhichItems(srclayer, TRUE, NULL) != MS_SUCCESS)
++ if (msLayerWhichItems(srclayer, MS_TRUE, NULL) != MS_SUCCESS)
+ {
+ msFree(itemlist);
+ return MS_FAILURE;
+@@ -320,7 +320,7 @@
+ else
+ {
+ /* get only the required items */
+- if (msLayerWhichItems(srclayer, FALSE, NULL) != MS_SUCCESS)
++ if (msLayerWhichItems(srclayer, MS_FALSE, NULL) != MS_SUCCESS)
+ return MS_FAILURE;
+ }
+ }
+@@ -349,7 +349,7 @@
+ msUnionLayerFreeExpressionTokens(srclayer);
+
+ /* get only the required items */
+- if (msLayerWhichItems(srclayer, FALSE, NULL) != MS_SUCCESS)
++ if (msLayerWhichItems(srclayer, MS_FALSE, NULL) != MS_SUCCESS)
+ return MS_FAILURE;
+ }
+
diff --git a/graphics/mapserver/pkg-plist b/graphics/mapserver/pkg-plist
index 621958b56ac8..69586272fec8 100644
--- a/graphics/mapserver/pkg-plist
+++ b/graphics/mapserver/pkg-plist
@@ -2,7 +2,6 @@ bin/legend
bin/scalebar
bin/shp2img
bin/shp2mysql
-bin/shp2pdf
bin/shptree
bin/shptreetst
bin/shptreevis