aboutsummaryrefslogtreecommitdiff
path: root/graphics/mapyrus/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-04-28 03:16:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-04-28 03:16:02 +0000
commitfb3af5ae69c561a5702cce2120f31561c7080f42 (patch)
tree2eb22c1fdc464848518c159e17767e012ced7367 /graphics/mapyrus/Makefile
parent0fc166cd4d8eee86fdaa6b41a4c11abeb4fde2e7 (diff)
Notes
Diffstat (limited to 'graphics/mapyrus/Makefile')
-rw-r--r--graphics/mapyrus/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/graphics/mapyrus/Makefile b/graphics/mapyrus/Makefile
new file mode 100644
index 000000000000..2730b98452ec
--- /dev/null
+++ b/graphics/mapyrus/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: mapyrus
+# Date created: 2006-04-25
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mapyrus
+PORTVERSION= 0.606
+CATEGORIES= graphics print java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= nivit@email.it
+COMMENT= A software for creating plots of points, lines, etc
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+USE_JAVA= yes
+USE_ZIP= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+SUB_FILES= ${PORTNAME} pkg-message
+SUB_LIST= JAVA=${JAVA} DATADIR=${DATADIR} MAPYRUSJAR=${MAPYRUSJAR}
+
+MAPYRUSJAR= ${PORTNAME}.jar
+MAPYRUSDOCS= ${PORTNAME}.pdf
+
+FIND_DATA= -type f -not \( -name "copying" -or -name "*.tex" \)
+FIND_HERE= userdoc
+
+.if defined(WITH_EXAMPLES)
+PLIST_SUB= PORTEXAMPLES=""
+.else
+PLIST_SUB= PORTEXAMPLES="@comment "
+.endif
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKDIR} && ${INSTALL_DATA} ${MAPYRUSJAR} ${DATADIR}/${MAPYRUSJAR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKDIR} && ${INSTALL_DATA} ${MAPYRUSDOCS} ${DOCSDIR}/
+.endif
+.if defined(WITH_EXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKDIR} && ${FIND} ${FIND_HERE} ${FIND_DATA} -exec ${INSTALL_DATA} {} ${EXAMPLESDIR} \;
+.endif
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>