aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-gallium-va/Makefile
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-12-03 20:55:32 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-12-03 20:55:32 +0000
commit450f410688e70e8702b8a1e9bbcaf3f32a7639dd (patch)
treeebeb185033e075e1c9847a01feafedb1d40da974 /graphics/mesa-gallium-va/Makefile
parentfee50c0a2814ba8b395730bbf8b7a2243e2c5d5c (diff)
downloadports-450f410688e70e8702b8a1e9bbcaf3f32a7639dd.tar.gz
ports-450f410688e70e8702b8a1e9bbcaf3f32a7639dd.zip
Notes
Diffstat (limited to 'graphics/mesa-gallium-va/Makefile')
-rw-r--r--graphics/mesa-gallium-va/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/graphics/mesa-gallium-va/Makefile b/graphics/mesa-gallium-va/Makefile
index 421ebec15e4d..0b77d722c419 100644
--- a/graphics/mesa-gallium-va/Makefile
+++ b/graphics/mesa-gallium-va/Makefile
@@ -7,12 +7,14 @@ CATEGORIES= graphics
COMMENT= Mesa Gallium VAAPI drivers
-USES= xorg
-USE_XORG= xcb xfixes xrandr
-
LIB_DEPENDS= libva.so:multimedia/libva \
libzstd.so:archivers/zstd
-BUILD_DEPENDS= wayland-protocols>=1.8:graphics/wayland-protocols
+
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT= X11
+X11_DESC= Enable X11 support
+X11_USES= xorg
+X11_USE= xorg=xorgproto,x11,xcb,xdamage,xext,xfixes,xshmfence,xxf86vm,xrandr
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
@@ -29,17 +31,25 @@ MESON_ARGS+= -Ddri-drivers="" \
-Dgallium-opencl=disabled \
-Dgallium-xvmc=disabled \
-Dgallium-nine=false \
- -Degl=disabled \
-Dgbm=disabled \
+ -Dgles1=disabled \
-Dgles2=disabled \
+ -Dosmesa=none \
-Dglx=disabled \
- -Dopengl=false \
- -Dshared-glapi=disabled \
- -Dosmesa=none
+ -Ddri3=disabled
-LDFLAGS_i386= -Wl,-znotext
+LDFLAGS_i386= -Wl,-znotext
MESON_ARGS+= -Dgallium-va=enabled
+.if ${PORT_OPTIONS:MX11}
+MESON_ARGS+= -Dplatforms="x11"
+.else
+MESON_ARGS+= -Dglx=disabled \
+ -Degl=disabled \
+ -Dopengl=false \
+ -Dshared-glapi=disabled
+.endif
+
.include "${MASTERDIR}/Makefile.targets"
.include <bsd.port.post.mk>