aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-gallium-vdpau
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-12-03 20:55:32 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-12-03 20:55:32 +0000
commit450f410688e70e8702b8a1e9bbcaf3f32a7639dd (patch)
treeebeb185033e075e1c9847a01feafedb1d40da974 /graphics/mesa-gallium-vdpau
parentfee50c0a2814ba8b395730bbf8b7a2243e2c5d5c (diff)
downloadports-450f410688e70e8702b8a1e9bbcaf3f32a7639dd.tar.gz
ports-450f410688e70e8702b8a1e9bbcaf3f32a7639dd.zip
Notes
Diffstat (limited to 'graphics/mesa-gallium-vdpau')
-rw-r--r--graphics/mesa-gallium-vdpau/Makefile29
-rw-r--r--graphics/mesa-gallium-vdpau/pkg-plist23
2 files changed, 42 insertions, 10 deletions
diff --git a/graphics/mesa-gallium-vdpau/Makefile b/graphics/mesa-gallium-vdpau/Makefile
index 661f78b22f1c..e713adb06690 100644
--- a/graphics/mesa-gallium-vdpau/Makefile
+++ b/graphics/mesa-gallium-vdpau/Makefile
@@ -2,18 +2,19 @@
PORTNAME= mesa-gallium-vdpau
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 2
CATEGORIES= graphics
COMMENT= Mesa Gallium VDPAU drivers
-USES= xorg
-USE_XORG= xcb xfixes xrandr
-
LIB_DEPENDS= libva.so:multimedia/libva \
libvdpau.so:multimedia/libvdpau \
libzstd.so:archivers/zstd
-BUILD_DEPENDS= wayland-protocols>=1.8:graphics/wayland-protocols
+
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT= X11
+X11_DESC= Enable X11 support
+X11_USES= xorg
+X11_USE= xorg=xorgproto,x11,xcb,xdamage,xext,xfixes,xshmfence,xxf86vm,xrandr
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
@@ -24,23 +25,31 @@ ONLY_FOR_ARCHS_REASON= Used only by amd/radeon hardware
MESON_ARGS+= -Ddri-drivers="" \
-Dgallium-drivers="r300,r600,radeonsi" \
-Dvulkan-drivers="" \
- -Dgallium-va=disabled \
+ -Dgallium-vdpau=disabled \
-Dgallium-omx=disabled \
-Dgallium-xa=disabled \
-Dgallium-opencl=disabled \
-Dgallium-xvmc=disabled \
-Dgallium-nine=false \
- -Degl=disabled \
-Dgbm=disabled \
+ -Dgles1=disabled \
-Dgles2=disabled \
+ -Dosmesa=none \
-Dglx=disabled \
- -Dopengl=false \
- -Dshared-glapi=disabled \
- -Dosmesa=none
+ -Ddri3=disabled
LDFLAGS_i386= -Wl,-znotext
MESON_ARGS+= -Dgallium-vdpau=enabled
+.if ${PORT_OPTIONS:MX11}
+MESON_ARGS+= -Dplatforms="x11"
+.else
+MESON_ARGS+= -Dglx=disabled \
+ -Degl=disabled \
+ -Dopengl=false \
+ -Dshared-glapi=disabled
+.endif
+
.include "${MASTERDIR}/Makefile.targets"
.include <bsd.port.post.mk>
diff --git a/graphics/mesa-gallium-vdpau/pkg-plist b/graphics/mesa-gallium-vdpau/pkg-plist
index ed12f5810083..7b0d81e78957 100644
--- a/graphics/mesa-gallium-vdpau/pkg-plist
+++ b/graphics/mesa-gallium-vdpau/pkg-plist
@@ -1,3 +1,24 @@
+@comment include/EGL/egl.h
+@comment include/EGL/eglext.h
+@comment include/EGL/eglextchromium.h
+@comment include/EGL/eglmesaext.h
+@comment include/EGL/eglplatform.h
+@comment include/GL/gl.h
+@comment include/GL/glcorearb.h
+@comment include/GL/glext.h
+@comment include/GL/internal/dri_interface.h
+@comment include/KHR/khrplatform.h
+@comment lib/dri/r300_dri.so
+@comment lib/dri/r600_dri.so
+@comment lib/dri/r600_drv_video.so
+@comment lib/dri/radeonsi_dri.so
+@comment lib/dri/radeonsi_drv_video.so
+@comment lib/libEGL.so
+@comment lib/libEGL.so.1
+@comment lib/libEGL.so.1.0.0
+@comment lib/libglapi.so
+@comment lib/libglapi.so.0
+@comment lib/libglapi.so.0.0.0
lib/vdpau/libvdpau_r300.so
lib/vdpau/libvdpau_r300.so.1
lib/vdpau/libvdpau_r300.so.1.0
@@ -10,4 +31,6 @@ lib/vdpau/libvdpau_radeonsi.so
lib/vdpau/libvdpau_radeonsi.so.1
lib/vdpau/libvdpau_radeonsi.so.1.0
lib/vdpau/libvdpau_radeonsi.so.1.0.0
+@comment libdata/pkgconfig/dri.pc
+@comment libdata/pkgconfig/egl.pc
@comment share/drirc.d/00-mesa-defaults.conf