aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-gallium-vdpau
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-10-12 08:30:54 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-10-12 08:30:54 +0000
commit57ce68a0c0cab56c3d08120e6f55c11a8c248f06 (patch)
tree88e8ad4aa5aa680ec7c0bbc956676c47044a89fc /graphics/mesa-gallium-vdpau
parent3870ad6c4bb281c7abf1b06de72b9adfd658d96f (diff)
downloadports-57ce68a0c0cab56c3d08120e6f55c11a8c248f06.tar.gz
ports-57ce68a0c0cab56c3d08120e6f55c11a8c248f06.zip
Notes
Diffstat (limited to 'graphics/mesa-gallium-vdpau')
-rw-r--r--graphics/mesa-gallium-vdpau/Makefile45
-rw-r--r--graphics/mesa-gallium-vdpau/pkg-descr9
-rw-r--r--graphics/mesa-gallium-vdpau/pkg-plist13
3 files changed, 67 insertions, 0 deletions
diff --git a/graphics/mesa-gallium-vdpau/Makefile b/graphics/mesa-gallium-vdpau/Makefile
new file mode 100644
index 000000000000..a80b4fd19377
--- /dev/null
+++ b/graphics/mesa-gallium-vdpau/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= mesa-gallium-vdpau
+PORTVERSION= ${MESAVERSION}
+CATEGORIES= graphics
+
+COMMENT= Mesa Gallium VDPAU drivers
+
+USES= xorg
+USE_XORG= xcb xfixes xrandr
+
+LIB_DEPENDS= libva.so:multimedia/libva \
+ libvdpau.so:multimedia/libvdpau \
+ libzstd.so:archivers/zstd
+BUILD_DEPENDS= wayland-protocols>=1.8:graphics/wayland-protocols
+
+.include <bsd.port.options.mk>
+.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
+
+ONLY_FOR_ARCHS= i386 amd64 aarch64 powerpc64
+ONLY_FOR_ARCHS_REASON= Used only by amd/radeon hardware
+
+MESON_ARGS+= -Ddri-drivers="" \
+ -Dgallium-drivers="r300,r600,radeonsi" \
+ -Dvulkan-drivers="" \
+ -Dgallium-va=disabled \
+ -Dgallium-omx=disabled \
+ -Dgallium-xa=disabled \
+ -Dgallium-opencl=disabled \
+ -Dgallium-xvmc=disabled \
+ -Dgallium-nine=false \
+ -Degl=disabled \
+ -Dgbm=disabled \
+ -Dgles2=disabled \
+ -Dglx=disabled \
+ -Dopengl=false \
+ -Dshared-glapi=disabled \
+ -Dosmesa=none
+
+LDFLAGS_i386= -Wl,-znotext
+
+MESON_ARGS+= -Dgallium-vdpau=enabled
+
+.include "${MASTERDIR}/Makefile.targets"
+.include <bsd.port.post.mk>
diff --git a/graphics/mesa-gallium-vdpau/pkg-descr b/graphics/mesa-gallium-vdpau/pkg-descr
new file mode 100644
index 000000000000..31a2390ed7c1
--- /dev/null
+++ b/graphics/mesa-gallium-vdpau/pkg-descr
@@ -0,0 +1,9 @@
+Mesa is a 3-D graphics library with an API which is very similar to that
+of OpenGL*. To the extent that Mesa utilizes the OpenGL command syntax or
+state machine, it is being used with authorization from Silicon Graphics,
+Inc. However, the author makes no claim that Mesa is in any way a
+compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
+
+VDPAU is a Gallium driver for video decoding on AMD hardware.
+
+WWW: https://www.mesa3d.org/
diff --git a/graphics/mesa-gallium-vdpau/pkg-plist b/graphics/mesa-gallium-vdpau/pkg-plist
new file mode 100644
index 000000000000..ed12f5810083
--- /dev/null
+++ b/graphics/mesa-gallium-vdpau/pkg-plist
@@ -0,0 +1,13 @@
+lib/vdpau/libvdpau_r300.so
+lib/vdpau/libvdpau_r300.so.1
+lib/vdpau/libvdpau_r300.so.1.0
+lib/vdpau/libvdpau_r300.so.1.0.0
+lib/vdpau/libvdpau_r600.so
+lib/vdpau/libvdpau_r600.so.1
+lib/vdpau/libvdpau_r600.so.1.0
+lib/vdpau/libvdpau_r600.so.1.0.0
+lib/vdpau/libvdpau_radeonsi.so
+lib/vdpau/libvdpau_radeonsi.so.1
+lib/vdpau/libvdpau_radeonsi.so.1.0
+lib/vdpau/libvdpau_radeonsi.so.1.0.0
+@comment share/drirc.d/00-mesa-defaults.conf