aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesagl/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-02-02 20:07:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-02-02 20:07:23 +0000
commit1a2a93728347cdab7509098a2d2643dc3dc23563 (patch)
tree21c83c41a4dfb6103661c97ec4c59cdb4bec3b0e /graphics/mesagl/Makefile
parentdb52cf2298e6395786365827f15f0b362e3cf520 (diff)
downloadports-1a2a93728347cdab7509098a2d2643dc3dc23563.tar.gz
ports-1a2a93728347cdab7509098a2d2643dc3dc23563.zip
Notes
Diffstat (limited to 'graphics/mesagl/Makefile')
-rw-r--r--graphics/mesagl/Makefile54
1 files changed, 0 insertions, 54 deletions
diff --git a/graphics/mesagl/Makefile b/graphics/mesagl/Makefile
deleted file mode 100644
index 0dfe0ab951fc..000000000000
--- a/graphics/mesagl/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-# New ports collection makefile for: Mesa
-# Date created: Tue Feb 7 12:02:49 1995
-# Whom: hsu
-#
-# $FreeBSD$
-#
-
-PORTNAME= Mesa
-PORTVERSION= 5.0.2
-CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- ftp://ftp.fu-berlin.de/pub/unix/X11/graphics/Mesa/
-MASTER_SITE_SUBDIR= mesa3d
-DISTFILES= MesaLib-${PORTVERSION}${EXTRACT_SUFX} \
- MesaDemos-${PORTVERSION}${EXTRACT_SUFX}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A graphics library similar to SGI's OpenGL
-
-CONFLICTS= XFree86-libraries-[4-9]* xorg-libraries-[6-9]*
-
-USE_BZIP2= yes
-USE_LDCONFIG= yes
-
-.if defined(WANT_GGI)
-LIB_DEPENDS= ggi.2:${PORTSDIR}/graphics/libggi
-CONFIGURE_ARGS+=--with-ggi=${LOCALBASE}
-.endif
-
-USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-CONFIGURE_ENV+= GLVER="${GLVER}" LIBS="-lm"
-SUB_GL= src si-glu src-glu
-INCLUDE_GL= include
-GLVER= 14
-MAKE_ENV+= SUB_GL="${SUB_GL}" \
- INCLUDE_GL=${INCLUDE_GL}
-
-.include <bsd.port.pre.mk>
-
-.if ${X_WINDOW_SYSTEM:L} != xfree86-3
-IGNORE= is unnecessary because libGL and libGLU come with XFree86 4.0 and higher
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-
-post-install:
-.for lib in GL GLU
- @${LN} -sf ${PREFIX}/lib/lib${lib}.so ${PREFIX}/lib/libMesa${lib}.so
-.endfor
-
-.include <bsd.port.post.mk>