aboutsummaryrefslogtreecommitdiff
path: root/graphics/meshviewer
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-05-20 03:27:54 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-05-20 03:27:54 +0000
commitecb94f19a4c9a162207547b5e07aa2557152117b (patch)
treed98f99b8e391a85e1cf76d0f05b088ea89ffbd5f /graphics/meshviewer
parentcda040dcec16ccd2073a02c1abf112a7a3e887f0 (diff)
Notes
Diffstat (limited to 'graphics/meshviewer')
-rw-r--r--graphics/meshviewer/Makefile17
-rw-r--r--graphics/meshviewer/files/patch-qt4__glmesh.cpp11
-rw-r--r--graphics/meshviewer/files/patch-qt4__glmesh_common.cpp11
3 files changed, 30 insertions, 9 deletions
diff --git a/graphics/meshviewer/Makefile b/graphics/meshviewer/Makefile
index 45e53ecad93b..8e04c2995a3a 100644
--- a/graphics/meshviewer/Makefile
+++ b/graphics/meshviewer/Makefile
@@ -1,4 +1,3 @@
-# ex:ts=8
# Ports collection makefile for: meshviewer
# Date created: Jun 10, 2002
# Whom: ijliao
@@ -7,7 +6,7 @@
PORTNAME= meshviewer
PORTVERSION= 0.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/mview/mview/${PORTVERSION}
DISTNAME= mview-src-${PORTVERSION}
@@ -17,23 +16,23 @@ COMMENT= Mesh Viewer
WRKSRC= ${WRKDIR}/mview-${PORTVERSION}
+USE_GL= glu
USE_QT_VER= 4
QT_COMPONENTS= corelib gui opengl moc_build
USE_GMAKE= yes
-LDFLAGS+= ${PTHREAD_LIBS}
+CXXFLAGS+= -I. -Imesh -Imathvector \
+ `pkg-config --cflags QtOpenGL glu`
+LDFLAGS+= ${PTHREAD_LIBS} \
+ `pkg-config --libs QtOpenGL glu`
MAKE_ARGS= QTDIR="${QT_PREFIX}" CC="${CXX}" MOC="${MOC}" \
- CPPFLAGS="${CPPFLAGS}" FLAGS="${CXXFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
LIBPATH="" LIBS_QT4="${LDFLAGS}"
PORTDOCS= *
PLIST_FILES= bin/mview
-CPPFLAGS+= -I. -Imesh -Imathvector \
- `pkg-config --cflags QtOpenGL glu`
-LDFLAGS+= `pkg-config --libs QtOpenGL glu`
-
post-patch:
- @${REINPLACE_CMD} -e 's|make |$$(MAKE) |g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|make |$$(MAKE) |g' -e 's|CPPFLAGS|CXXFLAGS|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|<values.h>|<cmath>|g' ${WRKSRC}/mesh/mesh.cpp
do-install:
diff --git a/graphics/meshviewer/files/patch-qt4__glmesh.cpp b/graphics/meshviewer/files/patch-qt4__glmesh.cpp
new file mode 100644
index 000000000000..24f07ed78bc7
--- /dev/null
+++ b/graphics/meshviewer/files/patch-qt4__glmesh.cpp
@@ -0,0 +1,11 @@
+--- qt4/glmesh.cpp~ 2012-05-20 00:04:04.000000000 -0300
++++ qt4/glmesh.cpp 2012-05-20 00:04:21.000000000 -0300
+@@ -21,6 +21,8 @@
+ #include "mview.h"
+ #include "coordinates.h"
+
++#include <GL/glu.h>
++
+ // for FPS
+ unsigned long timeCounter;
+ unsigned int frameCounter;
diff --git a/graphics/meshviewer/files/patch-qt4__glmesh_common.cpp b/graphics/meshviewer/files/patch-qt4__glmesh_common.cpp
new file mode 100644
index 000000000000..16bef5058d22
--- /dev/null
+++ b/graphics/meshviewer/files/patch-qt4__glmesh_common.cpp
@@ -0,0 +1,11 @@
+--- qt4/glmesh_common.cpp~ 2012-05-20 00:04:54.000000000 -0300
++++ qt4/glmesh_common.cpp 2012-05-20 00:05:03.000000000 -0300
+@@ -10,6 +10,8 @@
+
+ #include "glmesh.h"
+
++#include <GL/glu.h>
++
+ void GLMesh::checkForTraps(const char *string, int value)
+ {
+ GLenum errorCode = glGetError();