aboutsummaryrefslogtreecommitdiff
path: root/graphics/metapixel
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-12 13:16:10 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-12 13:16:10 +0000
commit7511636551a90700c1c43e7cd3df150bb8389e6a (patch)
treed7c1e0407aa5a0d93527b636438f522929c79f02 /graphics/metapixel
parentd03cf65e4a397f08fa0a651fd1f30e35aaf544a5 (diff)
downloadports-7511636551a90700c1c43e7cd3df150bb8389e6a.tar.gz
ports-7511636551a90700c1c43e7cd3df150bb8389e6a.zip
Notes
Diffstat (limited to 'graphics/metapixel')
-rw-r--r--graphics/metapixel/Makefile16
-rw-r--r--graphics/metapixel/distinfo3
-rw-r--r--graphics/metapixel/files/patch-Makefile46
-rw-r--r--graphics/metapixel/files/patch-metapixel.c11
-rw-r--r--graphics/metapixel/files/patch-sizesort11
-rw-r--r--graphics/metapixel/pkg-descr16
-rw-r--r--graphics/metapixel/pkg-plist3
7 files changed, 66 insertions, 40 deletions
diff --git a/graphics/metapixel/Makefile b/graphics/metapixel/Makefile
index cef6446b80e5..82d9b9d3f485 100644
--- a/graphics/metapixel/Makefile
+++ b/graphics/metapixel/Makefile
@@ -5,13 +5,13 @@
# $FreeBSD$
PORTNAME= metapixel
-PORTVERSION= 0.7
-PORTREVISION= 3
+PORTVERSION= 0.8
CATEGORIES= graphics
-MASTER_SITES= http://www.complang.tuwien.ac.at/~schani/metapixel/
+MASTER_SITES= http://www.complang.tuwien.ac.at/~schani/metapixel/ \
+ http://dragon.roe.ch/mirrors/distfiles/metapixel/
MAINTAINER= daniel@roe.ch
-COMMENT= "Metapixel is a program for generating photomosaics"
+COMMENT= A photomosaic generator
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
@@ -19,17 +19,21 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
USE_GETOPT_LONG=yes
USE_GMAKE= yes
USE_REINPLACE= yes
-MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I." \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
post-patch:
@${RM} ${WRKSRC}/getopt.h
@${REINPLACE_CMD} -e 's,values.h,limits.h,' ${WRKSRC}/libzoom/simple.h
@${REINPLACE_CMD} -e 's,MINSHORT,SHRT_MIN,; \
- s,MAXSHORT,SHRT_MAX,' ${WRKSRC}/libzoom/zoom.c
+ s,MAXSHORT,SHRT_MAX,' ${WRKSRC}/libzoom/zoom.c
+ @${MV} ${WRKSRC}/sizesort ${WRKSRC}/metapixel-sizesort
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/metapixel ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/metapixel-prepare ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/metapixel-convert ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/metapixel-imagesize ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/metapixel-sizesort ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/graphics/metapixel/distinfo b/graphics/metapixel/distinfo
index 78b21f5abbf6..59df9cc3587a 100644
--- a/graphics/metapixel/distinfo
+++ b/graphics/metapixel/distinfo
@@ -1 +1,2 @@
-MD5 (metapixel-0.7.tar.gz) = ffb60f432e8a4c85432f572cbd265aff
+MD5 (metapixel-0.8.tar.gz) = 882185b83a0e9c1e035a9eb8928dae9c
+SIZE (metapixel-0.8.tar.gz) = 62754
diff --git a/graphics/metapixel/files/patch-Makefile b/graphics/metapixel/files/patch-Makefile
index 0da82060c998..c67e894cbd3c 100644
--- a/graphics/metapixel/files/patch-Makefile
+++ b/graphics/metapixel/files/patch-Makefile
@@ -1,25 +1,47 @@
---- Makefile.orig Sat Jan 22 07:32:17 2000
-+++ Makefile Sun Jul 6 19:40:11 2003
-@@ -1,5 +1,3 @@
+--- Makefile.orig Thu Jan 15 20:56:02 2004
++++ Makefile Wed Feb 11 17:44:32 2004
+@@ -1,33 +1,30 @@
-PREFIX = /usr/local
-INSTALL = install
-
+-
BINDIR = $(PREFIX)/bin
-@@ -7,12 +5,12 @@
+ VERSION = 0.8
+ #DEBUG = -g
+-OPTIMIZE = -O3
++#OPTIMIZE = -O3
#PROFILE = -pg
--LDOPTS = -L/usr/X11R6/lib $(PROFILE)
--CCOPTS = -I/usr/X11R6/include -I/usr/X11R6/include/X11 -Wall -O9 $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
+-LDOPTS = -L/sw/lib -L/usr/X11R6/lib $(PROFILE) $(DEBUG)
+-CCOPTS = -I/sw/include -I/usr/X11R6/include -I/usr/X11R6/include/X11 -I. -Wall $(OPTIMIZE) $(DEBUG) $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
-CC = gcc
-+LDOPTS = ${LDFLAGS} $(PROFILE)
-+CCOPTS = ${CFLAGS} ${CPPFLAGS} -Wall $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
++LDOPTS = ${LDFLAGS} $(PROFILE) $(DEBUG)
++CCOPTS = ${CFLAGS} ${CPPFLAGS} -Wall $(DEBUG) $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
+#CC = gcc
#LIBFFM = -lffm
--OBJS = metapixel.o vector.o rwpng.o rwjpeg.o readimage.o writeimage.o getopt.o getopt1.o
-+OBJS = metapixel.o vector.o rwpng.o rwjpeg.o readimage.o writeimage.o
+-OBJS = metapixel.o vector.o rwpng.o rwjpeg.o readimage.o writeimage.o lispreader.o getopt.o getopt1.o
+-CONVERT_OBJS = convert.o lispreader.o getopt.o getopt1.o
++OBJS = metapixel.o vector.o rwpng.o rwjpeg.o readimage.o writeimage.o lispreader.o
++CONVERT_OBJS = convert.o lispreader.o
+ IMAGESIZE_OBJS = imagesize.o rwpng.o rwjpeg.o readimage.o
+
+-all : metapixel convert imagesize
++all : metapixel metapixel-convert metapixel-imagesize
+
+ metapixel : $(OBJS) libzoom/libzoom.a
+ $(CC) $(LDOPTS) -o metapixel $(OBJS) libzoom/libzoom.a -lpng -ljpeg $(LIBFFM) -lm -lz
+
+-convert : $(CONVERT_OBJS)
+- $(CC) $(LDOPTS) -o convert $(CONVERT_OBJS)
++metapixel-convert : $(CONVERT_OBJS)
++ $(CC) $(LDOPTS) -o metapixel-convert $(CONVERT_OBJS)
- all : metapixel
+-imagesize : $(IMAGESIZE_OBJS)
+- $(CC) $(LDOPTS) -o imagesize $(IMAGESIZE_OBJS) libzoom/libzoom.a -lpng -ljpeg -lm -lz
++metapixel-imagesize : $(IMAGESIZE_OBJS)
++ $(CC) $(LDOPTS) -o metapixel-imagesize $(IMAGESIZE_OBJS) libzoom/libzoom.a -lpng -ljpeg -lm -lz
+ %.o : %.c
+ $(CC) $(CCOPTS) -c $<
diff --git a/graphics/metapixel/files/patch-metapixel.c b/graphics/metapixel/files/patch-metapixel.c
deleted file mode 100644
index 644d1a7e9f40..000000000000
--- a/graphics/metapixel/files/patch-metapixel.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- metapixel.c.orig Fri May 24 03:05:45 2002
-+++ metapixel.c Fri May 24 03:06:16 2002
-@@ -1127,7 +1127,7 @@
- break;
-
- case 256 :
-- printf("metapixel " METAPIXEL_VERSION "\n"
-+ printf("metapixel \n"
- "\n"
- "Copyright (C) 1997-2000 Mark Probst\n"
- "\n"
diff --git a/graphics/metapixel/files/patch-sizesort b/graphics/metapixel/files/patch-sizesort
new file mode 100644
index 000000000000..2da5f547c9eb
--- /dev/null
+++ b/graphics/metapixel/files/patch-sizesort
@@ -0,0 +1,11 @@
+--- sizesort.orig Thu Jan 15 20:56:03 2004
++++ sizesort Wed Feb 11 17:44:32 2004
+@@ -31,7 +31,7 @@
+
+ foreach my $filename (glob("$srcdir/*")) {
+ if (-f $filename && -r $filename) {
+- my ($w, $h) = split /\s+/, `imagesize $filename`;
++ my ($w, $h) = split /\s+/, `metapixel-imagesize $filename`;
+ print "$filename $w $h\n";
+ my $dir = sprintf "$destdir/%dx%d", $w, $h;
+ `mkdir $dir` if (!-d $dir);
diff --git a/graphics/metapixel/pkg-descr b/graphics/metapixel/pkg-descr
index a84e43ef7bad..548a26be9147 100644
--- a/graphics/metapixel/pkg-descr
+++ b/graphics/metapixel/pkg-descr
@@ -1,13 +1,9 @@
-Metapixel is a program for generating photomosaics. It can
-generate classical photomosaics, in which the source image is
-viewed as a matrix of equally sized rectangles for each of which
-a matching image is substitued, as well as collage-style
-photomosaics, in which rectangular parts of the source image at
-arbitrary positions (i.e. not aligned to a matrix) are
-substituted by matching images.
+Metapixel is a photomosaic generator. It can generate classical
+photomosaics, in which the source image is viewed as a matrix
+of equally sized rectangles for each of which a matching image
+is substituted, as well as collage-style photomosaics, where
+the images are placed at arbitrary positions in the source
+image, not aligned to a matrix.
Author: Mark Propst <schani@complang.tuwien.ac.at>
WWW: http://www.complang.tuwien.ac.at/~schani/metapixel/
-
-- Tilman Linneweh
-freebsdports@arved.de
diff --git a/graphics/metapixel/pkg-plist b/graphics/metapixel/pkg-plist
index c7423f47c275..76b871c09a31 100644
--- a/graphics/metapixel/pkg-plist
+++ b/graphics/metapixel/pkg-plist
@@ -1,2 +1,5 @@
bin/metapixel
bin/metapixel-prepare
+bin/metapixel-convert
+bin/metapixel-imagesize
+bin/metapixel-sizesort