aboutsummaryrefslogtreecommitdiff
path: root/graphics/metapixel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-23 19:07:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-23 19:07:58 +0000
commitbff5acba31c26011c053860ed03dc08930757a0d (patch)
tree27ea571c503cfd3ddd4148e8b2d684e3b078cfd0 /graphics/metapixel
parent7a3bbb8698ff243242906d5d94ae4608898619e4 (diff)
downloadports-bff5acba31c26011c053860ed03dc08930757a0d.tar.gz
ports-bff5acba31c26011c053860ed03dc08930757a0d.zip
Notes
Diffstat (limited to 'graphics/metapixel')
-rw-r--r--graphics/metapixel/Makefile27
-rw-r--r--graphics/metapixel/distinfo1
-rw-r--r--graphics/metapixel/files/patch-Makefile25
-rw-r--r--graphics/metapixel/files/patch-metapixel.c11
-rw-r--r--graphics/metapixel/pkg-comment1
-rw-r--r--graphics/metapixel/pkg-descr13
-rw-r--r--graphics/metapixel/pkg-plist2
7 files changed, 80 insertions, 0 deletions
diff --git a/graphics/metapixel/Makefile b/graphics/metapixel/Makefile
new file mode 100644
index 000000000000..9c9d09865929
--- /dev/null
+++ b/graphics/metapixel/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: metapixel
+# Date created: 2002-05-23
+# Whom: Tilman Linneweh <freebsdports@arved.de>
+#
+# $FreeBSD$
+
+PORTNAME= metapixel
+PORTVERSION= 0.7
+CATEGORIES= graphics
+MASTER_SITES= http://www.complang.tuwien.ac.at/~schani/metapixel/
+
+MAINTAINER= freebsdports@arved.de
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_GMAKE= yes
+
+post-patch:
+ @${RM} ${WRKSRC}/getopt.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/metapixel ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/metapixel-prepare ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/metapixel/distinfo b/graphics/metapixel/distinfo
new file mode 100644
index 000000000000..78b21f5abbf6
--- /dev/null
+++ b/graphics/metapixel/distinfo
@@ -0,0 +1 @@
+MD5 (metapixel-0.7.tar.gz) = ffb60f432e8a4c85432f572cbd265aff
diff --git a/graphics/metapixel/files/patch-Makefile b/graphics/metapixel/files/patch-Makefile
new file mode 100644
index 000000000000..b74b1c5bafd6
--- /dev/null
+++ b/graphics/metapixel/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig Fri May 24 03:03:30 2002
++++ Makefile Fri May 24 03:04:54 2002
+@@ -1,15 +1,17 @@
+-PREFIX = /usr/local
+-INSTALL = install
++#PREFIX = /usr/local
++#INSTALL = install
+
+ BINDIR = $(PREFIX)/bin
+
+ VERSION = 0.7
+
+ #PROFILE = -pg
++CFLAGS+= -I/usr/local/include
++LDFLAGS+= -L/usr/local/lib
+
+-LDOPTS = -L/usr/X11R6/lib $(PROFILE)
+-CCOPTS = -I/usr/X11R6/include -I/usr/X11R6/include/X11 -Wall -O9 $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
+-CC = gcc
++LDOPTS = ${LDFLAGS} -L/usr/X11R6/lib $(PROFILE)
++CCOPTS = ${CFLAGS} -I/usr/X11R6/include -I/usr/X11R6/include/X11 -Wall -O9 $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
++#CC = gcc
+ #LIBFFM = -lffm
+
+ OBJS = metapixel.o vector.o rwpng.o rwjpeg.o readimage.o writeimage.o getopt.o getopt1.o
diff --git a/graphics/metapixel/files/patch-metapixel.c b/graphics/metapixel/files/patch-metapixel.c
new file mode 100644
index 000000000000..644d1a7e9f40
--- /dev/null
+++ b/graphics/metapixel/files/patch-metapixel.c
@@ -0,0 +1,11 @@
+--- metapixel.c.orig Fri May 24 03:05:45 2002
++++ metapixel.c Fri May 24 03:06:16 2002
+@@ -1127,7 +1127,7 @@
+ break;
+
+ case 256 :
+- printf("metapixel " METAPIXEL_VERSION "\n"
++ printf("metapixel \n"
+ "\n"
+ "Copyright (C) 1997-2000 Mark Probst\n"
+ "\n"
diff --git a/graphics/metapixel/pkg-comment b/graphics/metapixel/pkg-comment
new file mode 100644
index 000000000000..89f73ad335f6
--- /dev/null
+++ b/graphics/metapixel/pkg-comment
@@ -0,0 +1 @@
+Metapixel is a program for generating photomosaics
diff --git a/graphics/metapixel/pkg-descr b/graphics/metapixel/pkg-descr
new file mode 100644
index 000000000000..a84e43ef7bad
--- /dev/null
+++ b/graphics/metapixel/pkg-descr
@@ -0,0 +1,13 @@
+Metapixel is a program for generating photomosaics. It can
+generate classical photomosaics, in which the source image is
+viewed as a matrix of equally sized rectangles for each of which
+a matching image is substitued, as well as collage-style
+photomosaics, in which rectangular parts of the source image at
+arbitrary positions (i.e. not aligned to a matrix) are
+substituted by matching images.
+
+Author: Mark Propst <schani@complang.tuwien.ac.at>
+WWW: http://www.complang.tuwien.ac.at/~schani/metapixel/
+
+- Tilman Linneweh
+freebsdports@arved.de
diff --git a/graphics/metapixel/pkg-plist b/graphics/metapixel/pkg-plist
new file mode 100644
index 000000000000..c7423f47c275
--- /dev/null
+++ b/graphics/metapixel/pkg-plist
@@ -0,0 +1,2 @@
+bin/metapixel
+bin/metapixel-prepare