aboutsummaryrefslogtreecommitdiff
path: root/graphics/mhgui/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-24 23:24:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-24 23:24:51 +0000
commite5beb689031b9cd6ad8b39bd938b4f4d79140f99 (patch)
tree857dfe3805c316ab023a28e6eab963423678eece /graphics/mhgui/Makefile
parentbd18590ca43063af35dde519d1d0797e3e9d9d3f (diff)
Notes
Diffstat (limited to 'graphics/mhgui/Makefile')
-rw-r--r--graphics/mhgui/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/graphics/mhgui/Makefile b/graphics/mhgui/Makefile
index 40f4aca16ad3..77528fbe5406 100644
--- a/graphics/mhgui/Makefile
+++ b/graphics/mhgui/Makefile
@@ -12,30 +12,25 @@ COMMENT= GUI widget library for MakeHuman
LICENSE= GPLv2
-LIB_DEPENDS= animorph:${PORTSDIR}/graphics/animorph \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libanimorph.so:${PORTSDIR}/graphics/animorph \
+ libpng15.so:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= pkgconfig
+USES= pkgconfig gmake
USE_LDCONFIG= yes
USE_XORG= xi xmu ice sm
USE_GL= glut
-USE_GCC= yes # otherwise graphics/makehuman won't link
+USE_GCC= any # otherwise graphics/makehuman won't link
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e '/^libmhguidocdir =/ s|doc/|share/doc/|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|\$$(libdir)|\$$(exec_prefix)/libdata|' ${WRKSRC}/Makefile.in
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libmhguidocDATA||' ${WRKSRC}/Makefile.in
-.endif
.include <bsd.port.mk>