aboutsummaryrefslogtreecommitdiff
path: root/graphics/ming/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-08-08 00:56:28 +0000
committerSteve Wills <swills@FreeBSD.org>2011-08-08 00:56:28 +0000
commit3b8a4becc66e5c6dae63ec9d04ec9031c49802bc (patch)
tree77ebb8ae23172482c0622517eb857921d2424796 /graphics/ming/Makefile
parent49754b947cbd622c3b7672af66618b45cfb9a125 (diff)
downloadports-3b8a4becc66e5c6dae63ec9d04ec9031c49802bc.tar.gz
ports-3b8a4becc66e5c6dae63ec9d04ec9031c49802bc.zip
Notes
Diffstat (limited to 'graphics/ming/Makefile')
-rw-r--r--graphics/ming/Makefile35
1 files changed, 31 insertions, 4 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 2ed018f2f48d..9c25c6025c12 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ming
PORTVERSION= 0.4.3
+PORTREVISION?= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Releases/Ming%20${PORTVERSION}
@@ -20,11 +21,11 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
CONFLICTS= ja-ming-[0-9]*
USE_GNOME= gnomehack
+USE_GMAKE= yes
USE_BISON= build
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/ming \
- ac_cv_path_PYTHON=no
+CONFIGURE_ARGS+= --includedir=${PREFIX}/include/ming
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
@@ -35,7 +36,16 @@ CFLAGS+= ${CPPFLAGS}
DOCS= HISTORY NEWS README TODO
DOCS_UTIL= README TIPS TODO swftoperl.html
+.if defined(SLAVE_PORT)
+LIB_DEPENDS+= ming.5:${PORTSDIR}/graphics/ming
+.endif
+
+.if defined(SLAVE_PORT) && ${SLAVE_PORT}=="p5"
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.endif
+
post-install:
+.if !defined(SLAVE_PORT)
${INSTALL_SCRIPT} ${WRKSRC}/util/ming-config ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/util/cws2fws ${PREFIX}/bin
@${MKDIR} ${PREFIX}/include/ming
@@ -48,13 +58,30 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/blocks/*.h ${PREFIX}/include/ming/blocks
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for docs in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
@${MKDIR} ${DOCSDIR}/util
.for docs_utils in ${DOCS_UTIL}
@${INSTALL_DATA} ${WRKSRC}/util/${docs_utils} ${DOCSDIR}/util
.endfor
.endif
+.endif
+
+.if defined(SLAVE_PORT) && ${SLAVE_PORT}=="p5"
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/examples/*.* ${EXAMPLESDIR}
+.endif
+.endif
+
+pre-install:
+.if defined(SLAVE_PORT) && ${SLAVE_PORT}=="p5"
+ @${REINPLACE_CMD} 's/3pm/3/g' ${INSTALL_WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's/3pm/3/g' ${INSTALL_WRKSRC}/Makefile.perl
+.for m in ${MAN3}
+ ${MV} ${INSTALL_WRKSRC}/blib/man3/${m}pm ${INSTALL_WRKSRC}/blib/man3/${m}
+.endfor
+.endif
.include <bsd.port.mk>