aboutsummaryrefslogtreecommitdiff
path: root/graphics/ming
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-01-21 05:57:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-01-21 05:57:50 +0000
commit66acb9cd06907030a13dd56c90708c4cf4861f92 (patch)
tree1b86710ecc3bb60c1a702a6e49a3b7540d0959a4 /graphics/ming
parent24ebd4cbfc87f39b6d0e861ecc2b1ddf6ef5ac2e (diff)
downloadports-66acb9cd06907030a13dd56c90708c4cf4861f92.tar.gz
ports-66acb9cd06907030a13dd56c90708c4cf4861f92.zip
Notes
Diffstat (limited to 'graphics/ming')
-rw-r--r--graphics/ming/Makefile33
-rw-r--r--graphics/ming/distinfo2
-rw-r--r--graphics/ming/files/Makefile16
-rw-r--r--graphics/ming/pkg-comment2
-rw-r--r--graphics/ming/pkg-descr4
-rw-r--r--graphics/ming/pkg-plist65
6 files changed, 108 insertions, 14 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index d2b8b05798e4..d8aa33d5fe00 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.3a
+PORTVERSION= 0.0.9b
CATEGORIES= graphics
MASTER_SITES= http://www.opaque.net/ming/
EXTRACT_SUFX= .tgz
@@ -18,11 +18,40 @@ MAKE_ARGS= NOPROFILE=true
DOCS= CHANGES \
CREDITS \
- Makefile \
README \
TODO
+post-extract:
+ ${MKDIR} ${WRKSRC}/c++
+ ${CP} ${WRKSRC}/../c++_ext/ming.h ${WRKSRC}/c++/
+
+post-patch:
+ ${PERL} -i -p \
+ -e 's:"\.\./\.\./c\+\+_ext/ming\.h":<c++/ming.h>:g;' \
+ -e 's:"\.\./\.\./ming\.h":<ming.h>:g;' \
+ ${WRKSRC}/../examples/c/* \
+ ${WRKSRC}/../examples/c++/* \
+ ${WRKSRC}/../examples/common/* \
+ ${WRKSRC}/c++/ming.h
+
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ming
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${PREFIX}/share/doc/ming/
+.endfor
+ ${MKDIR} ${PREFIX}/share/examples/ming/common
+ ${INSTALL_DATA} ${WRKSRC}/../examples/common/* \
+ ${PREFIX}/share/examples/ming/common/
+ ${MKDIR} ${PREFIX}/share/examples/ming/c
+ ${INSTALL_DATA} ${WRKSRC}/../examples/c/*.c \
+ ${PREFIX}/share/examples/ming/c/
+ ${MKDIR} ${PREFIX}/share/examples/ming/c++
+ ${INSTALL_DATA} ${WRKSRC}/../examples/c++/*.cpp \
+ ${PREFIX}/share/examples/ming/c++/
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/ming/distinfo b/graphics/ming/distinfo
index 909f32315482..43e0762517f6 100644
--- a/graphics/ming/distinfo
+++ b/graphics/ming/distinfo
@@ -1 +1 @@
-MD5 (ming-0.0.3a.tgz) = befc531dae73efb4f8558278e38b1e48
+MD5 (ming-0.0.9b.tgz) = 4b3117322e0af30a19514240f1df9566
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
index 130a2a2731b9..ab2b8c4cd8d1 100644
--- a/graphics/ming/files/Makefile
+++ b/graphics/ming/files/Makefile
@@ -1,16 +1,17 @@
# $FreeBSD$
LIB= ming
-SHLIB_MAJOR?= 1
+SHLIB_MAJOR?= 2
SHLIB_MINOR?= 0
CFLAGS+= -I${.CURDIR}/actioncompiler -I${.CURDIR}/blocks -I${LOCALBASE}/include
LDADD= -lm
SRCS= blocklist.c \
displaylist.c \
+ ming.c \
movie.c \
movieclip.c \
position.c \
- shape.c \
+ shape_util.c \
actioncompiler/compile.c \
actioncompiler/compileaction.c \
actioncompiler/compiler.tab.c \
@@ -43,6 +44,7 @@ SRCS= blocklist.c \
blocks/text.c \
blocks/textfield.c
INCS= blocklist.h \
+ blocktypes.h \
displaylist.h \
fill.h \
libming.h \
@@ -50,8 +52,7 @@ INCS= blocklist.h \
movie.h \
movieclip.h \
position.h \
- shape.h \
- blocks/swf.h
+ shape_util.h
NOMAN= YES
LIBDIR= ${LOCALBASE}/lib
@@ -77,7 +78,10 @@ beforeinstall: _includeinstall
_includeinstall: pre-_includeinstall
pre-_includeinstall:
- mkdir -p ${INCDIR}/blocks
+ mkdir -p ${DESTDIR}${INCDIR}/blocks ${DESTDIR}${INCDIR}/c++
beforeinstall:
- mv ${INCDIR}/swf.h ${INCDIR}/blocks/
+ ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
+ ${.CURDIR}/blocks/swf.h ${INCDIR}/blocks/
+ ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
+ ${.CURDIR}/c++/ming.h ${INCDIR}/c++/
diff --git a/graphics/ming/pkg-comment b/graphics/ming/pkg-comment
index 7859b7a4bcf8..721346f2c5b2 100644
--- a/graphics/ming/pkg-comment
+++ b/graphics/ming/pkg-comment
@@ -1 +1 @@
-LGPL Flash (TM) movie output library with PHP, Python and Ruby interfaces
+LGPL'ed Flash 4 movie output library with many languages support
diff --git a/graphics/ming/pkg-descr b/graphics/ming/pkg-descr
index 8ddd688d6fee..f7c87c6d550e 100644
--- a/graphics/ming/pkg-descr
+++ b/graphics/ming/pkg-descr
@@ -1,5 +1,5 @@
-Ming is an LGPL Flash (TM) movie (SWF) output library with PHP, Python
-and Ruby interfaces.
+Ming is an LGPL'ed Flash 4 (TM) movie (SWF) output library with PHP,
+Python, Ruby, Perl5, C and C++ interfaces.
Author: Opaque Industries <dave@opaque.net>
WWW: http://www.opaque.net/ming/
diff --git a/graphics/ming/pkg-plist b/graphics/ming/pkg-plist
index d2cffe3faf2f..0928a3fd1d5f 100644
--- a/graphics/ming/pkg-plist
+++ b/graphics/ming/pkg-plist
@@ -1,4 +1,5 @@
include/ming/blocklist.h
+include/ming/blocktypes.h
include/ming/displaylist.h
include/ming/fill.h
include/ming/libming.h
@@ -6,10 +7,70 @@ include/ming/ming.h
include/ming/movie.h
include/ming/movieclip.h
include/ming/position.h
-include/ming/shape.h
+include/ming/shape_util.h
include/ming/blocks/swf.h
+include/ming/c++/ming.h
@dirrm include/ming/blocks
+@dirrm include/ming/c++
@dirrm include/ming
lib/libming.a
lib/libming.so
-lib/libming.so.1
+lib/libming.so.2
+share/doc/ming/CHANGES
+share/doc/ming/CREDITS
+share/doc/ming/README
+share/doc/ming/TODO
+@dirrm share/doc/ming
+share/examples/ming/c/action.c
+share/examples/ming/c/alphafill.c
+share/examples/ming/c/animation.c
+share/examples/ming/c/bitmapxform.c
+share/examples/ming/c/button.c
+share/examples/ming/c/cxform.c
+share/examples/ming/c/drag.c
+share/examples/ming/c/glyph.c
+share/examples/ming/c/gradient.c
+share/examples/ming/c/gradientxform.c
+share/examples/ming/c/jpegfill.c
+share/examples/ming/c/keypress.c
+share/examples/ming/c/morph.c
+share/examples/ming/c/mousetrack.c
+share/examples/ming/c/newbutton.c
+share/examples/ming/c/png.c
+share/examples/ming/c/pngalpha.c
+share/examples/ming/c/shape.c
+share/examples/ming/c/sprite.c
+share/examples/ming/c/streammp3.c
+share/examples/ming/c/text.c
+@dirrm share/examples/ming/c
+share/examples/ming/c++/action.cpp
+share/examples/ming/c++/alphafill.cpp
+share/examples/ming/c++/animation.cpp
+share/examples/ming/c++/bitmapxform.cpp
+share/examples/ming/c++/button.cpp
+share/examples/ming/c++/cxform.cpp
+share/examples/ming/c++/drag.cpp
+share/examples/ming/c++/glyph.cpp
+share/examples/ming/c++/gradient.cpp
+share/examples/ming/c++/gradientxform.cpp
+share/examples/ming/c++/jpegfill.cpp
+share/examples/ming/c++/keypress.cpp
+share/examples/ming/c++/morph.cpp
+share/examples/ming/c++/mousetrack.cpp
+share/examples/ming/c++/newbutton.cpp
+share/examples/ming/c++/png.cpp
+share/examples/ming/c++/pngalpha.cpp
+share/examples/ming/c++/shape.cpp
+share/examples/ming/c++/sprite.cpp
+share/examples/ming/c++/streammp3.cpp
+share/examples/ming/c++/text.cpp
+@dirrm share/examples/ming/c++
+share/examples/ming/common/alpha.dbl
+share/examples/ming/common/alphafill.jpg
+share/examples/ming/common/alphafill.msk
+share/examples/ming/common/backyard.jpg
+share/examples/ming/common/distortobass.mp3
+share/examples/ming/common/png.dbl
+share/examples/ming/common/test.fdb
+@dirrm share/examples/ming/common
+@dirrm share/examples/ming