aboutsummaryrefslogtreecommitdiff
path: root/graphics/ming
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-10 19:40:38 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-10 19:40:38 +0000
commit631d2ecd4c60c2a40f6f55c0ffac1615cb941e0b (patch)
treebc58f071d1194274efe71f1171cf9b2f3b073e78 /graphics/ming
parentaa248bc73c24861819c4d3ce9691171f979af05e (diff)
downloadports-631d2ecd4c60c2a40f6f55c0ffac1615cb941e0b.tar.gz
ports-631d2ecd4c60c2a40f6f55c0ffac1615cb941e0b.zip
Notes
Diffstat (limited to 'graphics/ming')
-rw-r--r--graphics/ming/Makefile111
-rw-r--r--graphics/ming/distinfo9
-rw-r--r--graphics/ming/files/Makefile109
-rw-r--r--graphics/ming/files/patch-mingpp.h11
-rw-r--r--graphics/ming/pkg-plist139
5 files changed, 104 insertions, 275 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 0069c41b2fcb..ef37e4221272 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= ming
-PORTVERSION= 0.2a
-PORTREVISION= 1
+PORTVERSION= 0.3.0
CATEGORIES= graphics
-MASTER_SITES= http://www.opaque.net/ming/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}-examples${EXTRACT_SUFX}
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= LGPL'ed Flash 4/5 movie output library with many languages support
@@ -21,81 +19,52 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
CONFLICTS= ja-ming-*
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-MAKE_ARGS= NOPROFILE=true
+USE_GNOME= gnometarget
+USE_BISON= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/ming \
+ ac_cv_path_PYTHON=no
INSTALLS_SHLIB= yes
-UTILS= gif2dbl \
- gif2mask \
- listfdb \
- listjpeg \
- listswf \
- makefdb \
- png2dbl \
- swftophp
-DOCS= CHANGES \
- CREDITS \
- README \
- TODO
-DOCS_UTIL= README \
- TODO
+CPPFLAGS= -I. -I.. -I${LOCALBASE}/include
+LDFLAGS= -L. -L.. -L${LOCALBASE}/lib
+CFLAGS+= ${CPPFLAGS}
-post-extract:
- ${LN} -s ${WRKDIR}/${PORTNAME}-examples ${WRKSRC}/../examples
- ${SED} -e 's:"\.\./\.\./ming\.h":<ming.h>:g' \
- ${WRKSRC}/ming.h > ${WRKSRC}/mingpp.h
- cd ${WRKSRC}/../util && \
- ${RM} bindump.c decompile5.c hexdump.c listmp3.c
-# cd ${WRKSRC}/../php_ext && ${LN} -sf ming-4.0.6.c ming.c
- ${RM} -rf ${WRKSRC}/../examples/results
+UTILS= dbl2png listaction listaction_d listfdb listjpeg listmp3 \
+ listswf listswf_d makefdb makeswf raw2adpcm swftoperl \
+ swftophp swftopython
+DOCS= CREDITS ChangeLog HISTORY NEWS README TODO
+DOCS_UTIL= README TIPS TODO swftoperl.html
-pre-build:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}/
+post-patch:
+ @${REINPLACE_CMD} -e 's|@SHCFLAGS@|-fPIC -DPIC|g ; \
+ s|@SHLIBLDFLAGS@|-shared -Wl,-soname,$$(SHAREDLIB)|g ; \
+ s|@SHLIBEXT@|.so.4|g' ${WRKSRC}/Makefile.config.in
+ @${REINPLACE_CMD} -e '/SHORT_SHLIBEXT/d' ${WRKSRC}/src/Makefile
-post-build:
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -I${PREFIX}/include -I${PREFIX}/include/ming -c *.c
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -L${PREFIX}/lib -o gif2dbl gif2dbl.o -lm -lz -lungif
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -L${PREFIX}/lib -o gif2mask gif2mask.o -lm -lz -lungif
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -L${PREFIX}/lib -o listfdb listfdb.o blocktypes.o
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -L${PREFIX}/lib -o listjpeg listjpeg.o
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -L${PREFIX}/lib -o listswf listswf.o blocktypes.o decompile.o read.o -lz
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -L${PREFIX}/lib -o makefdb makefdb.o blocktypes.o read.o
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -L${PREFIX}/lib -o png2dbl png2dbl.o -lm -lz -lpng
- cd ${WRKSRC}/../util && \
- ${CC} ${CFLAGS} -L${PREFIX}/lib -o swftophp swftophp.o blocktypes.o decompile.o read.o -lm
-
-pre-install:
- ${MKDIR} ${PREFIX}/include/ming/blocks
-
-post-install:
-.for f in ${UTILS}
- ${INSTALL_PROGRAM} ${WRKSRC}/../util/${f} ${PREFIX}/bin/
+do-install:
+.for file in ${UTILS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/${file} ${PREFIX}/bin
.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/util/ming-config ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/include/ming
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/ming
+ ${INSTALL_DATA} ${WRKSRC}/src/*.h ${PREFIX}/include/ming
+ @${MKDIR} ${PREFIX}/include/ming/blocks
+ ${INSTALL_DATA} ${WRKSRC}/src/blocks/*.h ${PREFIX}/include/ming/blocks
+ ${INSTALL_DATA} ${WRKSRC}/libming.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libming.so.4 ${PREFIX}/lib
+ ${LN} -sf libming.so.4 ${PREFIX}/lib/libming.so
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ming/utils
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/../${f} ${PREFIX}/share/doc/ming/
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
-.for f in ${DOCS_UTIL}
- ${INSTALL_DATA} ${WRKSRC}/../util/${f} ${PREFIX}/share/doc/ming/utils/
+ @${MKDIR} ${DOCSDIR}/util
+.for file in ${DOCS_UTIL}
+ @${INSTALL_DATA} ${WRKSRC}/util/${file} ${DOCSDIR}/util
.endfor
- ${MKDIR} ${PREFIX}/share/examples/ming/common
- ${INSTALL_DATA} ${WRKSRC}/../examples/common/* \
- ${PREFIX}/share/examples/ming/common/
- ${MKDIR} ${PREFIX}/share/examples/ming/c
- ${INSTALL_DATA} ${WRKSRC}/../examples/c/*.c \
- ${PREFIX}/share/examples/ming/c/
- ${MKDIR} ${PREFIX}/share/examples/ming/c++
- ${INSTALL_DATA} ${WRKSRC}/../examples/c++/*.cpp \
- ${PREFIX}/share/examples/ming/c++/
.endif
.include <bsd.port.mk>
diff --git a/graphics/ming/distinfo b/graphics/ming/distinfo
index 551b231d8016..451b25fbec39 100644
--- a/graphics/ming/distinfo
+++ b/graphics/ming/distinfo
@@ -1,6 +1,3 @@
-MD5 (ming-0.2a.tgz) = 72b25da0af28d9cb025c2aaf3fd0185c
-SHA256 (ming-0.2a.tgz) = b986908e72228574efcc7d4a196ae4edf9a276399a1ada6aaf66aafe6142e744
-SIZE (ming-0.2a.tgz) = 316447
-MD5 (ming-examples.tgz) = 592953577628990479c9be78522da8de
-SHA256 (ming-examples.tgz) = 96695717927dfaa2fed89675b49fd1870e274e472824a9ee541b0935a46c1f46
-SIZE (ming-examples.tgz) = 619167
+MD5 (ming-0.3.0.tar.gz) = 56b29eeb4fdd0b98c9ee62e25d14841d
+SHA256 (ming-0.3.0.tar.gz) = 820afbafc8697dabb34415eb86b2c589625449709f4434446c323c4d14391cd9
+SIZE (ming-0.3.0.tar.gz) = 287330
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
deleted file mode 100644
index 73d4ee1c3aff..000000000000
--- a/graphics/ming/files/Makefile
+++ /dev/null
@@ -1,109 +0,0 @@
-# $FreeBSD$
-
-.PATH: ${.CURDIR}/actioncompiler ${.CURDIR}/blocks
-
-LIB= ming
-SHLIB_MAJOR?= 3
-SHLIB_MINOR?= 0
-CFLAGS+= -I${.CURDIR}/actioncompiler -I${.CURDIR}/blocks -I${LOCALBASE}/include
-LDADD= -lm
-SRCS= blocklist.c \
- displaylist.c \
- fill.c \
- ming.c \
- movie.c \
- movieclip.c \
- position.c \
- shape_cubic.c \
- shape_util.c \
- text_util.c \
- assembler.c \
- compile.c \
- compileaction.c \
- lex.swf4.c \
- lex.swf5.c \
- swf4compiler.tab.c \
- swf5compiler.tab.c \
- action.c \
- bitmap.c \
- block.c \
- browserfont.c \
- button.c \
- character.c \
- cxform.c \
- dbl.c \
- error.c \
- fillstyle.c \
- font.c \
- fontinfo.c \
- gradient.c \
- input.c \
- jpeg.c \
- linestyle.c \
- loadfont.c \
- matrix.c \
- method.c \
- morph.c \
- mp3.c \
- output.c \
- outputblock.c \
- placeobject.c \
- rect.c \
- shape.c \
- soundstream.c \
- sprite.c \
- text.c \
- textfield.c
-INCSGROUPS= INCS BLKS
-INCS= blocklist.h \
- blocktypes.h \
- displaylist.h \
- fill.h \
- libming.h \
- ../ming.h \
- ../mingpp.h \
- movie.h \
- movieclip.h \
- position.h \
- shape_cubic.h \
- shape_util.h \
- text_util.h
-
-NOMAN= YES
-LIBDIR= ${LOCALBASE}/lib
-INCSDIR= ${LOCALBASE}/include/ming
-
-BLKS= block.h cxform.h \
- error.h exports.h \
- input.h matrix.h \
- outputblock.h placeobject.h \
- sound.h sprite.h \
- swf.h blocktypes.h \
- character.h libswf.h \
- method.h output.h \
- rect.h
-BLKS:= ${BLKS:S;^;${.CURDIR}/blocks/;}
-BLKSDIR= ${INCSDIR}/blocks
-
-.include <bsd.lib.mk>
-
-# For pre-bsd.incs.mk API
-.if defined(INCOWN)
-INCDIR= ${INCSDIR}
-beforeinstall:
- ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
- ${.CURDIR}/blocks/block.h ${.CURDIR}/blocks/cxform.h \
- ${.CURDIR}/blocks/error.h ${.CURDIR}/blocks/exports.h \
- ${.CURDIR}/blocks/input.h ${.CURDIR}/blocks/matrix.h \
- ${.CURDIR}/blocks/outputblock.h ${.CURDIR}/blocks/placeobject.h \
- ${.CURDIR}/blocks/sound.h ${.CURDIR}/blocks/sprite.h \
- ${.CURDIR}/blocks/swf.h ${.CURDIR}/blocks/blocktypes.h \
- ${.CURDIR}/blocks/character.h ${.CURDIR}/blocks/libswf.h \
- ${.CURDIR}/blocks/method.h ${.CURDIR}/blocks/output.h \
- ${.CURDIR}/blocks/rect.h ${INCDIR}/blocks/
-.endif
-
-dynamic: lib${LIB}.so
-
-static: lib${LIB}.a
-
diff --git a/graphics/ming/files/patch-mingpp.h b/graphics/ming/files/patch-mingpp.h
deleted file mode 100644
index 8fd367014b28..000000000000
--- a/graphics/ming/files/patch-mingpp.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../mingpp.h Thu Mar 7 18:28:27 2002
-+++ ../mingpp.h Thu Mar 7 18:28:41 2002
-@@ -627,7 +627,7 @@
- void setColor(unsigned char r, unsigned char g, unsigned char b, int a=0xff)
- { SWFText_setColor(this->text, r, g, b, a); }
-
-- void addString(const char *string, float *advance=NULL)
-+ void addString(const char *string, int *advance=NULL)
- { SWFText_addString(this->text, string, advance); }
-
- void setSpacing(float spacing)
diff --git a/graphics/ming/pkg-plist b/graphics/ming/pkg-plist
index 32a1973dd4eb..523f0462dc5d 100644
--- a/graphics/ming/pkg-plist
+++ b/graphics/ming/pkg-plist
@@ -1,104 +1,87 @@
-bin/gif2dbl
-bin/gif2mask
+bin/dbl2png
+bin/listaction
+bin/listaction_d
bin/listfdb
bin/listjpeg
+bin/listmp3
bin/listswf
+bin/listswf_d
bin/makefdb
-bin/png2dbl
+bin/makeswf
+bin/ming-config
+bin/raw2adpcm
+bin/swftoperl
bin/swftophp
+bin/swftopython
+include/ming/actiontypes.h
include/ming/blocklist.h
-include/ming/blocktypes.h
-include/ming/displaylist.h
-include/ming/fill.h
-include/ming/libming.h
-include/ming/ming.h
-include/ming/movie.h
-include/ming/movieclip.h
-include/ming/position.h
-include/ming/shape_cubic.h
-include/ming/shape_util.h
-include/ming/text_util.h
+include/ming/blocks/action.h
+include/ming/blocks/bitmap.h
include/ming/blocks/block.h
include/ming/blocks/blocktypes.h
+include/ming/blocks/browserfont.h
+include/ming/blocks/button.h
include/ming/blocks/character.h
include/ming/blocks/cxform.h
+include/ming/blocks/dbl.h
include/ming/blocks/error.h
include/ming/blocks/exports.h
+include/ming/blocks/fillstyle.h
+include/ming/blocks/font.h
+include/ming/blocks/fontinfo.h
+include/ming/blocks/fromswf.h
+include/ming/blocks/gradient.h
+include/ming/blocks/imports.h
include/ming/blocks/input.h
+include/ming/blocks/jpeg.h
include/ming/blocks/libswf.h
+include/ming/blocks/linestyle.h
include/ming/blocks/matrix.h
include/ming/blocks/method.h
+include/ming/blocks/morph.h
include/ming/blocks/output.h
include/ming/blocks/outputblock.h
include/ming/blocks/placeobject.h
include/ming/blocks/rect.h
+include/ming/blocks/shape.h
include/ming/blocks/sound.h
+include/ming/blocks/soundinstance.h
+include/ming/blocks/soundstream.h
include/ming/blocks/sprite.h
include/ming/blocks/swf.h
+include/ming/blocks/text.h
+include/ming/blocks/textfield.h
+include/ming/blocks/ttffont.h
+include/ming/blocks/utf8.h
+include/ming/blocks/videostream.h
+include/ming/displaylist.h
+include/ming/fill.h
+include/ming/font_util.h
+include/ming/gc.h
+include/ming/libming.h
+include/ming/ming.h
+include/ming/ming_config.h
include/ming/mingpp.h
-@dirrm include/ming/blocks
-@dirrm include/ming
+include/ming/movie.h
+include/ming/movieclip.h
+include/ming/position.h
+include/ming/shape_cubic.h
+include/ming/shape_util.h
+include/ming/text_util.h
lib/libming.a
lib/libming.so
-lib/libming.so.3
-%%PORTDOCS%%share/doc/ming/CHANGES
-%%PORTDOCS%%share/doc/ming/CREDITS
-%%PORTDOCS%%share/doc/ming/README
-%%PORTDOCS%%share/doc/ming/TODO
-%%PORTDOCS%%share/doc/ming/utils/README
-%%PORTDOCS%%share/doc/ming/utils/TODO
-%%PORTDOCS%%@dirrm share/doc/ming/utils
-%%PORTDOCS%%@dirrm share/doc/ming
-%%PORTDOCS%%share/examples/ming/c/action.c
-%%PORTDOCS%%share/examples/ming/c/alphafill.c
-%%PORTDOCS%%share/examples/ming/c/animation.c
-%%PORTDOCS%%share/examples/ming/c/bitmapxform.c
-%%PORTDOCS%%share/examples/ming/c/button.c
-%%PORTDOCS%%share/examples/ming/c/cxform.c
-%%PORTDOCS%%share/examples/ming/c/drag.c
-%%PORTDOCS%%share/examples/ming/c/glyph.c
-%%PORTDOCS%%share/examples/ming/c/gradient.c
-%%PORTDOCS%%share/examples/ming/c/gradientxform.c
-%%PORTDOCS%%share/examples/ming/c/jpegfill.c
-%%PORTDOCS%%share/examples/ming/c/keypress.c
-%%PORTDOCS%%share/examples/ming/c/morph.c
-%%PORTDOCS%%share/examples/ming/c/mousetrack.c
-%%PORTDOCS%%share/examples/ming/c/newbutton.c
-%%PORTDOCS%%share/examples/ming/c/png.c
-%%PORTDOCS%%share/examples/ming/c/pngalpha.c
-%%PORTDOCS%%share/examples/ming/c/shape.c
-%%PORTDOCS%%share/examples/ming/c/sprite.c
-%%PORTDOCS%%share/examples/ming/c/streammp3.c
-%%PORTDOCS%%share/examples/ming/c/text.c
-%%PORTDOCS%%@dirrm share/examples/ming/c
-%%PORTDOCS%%share/examples/ming/c++/action.cpp
-%%PORTDOCS%%share/examples/ming/c++/alphafill.cpp
-%%PORTDOCS%%share/examples/ming/c++/animation.cpp
-%%PORTDOCS%%share/examples/ming/c++/bitmapxform.cpp
-%%PORTDOCS%%share/examples/ming/c++/button.cpp
-%%PORTDOCS%%share/examples/ming/c++/cxform.cpp
-%%PORTDOCS%%share/examples/ming/c++/drag.cpp
-%%PORTDOCS%%share/examples/ming/c++/glyph.cpp
-%%PORTDOCS%%share/examples/ming/c++/gradient.cpp
-%%PORTDOCS%%share/examples/ming/c++/gradientxform.cpp
-%%PORTDOCS%%share/examples/ming/c++/jpegfill.cpp
-%%PORTDOCS%%share/examples/ming/c++/keypress.cpp
-%%PORTDOCS%%share/examples/ming/c++/morph.cpp
-%%PORTDOCS%%share/examples/ming/c++/mousetrack.cpp
-%%PORTDOCS%%share/examples/ming/c++/newbutton.cpp
-%%PORTDOCS%%share/examples/ming/c++/png.cpp
-%%PORTDOCS%%share/examples/ming/c++/pngalpha.cpp
-%%PORTDOCS%%share/examples/ming/c++/shape.cpp
-%%PORTDOCS%%share/examples/ming/c++/sprite.cpp
-%%PORTDOCS%%share/examples/ming/c++/streammp3.cpp
-%%PORTDOCS%%share/examples/ming/c++/text.cpp
-%%PORTDOCS%%@dirrm share/examples/ming/c++
-%%PORTDOCS%%share/examples/ming/common/alpha.dbl
-%%PORTDOCS%%share/examples/ming/common/alphafill.jpg
-%%PORTDOCS%%share/examples/ming/common/alphafill.msk
-%%PORTDOCS%%share/examples/ming/common/backyard.jpg
-%%PORTDOCS%%share/examples/ming/common/distortobass.mp3
-%%PORTDOCS%%share/examples/ming/common/png.dbl
-%%PORTDOCS%%share/examples/ming/common/test.fdb
-%%PORTDOCS%%@dirrm share/examples/ming/common
-%%PORTDOCS%%@dirrm share/examples/ming
+lib/libming.so.4
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/HISTORY
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/util/README
+%%PORTDOCS%%%%DOCSDIR%%/util/TIPS
+%%PORTDOCS%%%%DOCSDIR%%/util/TODO
+%%PORTDOCS%%%%DOCSDIR%%/util/swftoperl.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/util
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/ming/blocks
+@dirrm include/ming