aboutsummaryrefslogtreecommitdiff
path: root/graphics/ming
diff options
context:
space:
mode:
authorJosef Karthauser <joe@FreeBSD.org>2002-03-07 20:34:40 +0000
committerJosef Karthauser <joe@FreeBSD.org>2002-03-07 20:34:40 +0000
commit41dbe8a305f4bcc0dcae4e0e9ddda6b7a23a793d (patch)
tree9794cd715c2ab25e7daf336e89c2d0a7a1d8fad8 /graphics/ming
parent65e198582c1eb4df4c27f84f19dfd9c9703f8586 (diff)
downloadports-41dbe8a305f4bcc0dcae4e0e9ddda6b7a23a793d.tar.gz
ports-41dbe8a305f4bcc0dcae4e0e9ddda6b7a23a793d.zip
Notes
Diffstat (limited to 'graphics/ming')
-rw-r--r--graphics/ming/files/Makefile4
-rw-r--r--graphics/ming/files/patch-mingpp.h11
2 files changed, 13 insertions, 2 deletions
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
index ad7640a226dc..0f1057fb25c3 100644
--- a/graphics/ming/files/Makefile
+++ b/graphics/ming/files/Makefile
@@ -57,8 +57,8 @@ INCS= blocklist.h \
displaylist.h \
fill.h \
libming.h \
- ming.h \
- mingpp.h \
+ ../ming.h \
+ ../mingpp.h \
movie.h \
movieclip.h \
position.h \
diff --git a/graphics/ming/files/patch-mingpp.h b/graphics/ming/files/patch-mingpp.h
new file mode 100644
index 000000000000..8fd367014b28
--- /dev/null
+++ b/graphics/ming/files/patch-mingpp.h
@@ -0,0 +1,11 @@
+--- ../mingpp.h Thu Mar 7 18:28:27 2002
++++ ../mingpp.h Thu Mar 7 18:28:41 2002
+@@ -627,7 +627,7 @@
+ void setColor(unsigned char r, unsigned char g, unsigned char b, int a=0xff)
+ { SWFText_setColor(this->text, r, g, b, a); }
+
+- void addString(const char *string, float *advance=NULL)
++ void addString(const char *string, int *advance=NULL)
+ { SWFText_addString(this->text, string, advance); }
+
+ void setSpacing(float spacing)