aboutsummaryrefslogtreecommitdiff
path: root/graphics/ming
diff options
context:
space:
mode:
authorRuslan Ermilov <ru@FreeBSD.org>2002-07-21 19:21:04 +0000
committerRuslan Ermilov <ru@FreeBSD.org>2002-07-21 19:21:04 +0000
commitde3359b588b69fa9209a46f7d90a4fcd44c38bd3 (patch)
tree1379bfae8185d8c0a573072e7aa88a1327f2853d /graphics/ming
parentc97d2f822019ca0ea8521a0f6e765034e2a897db (diff)
downloadports-de3359b588b69fa9209a46f7d90a4fcd44c38bd3.tar.gz
ports-de3359b588b69fa9209a46f7d90a4fcd44c38bd3.zip
Notes
Diffstat (limited to 'graphics/ming')
-rw-r--r--graphics/ming/Makefile3
-rw-r--r--graphics/ming/files/Makefile39
2 files changed, 21 insertions, 21 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index b4287a563995..f7301c85eaba 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -69,6 +69,9 @@ post-build:
cd ${WRKSRC}/../util && \
${CC} ${CFLAGS} -L${PREFIX}/lib -o swftophp swftophp.o blocktypes.o decompile.o read.o -lm
+pre-install:
+ ${MKDIR} ${PREFIX}/include/ming/blocks
+
post-install:
.for f in ${UTILS}
${INSTALL_PROGRAM} ${WRKSRC}/../util/${f} ${PREFIX}/bin/
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
index 0f1057fb25c3..6aa45b0f97e9 100644
--- a/graphics/ming/files/Makefile
+++ b/graphics/ming/files/Makefile
@@ -52,6 +52,7 @@ SRCS= blocklist.c \
blocks/sprite.c \
blocks/text.c \
blocks/textfield.c
+INCSGROUPS= INCS BLKS
INCS= blocklist.h \
blocktypes.h \
displaylist.h \
@@ -68,30 +69,25 @@ INCS= blocklist.h \
NOMAN= YES
LIBDIR= ${LOCALBASE}/lib
-INCDIR= ${LOCALBASE}/include/ming
+INCSDIR= ${LOCALBASE}/include/ming
-.include <bsd.lib.mk>
-
-# For FreeBSD 3.x or older
-.if !target(_includeinstall)
-_includeinstall:
-.if defined(INCS)
-.for header in ${INCS}
- cd ${.CURDIR} && \
- ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
- ${header} ${DESTDIR}${INCDIR}
+BLKS= block.h cxform.h \
+ error.h exports.h \
+ input.h matrix.h \
+ outputblock.h placeobject.h \
+ sound.h sprite.h \
+ swf.h blocktypes.h \
+ character.h libswf.h \
+ method.h output.h \
+ rect.h
+BLKS:= ${BLKS:S;^;${.CURDIR}/blocks/;}
+BLKSDIR= ${INCSDIR}/blocks
-.endfor
-.endif
-
-beforeinstall: _includeinstall
-.endif
-
-_includeinstall: pre-_includeinstall
-
-pre-_includeinstall:
- mkdir -p ${DESTDIR}${INCDIR}/blocks
+.include <bsd.lib.mk>
+# For pre-bsd.incs.mk API
+.if defined(INCOWN)
+INCDIR= ${INCSDIR}
beforeinstall:
${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
${.CURDIR}/blocks/block.h ${.CURDIR}/blocks/cxform.h \
@@ -103,6 +99,7 @@ beforeinstall:
${.CURDIR}/blocks/character.h ${.CURDIR}/blocks/libswf.h \
${.CURDIR}/blocks/method.h ${.CURDIR}/blocks/output.h \
${.CURDIR}/blocks/rect.h ${INCDIR}/blocks/
+.endif
dynamic: lib${LIB}.so