aboutsummaryrefslogtreecommitdiff
path: root/graphics/ming
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-08-07 15:51:48 +0000
committerSteve Wills <swills@FreeBSD.org>2011-08-07 15:51:48 +0000
commitef8d112099a260ee3bbe9fa0004c815f492edba3 (patch)
treeb0e8d7d44300c86addb617babcc84b3a15224ebf /graphics/ming
parent92453ac2416f3a8604404f57a6f1ae63b918d0f3 (diff)
downloadports-ef8d112099a260ee3bbe9fa0004c815f492edba3.tar.gz
ports-ef8d112099a260ee3bbe9fa0004c815f492edba3.zip
Notes
Diffstat (limited to 'graphics/ming')
-rw-r--r--graphics/ming/Makefile39
-rw-r--r--graphics/ming/distinfo4
-rw-r--r--graphics/ming/files/patch-src_actioncompiler_swf5compiler.y23
-rw-r--r--graphics/ming/files/patch-src_blocks_pngdbl.c20
-rw-r--r--graphics/ming/pkg-descr2
-rw-r--r--graphics/ming/pkg-plist24
6 files changed, 33 insertions, 79 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 2f453859485f..2ed018f2f48d 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -6,25 +6,23 @@
#
PORTNAME= ming
-PORTVERSION= 0.3.0
-PORTREVISION= 4
+PORTVERSION= 0.4.3
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/Releases/Ming%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= LGPL'ed Flash 4/5 movie output library with many languages support
-
-BROKEN= Does not fetch
+COMMENT= Flash 4/5 movie output library with many languages support
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
- ungif.5:${PORTSDIR}/graphics/libungif
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ freetype.9:${PORTSDIR}/print/freetype2
CONFLICTS= ja-ming-[0-9]*
-USE_GNOME= gnometarget
+USE_GNOME= gnomehack
USE_BISON= build
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --includedir=${PREFIX}/include/ming \
ac_cv_path_PYTHON=no
USE_LDCONFIG= yes
@@ -34,22 +32,10 @@ CPPFLAGS= -I. -I.. -I${LOCALBASE}/include
LDFLAGS= -L. -L.. -L${LOCALBASE}/lib
CFLAGS+= ${CPPFLAGS}
-UTILS= dbl2png listaction listaction_d listfdb listjpeg listmp3 \
- listswf listswf_d makefdb makeswf raw2adpcm swftoperl \
- swftophp swftopython gif2dbl gif2mask png2dbl png2swf
-DOCS= CREDITS ChangeLog HISTORY NEWS README TODO
+DOCS= HISTORY NEWS README TODO
DOCS_UTIL= README TIPS TODO swftoperl.html
-post-patch:
- @${REINPLACE_CMD} -e 's|@SHCFLAGS@|-fPIC -DPIC|g ; \
- s|@SHLIBLDFLAGS@|-shared -Wl,-soname,$$(SHAREDLIB)|g ; \
- s|@SHLIBEXT@|.so.4|g' ${WRKSRC}/Makefile.config.in
- @${REINPLACE_CMD} -e '/SHORT_SHLIBEXT/d' ${WRKSRC}/src/Makefile
-
-do-install:
-.for file in ${UTILS}
- ${INSTALL_PROGRAM} ${WRKSRC}/util/${file} ${PREFIX}/bin
-.endfor
+post-install:
${INSTALL_SCRIPT} ${WRKSRC}/util/ming-config ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/util/cws2fws ${PREFIX}/bin
@${MKDIR} ${PREFIX}/include/ming
@@ -60,17 +46,14 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/util/png2dbl.c ${PREFIX}/include/ming/util
@${MKDIR} ${PREFIX}/include/ming/blocks
${INSTALL_DATA} ${WRKSRC}/src/blocks/*.h ${PREFIX}/include/ming/blocks
- ${INSTALL_DATA} ${WRKSRC}/libming.a ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/libming.so.4 ${PREFIX}/lib
- ${LN} -sf libming.so.4 ${PREFIX}/lib/libming.so
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
@${MKDIR} ${DOCSDIR}/util
-.for file in ${DOCS_UTIL}
- @${INSTALL_DATA} ${WRKSRC}/util/${file} ${DOCSDIR}/util
+.for docs_utils in ${DOCS_UTIL}
+ @${INSTALL_DATA} ${WRKSRC}/util/${docs_utils} ${DOCSDIR}/util
.endfor
.endif
diff --git a/graphics/ming/distinfo b/graphics/ming/distinfo
index 8226fde633e2..482c6ca74880 100644
--- a/graphics/ming/distinfo
+++ b/graphics/ming/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ming-0.3.0.tar.gz) = 820afbafc8697dabb34415eb86b2c589625449709f4434446c323c4d14391cd9
-SIZE (ming-0.3.0.tar.gz) = 287330
+SHA256 (ming-0.4.3.tar.gz) = 1fbe9f03c92130ebad0f68f61ed0d1e35c9b5b42adbb2ba1a340d2ac9523624b
+SIZE (ming-0.4.3.tar.gz) = 14920165
diff --git a/graphics/ming/files/patch-src_actioncompiler_swf5compiler.y b/graphics/ming/files/patch-src_actioncompiler_swf5compiler.y
deleted file mode 100644
index cf0ccde2b457..000000000000
--- a/graphics/ming/files/patch-src_actioncompiler_swf5compiler.y
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/actioncompiler/swf5compiler.y.orig 2006-02-08 23:48:38.000000000 +0100
-+++ src/actioncompiler/swf5compiler.y 2009-03-06 11:32:10.000000000 +0100
-@@ -1795,7 +1795,7 @@ opcode_list
-
- with
- : WITH
-- { $$ = bufferWriteOp(asmBuffer,
-+ { $<len>$ = bufferWriteOp(asmBuffer,
- SWFACTION_WITH); }
- opcode_list END { $$ = $<len>2 + $3;
- bufferPatchLength(asmBuffer, $3); }
-@@ -1828,9 +1828,9 @@ push_list
- ;
-
- opcode
-- : PUSH { $$ = bufferWriteOp(asmBuffer,
-+ : PUSH { $<len>$ = bufferWriteOp(asmBuffer,
- SWFACTION_PUSH);
-- $$ += bufferWriteS16(asmBuffer, 0); }
-+ $<len>$ += bufferWriteS16(asmBuffer, 0); }
- push_list { $$ = $<len>2 + $3;
- bufferPatchLength(asmBuffer, $3); }
-
diff --git a/graphics/ming/files/patch-src_blocks_pngdbl.c b/graphics/ming/files/patch-src_blocks_pngdbl.c
deleted file mode 100644
index 6c8c125614d0..000000000000
--- a/graphics/ming/files/patch-src_blocks_pngdbl.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/blocks/pngdbl.c.orig 2006-02-08 20:09:27.000000000 +0100
-+++ src/blocks/pngdbl.c 2010-03-28 20:34:13.000000000 +0200
-@@ -34,7 +34,7 @@
-
- if(fread(header, 1, 8, fp) != 8)
- return NULL;
-- if(!png_check_sig(header, 8))
-+ if(png_sig_cmp(header, 0, 8))
- return NULL;
- result = png_create_read_struct(PNG_LIBPNG_VER_STRING, NULL, NULL, NULL);
- if(!result)
-@@ -54,7 +54,7 @@
-
- if(SWFInput_read(input, header, 8) != 8)
- return NULL;
-- if(!png_check_sig(header, 8))
-+ if(png_sig_cmp(header, 0, 8))
- return NULL;
- result = png_create_read_struct(PNG_LIBPNG_VER_STRING, NULL, NULL, NULL);
- if(!result)
diff --git a/graphics/ming/pkg-descr b/graphics/ming/pkg-descr
index 65ed8241070b..74882f6175fa 100644
--- a/graphics/ming/pkg-descr
+++ b/graphics/ming/pkg-descr
@@ -1,4 +1,4 @@
Ming is an LGPL'ed Flash 4/5 (TM) movie (SWF) output library with PHP,
Python, Ruby, Perl5, C and C++ interfaces.
-WWW: http://www.opaque.net/ming/
+WWW: http://www.libming.org/
diff --git a/graphics/ming/pkg-plist b/graphics/ming/pkg-plist
index 1dc9efa307bd..49a73ec322cb 100644
--- a/graphics/ming/pkg-plist
+++ b/graphics/ming/pkg-plist
@@ -13,11 +13,13 @@ bin/makefdb
bin/makeswf
bin/ming-config
bin/png2dbl
-bin/png2swf
bin/raw2adpcm
+bin/swftocxx
bin/swftoperl
bin/swftophp
bin/swftopython
+bin/swftotcl
+include/ming/abctypes.h
include/ming/actiontypes.h
include/ming/blocklist.h
include/ming/blocks/action.h
@@ -31,7 +33,11 @@ include/ming/blocks/cxform.h
include/ming/blocks/dbl.h
include/ming/blocks/error.h
include/ming/blocks/exports.h
+include/ming/blocks/fdbfont.h
+include/ming/blocks/fileattrs.h
include/ming/blocks/fillstyle.h
+include/ming/blocks/filter.h
+include/ming/blocks/flv.h
include/ming/blocks/font.h
include/ming/blocks/fontinfo.h
include/ming/blocks/fromswf.h
@@ -42,18 +48,26 @@ include/ming/blocks/jpeg.h
include/ming/blocks/libswf.h
include/ming/blocks/linestyle.h
include/ming/blocks/matrix.h
+include/ming/blocks/metadata.h
include/ming/blocks/method.h
include/ming/blocks/morph.h
+include/ming/blocks/mp3.h
include/ming/blocks/output.h
include/ming/blocks/outputblock.h
include/ming/blocks/placeobject.h
+include/ming/blocks/protect.h
include/ming/blocks/rect.h
+include/ming/blocks/scalinggrid.h
+include/ming/blocks/scenedata.h
+include/ming/blocks/scriptlimits.h
include/ming/blocks/shape.h
include/ming/blocks/sound.h
include/ming/blocks/soundinstance.h
include/ming/blocks/soundstream.h
include/ming/blocks/sprite.h
include/ming/blocks/swf.h
+include/ming/blocks/symbolclass.h
+include/ming/blocks/tabindex.h
include/ming/blocks/text.h
include/ming/blocks/textfield.h
include/ming/blocks/ttffont.h
@@ -81,15 +95,15 @@ include/ming/util/output.h
include/ming/util/outputdecl.h
include/ming/util/parser.h
include/ming/util/parserdecl.h
+include/ming/util/png2dbl.c
include/ming/util/read.h
include/ming/util/swfoutput.h
include/ming/util/swftypes.h
-include/ming/util/png2dbl.c
lib/libming.a
+lib/libming.la
lib/libming.so
-lib/libming.so.4
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+lib/libming.so.5
+libdata/pkgconfig/libming.pc
%%PORTDOCS%%%%DOCSDIR%%/HISTORY
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README