aboutsummaryrefslogtreecommitdiff
path: root/graphics/mirage
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-11-18 22:50:48 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-11-18 22:50:48 +0000
commit8abf8757268d2b106b1889533d887b5e10268558 (patch)
treedc9398167d2f1ab1835e20daf0743dd67a939bc7 /graphics/mirage
parent5474288d56ebd66fb5c4effcf6fe4918290e9aaf (diff)
downloadports-8abf8757268d2b106b1889533d887b5e10268558.tar.gz
ports-8abf8757268d2b106b1889533d887b5e10268558.zip
Notes
Diffstat (limited to 'graphics/mirage')
-rw-r--r--graphics/mirage/Makefile2
-rw-r--r--graphics/mirage/files/patch-mirage.py10
-rw-r--r--graphics/mirage/files/patch-setup.py (renamed from graphics/mirage/files/patch-setyp.py)6
-rw-r--r--graphics/mirage/files/patch-xmouse.c12
4 files changed, 21 insertions, 9 deletions
diff --git a/graphics/mirage/Makefile b/graphics/mirage/Makefile
index 2631d339f9c1..c5fc8e8795a7 100644
--- a/graphics/mirage/Makefile
+++ b/graphics/mirage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mirage
PORTVERSION= 0.9.5.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}iv
diff --git a/graphics/mirage/files/patch-mirage.py b/graphics/mirage/files/patch-mirage.py
index 4b4f719f006e..243324d416a3 100644
--- a/graphics/mirage/files/patch-mirage.py
+++ b/graphics/mirage/files/patch-mirage.py
@@ -1,6 +1,6 @@
---- mirage.py.orig 2011-02-13 23:40:05.000000000 +0100
-+++ mirage.py 2013-05-22 17:56:33.000000000 +0200
-@@ -71,7 +71,7 @@
+--- mirage.py.orig 2011-02-13 22:40:05 UTC
++++ mirage.py
+@@ -71,7 +71,7 @@ class Base:
def __init__(self):
@@ -9,7 +9,7 @@
# FIX THIS! Does not work on windows and what happens if mo-files exists
# in both dirs?
-@@ -841,9 +841,7 @@
+@@ -841,9 +841,7 @@ class Base:
self.thumbpane_bottom_coord_loaded = bottom_coord
# update images:
if not self.thumbpane_updating:
@@ -20,7 +20,7 @@
def thumbpane_create_dir(self):
if not os.path.exists(os.path.expanduser('~/.thumbnails/')):
-@@ -4579,6 +4577,6 @@
+@@ -4579,6 +4577,6 @@ class Base:
if __name__ == "__main__":
base = Base()
diff --git a/graphics/mirage/files/patch-setyp.py b/graphics/mirage/files/patch-setup.py
index bcfac48da1bd..a6628e077b1b 100644
--- a/graphics/mirage/files/patch-setyp.py
+++ b/graphics/mirage/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2008-03-27 13:05:28.000000000 +0900
-+++ setup.py 2009-07-24 05:13:46.000000000 +0900
-@@ -56,9 +56,9 @@
+--- setup.py.orig 2011-02-13 22:40:05 UTC
++++ setup.py
+@@ -58,9 +58,9 @@ setup(name='Mirage',
],
py_modules = ['mirage'],
ext_modules = [Extension(name='imgfuncs', sources=['imgfuncs.c']),
diff --git a/graphics/mirage/files/patch-xmouse.c b/graphics/mirage/files/patch-xmouse.c
new file mode 100644
index 000000000000..2b604d8a02a8
--- /dev/null
+++ b/graphics/mirage/files/patch-xmouse.c
@@ -0,0 +1,12 @@
+--- xmouse.c.orig 2007-11-27 14:26:18 UTC
++++ xmouse.c
+@@ -37,7 +37,8 @@ PyObject* xmouse_geometry(PyObject* self
+
+ PyMethodDef methods[] =
+ {
+- {"geometry", xmouse_geometry, METH_VARARGS},
++ {"geometry", xmouse_geometry, METH_VARARGS, NULL},
++ {NULL, NULL, 0, NULL}
+ };
+
+ void initxmouse(void)