aboutsummaryrefslogtreecommitdiff
path: root/graphics/mirage
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-05-22 17:42:46 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-05-22 17:42:46 +0000
commit62ebfa21d77da0c53b1f27ee37691b87abbefb13 (patch)
tree31bcbf097ad2e9701c4c5a1179c3242605269588 /graphics/mirage
parentac16621310516c58a44d65c464d9e575712684ac (diff)
downloadports-62ebfa21d77da0c53b1f27ee37691b87abbefb13.tar.gz
ports-62ebfa21d77da0c53b1f27ee37691b87abbefb13.zip
Notes
Diffstat (limited to 'graphics/mirage')
-rw-r--r--graphics/mirage/Makefile11
-rw-r--r--graphics/mirage/files/patch-mirage.py35
2 files changed, 29 insertions, 17 deletions
diff --git a/graphics/mirage/Makefile b/graphics/mirage/Makefile
index ecf4cf08ff39..56525af64bb6 100644
--- a/graphics/mirage/Makefile
+++ b/graphics/mirage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mirage
PORTVERSION= 0.9.5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= BERLIOS/mirageiv
@@ -14,7 +14,6 @@ LICENSE= GPLv3
USE_BZIP2= yes
USE_GNOME= gtk20 pygtk2
-WANT_GNOME= yes
USES= gettext
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -22,9 +21,11 @@ PYDISTUTILS_PKGNAME= Mirage
PORT_VERBS= ${PORTNAME} imgfuncs
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS GNOME
-.if ${HAVE_GNOME:Mpygnome2}!=""
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNOME}
USE_GNOME+= pygnome2
.endif
@@ -40,4 +41,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/mirage/files/patch-mirage.py b/graphics/mirage/files/patch-mirage.py
index 79d6e7d48f7f..4b4f719f006e 100644
--- a/graphics/mirage/files/patch-mirage.py
+++ b/graphics/mirage/files/patch-mirage.py
@@ -1,20 +1,31 @@
---- mirage.py.orig 2013-04-10 19:04:47.000000000 +0200
-+++ mirage.py 2013-04-10 19:05:50.000000000 +0200
-@@ -1,3 +1,4 @@
-+#!/usr/bin/python2
- # $HeadURL: http://svn.berlios.de/svnroot/repos/mirageiv/branches/mirage-0.9.x/mirage.py $
- # $Id: mirage.py 337 2011-02-13 22:40:05Z fredricj $
+--- mirage.py.orig 2011-02-13 23:40:05.000000000 +0100
++++ mirage.py 2013-05-22 17:56:33.000000000 +0200
+@@ -71,7 +71,7 @@
-@@ -4575,10 +4576,10 @@
- timer_screensaver = gobject.timeout_add(1000, self.disable_screensaver_in_slideshow_mode)
+ def __init__(self):
+
+- gtk.gdk.threads_init()
++ #gtk.gdk.threads_init()
+
+ # FIX THIS! Does not work on windows and what happens if mo-files exists
+ # in both dirs?
+@@ -841,9 +841,7 @@
+ self.thumbpane_bottom_coord_loaded = bottom_coord
+ # update images:
+ if not self.thumbpane_updating:
+- thread = threading.Thread(target=self.thumbpane_update_pending_images, args=(force_upto_imgnum, None))
+- thread.setDaemon(True)
+- thread.start()
++ self.thumbpane_update_pending_images(force_upto_imgnum, None)
- def main(self):
-+ gtk.gdk.threads_enter()
- gtk.main()
-+ gtk.gdk.threads_leave()
+ def thumbpane_create_dir(self):
+ if not os.path.exists(os.path.expanduser('~/.thumbnails/')):
+@@ -4579,6 +4577,6 @@
if __name__ == "__main__":
base = Base()
- gtk.gdk.threads_enter()
++ #gtk.gdk.threads_enter()
base.main()
- gtk.gdk.threads_leave()
++ #gtk.gdk.threads_leave()