aboutsummaryrefslogtreecommitdiff
path: root/graphics/moth
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-11 19:38:00 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-11 19:38:00 +0000
commit6dc362a3624fff5863675f9eaf6dfea7b55a25e8 (patch)
treec5d516f88fb263a09b2c7640bba8773a313b7e5a /graphics/moth
parent11b7792aec5d530273a2907e3044dd64e5f982fb (diff)
downloadports-6dc362a3624fff5863675f9eaf6dfea7b55a25e8.tar.gz
ports-6dc362a3624fff5863675f9eaf6dfea7b55a25e8.zip
Notes
Diffstat (limited to 'graphics/moth')
-rw-r--r--graphics/moth/Makefile64
-rw-r--r--graphics/moth/distinfo4
-rw-r--r--graphics/moth/pkg-descr10
3 files changed, 78 insertions, 0 deletions
diff --git a/graphics/moth/Makefile b/graphics/moth/Makefile
new file mode 100644
index 000000000000..f184138db450
--- /dev/null
+++ b/graphics/moth/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: moth
+# Date created: 10 Sep 2005
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moth
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= http://moth.titanothere.com/moth/
+DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX} \
+ lib${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= A simple to use 3D mesh editor
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_QT_VER= 3
+USE_GL= yes
+USE_X_PREFIX= yes
+MAKE_ARGS= CC="${CXX}" XLIBDIR="${X11BASE}/lib" MOC="${MOC}" \
+ CFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS}" QTDIR="${X11BASE}" \
+ GLINCLUDEDIR="${X11BASE}/include" \
+ MOTH_INCLUDES="${WRKSRC_LIBMOTH}/include" \
+ MOTH_LIBRARIES="${WRKSRC_LIBMOTH}/lib"
+ALL_TARGET= clean moth
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= manual.pdf
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+WRKSRC_LIBMOTH= ${WRKDIR}/lib${PORTNAME}_${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^INCLUDES =|& ${QTCPPFLAGS} -I${LOCALBASE}/include|' \
+ ${WRKSRC_LIBMOTH}/Makefile ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|; s|strip|# &|; \
+ s|#\(-I$$(MOTH_INCLUDES)\)|\1|; \
+ s|^LIBRARIES =|& -L${LOCALBASE}/lib|; \
+ s|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/#include <GL\/glut\.h>/ d' \
+ ${WRKSRC_LIBMOTH}/src/MMaterial.cpp \
+ ${WRKSRC_LIBMOTH}/include/moth/MLightSource.h
+ @${FIND} ${WRKSRC_LIBMOTH}/src ${WRKSRC}/src -name '*.cpp' -exec \
+ ${GREP} -lEe 'M_PI|exp\(|sqrt\(|fabs\(' "{}" \; | ${XARGS} -L 1 \
+ ${REINPLACE_CMD} -Ee '1s|^|#include <math.h>|; 1G'
+
+# build libmoth first
+pre-build:
+ @(cd ${WRKSRC_LIBMOTH} && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} ${ALL_TARGET})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+.ifndef (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/moth/distinfo b/graphics/moth/distinfo
new file mode 100644
index 000000000000..1f4cfdded576
--- /dev/null
+++ b/graphics/moth/distinfo
@@ -0,0 +1,4 @@
+MD5 (moth_1.0.tar.gz) = f81a1f382bef418936eeb0620b807db9
+SIZE (moth_1.0.tar.gz) = 955784
+MD5 (libmoth_1.0.tar.gz) = a401c4964454cf8f4d1e137e25b8240d
+SIZE (libmoth_1.0.tar.gz) = 180729
diff --git a/graphics/moth/pkg-descr b/graphics/moth/pkg-descr
new file mode 100644
index 000000000000..8c0405253f6e
--- /dev/null
+++ b/graphics/moth/pkg-descr
@@ -0,0 +1,10 @@
+Moth is a simple to use triangle mesh editor based on standardized OpenGL and
+XML (file format) technologies. Its major field of application is the creation
+of 3D models for interactive applications like games, visualizations,
+simulations, virtual worlds and similar uses. Another field of application is
+3D sketching.
+
+WWW: http://moth.titanothere.com/
+
+- Igor Pokrovsky
+ip@doom.homeunix.org