aboutsummaryrefslogtreecommitdiff
path: root/graphics/mpegedit
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2001-12-08 02:27:16 +0000
committerPatrick Li <pat@FreeBSD.org>2001-12-08 02:27:16 +0000
commit9d9c2f18ad9d12de1586336d72ec43569ae589e7 (patch)
tree23b54fb7d4fb66e77885b39fa3398048509f7ca2 /graphics/mpegedit
parent40c3e68ad8f18972c3616f833785504cebd119f7 (diff)
downloadports-9d9c2f18ad9d12de1586336d72ec43569ae589e7.tar.gz
ports-9d9c2f18ad9d12de1586336d72ec43569ae589e7.zip
Notes
Diffstat (limited to 'graphics/mpegedit')
-rw-r--r--graphics/mpegedit/Makefile10
-rw-r--r--graphics/mpegedit/files/patch-aq16
-rw-r--r--graphics/mpegedit/pkg-descr2
-rw-r--r--graphics/mpegedit/pkg-plist6
4 files changed, 16 insertions, 18 deletions
diff --git a/graphics/mpegedit/Makefile b/graphics/mpegedit/Makefile
index 6c3e48f950e6..975422aac4d1 100644
--- a/graphics/mpegedit/Makefile
+++ b/graphics/mpegedit/Makefile
@@ -8,7 +8,7 @@
PORTNAME= mpegedit
PORTVERSION= 2.2
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.netsw.org/netsw/Graphic/Movie/MPEG/mpegedit/
+MASTER_SITES= http://www.netsw.org/graphic/movie/mpeg/mpegedit/
DISTNAME= ${PORTNAME}_v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -21,11 +21,11 @@ post-extract:
@find ${WRKSRC} -name '.depend' | xargs ${RM} -f
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mpeg_edit ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mpeg_edit ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/mpeg_edit
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/mpeg_edit
- ${INSTALL_DATA} ${WRKSRC}/manual.ps ${PREFIX}/share/doc/mpeg_edit
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/manual.ps ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/mpegedit/files/patch-aq b/graphics/mpegedit/files/patch-aq
index f2975dbae576..f2eb9431e9b4 100644
--- a/graphics/mpegedit/files/patch-aq
+++ b/graphics/mpegedit/files/patch-aq
@@ -1,6 +1,6 @@
---- editor/editor.C.orig Sun Jun 18 04:27:07 1995
-+++ editor/editor.C Sat Apr 1 20:10:46 2000
-@@ -45,11 +45,14 @@
+--- editor/editor.C.orig Sun Jun 18 07:27:07 1995
++++ editor/editor.C Fri Dec 7 21:02:51 2001
+@@ -45,11 +45,13 @@
#include <stdio.h>
#include <time.h>
#include <unistd.h>
@@ -8,14 +8,14 @@
#include <sys/time.h>
#include <sys/types.h>
#include <sys/wait.h>
+-#include "pbmplus.h"
+extern "C" {
- #include "pbmplus.h"
#include "pnm.h"
+}
#define del(x) delete x; x = NULL;
-@@ -3249,17 +3252,17 @@
+@@ -3249,17 +3251,17 @@
wins[0] = play_btn->WinId();
play_btn->RestrictEvents(wins,1);
@@ -37,7 +37,7 @@
dither_delay = clk.tv_usec + 1000000*clk.tv_sec;
dither_delay -= target.tv_usec + 1000000*target.tv_sec;
-@@ -3268,9 +3271,9 @@
+@@ -3268,9 +3270,9 @@
for(int a=0; a<5; a++)
{
@@ -49,7 +49,7 @@
usleep_delay += clk.tv_usec + 1000000*clk.tv_sec - 10000;
usleep_delay -= target.tv_usec + 1000000*target.tv_sec;
-@@ -3283,7 +3286,7 @@
+@@ -3283,7 +3285,7 @@
// Calculate when the frame _should_ finish
@@ -58,7 +58,7 @@
target.tv_usec += usec_per_frame - dither_delay - decode_delay;
if(target.tv_usec >= 1000000)
{
-@@ -3299,7 +3302,7 @@
+@@ -3299,7 +3301,7 @@
// See if we're ahead by more than a decode delay (for the next frame)
diff --git a/graphics/mpegedit/pkg-descr b/graphics/mpegedit/pkg-descr
index 49b1677787f4..f25cbbf23e67 100644
--- a/graphics/mpegedit/pkg-descr
+++ b/graphics/mpegedit/pkg-descr
@@ -4,7 +4,5 @@ encoded mpeg video stream.
The program has several bugs, but I've been able to use it. Expect
core-dumps. It has problems with displays >8 bits too.
-WWW: http://www.ripley.demon.co.uk/mpeg/index.html
-
eric.
erich@FreeBSD.org
diff --git a/graphics/mpegedit/pkg-plist b/graphics/mpegedit/pkg-plist
index a1c913e5594b..19f822c08176 100644
--- a/graphics/mpegedit/pkg-plist
+++ b/graphics/mpegedit/pkg-plist
@@ -1,4 +1,4 @@
bin/mpeg_edit
-share/doc/mpeg_edit/README
-share/doc/mpeg_edit/manual.ps
-@dirrm share/doc/mpeg_edit
+%%PORTDOCS%%share/doc/mpegedit/README
+%%PORTDOCS%%share/doc/mpegedit/manual.ps
+%%PORTDOCS%%@dirrm share/doc/mpegedit