aboutsummaryrefslogtreecommitdiff
path: root/graphics/mrsidviewer
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2002-07-31 17:12:08 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2002-07-31 17:12:08 +0000
commit007e3c3cdc5be7b45b7d073be40744d9c9eff73d (patch)
tree2b5bf8852d12e43dd146d56fc29f4d731c7ae5de /graphics/mrsidviewer
parenta176859d3dcbbd071fb81d193cae9b9f629bc3db (diff)
downloadports-007e3c3cdc5be7b45b7d073be40744d9c9eff73d.tar.gz
ports-007e3c3cdc5be7b45b7d073be40744d9c9eff73d.zip
Notes
Diffstat (limited to 'graphics/mrsidviewer')
-rw-r--r--graphics/mrsidviewer/Makefile36
-rw-r--r--graphics/mrsidviewer/distinfo1
-rw-r--r--graphics/mrsidviewer/pkg-comment1
-rw-r--r--graphics/mrsidviewer/pkg-descr6
-rw-r--r--graphics/mrsidviewer/pkg-message8
-rw-r--r--graphics/mrsidviewer/pkg-plist11
6 files changed, 63 insertions, 0 deletions
diff --git a/graphics/mrsidviewer/Makefile b/graphics/mrsidviewer/Makefile
new file mode 100644
index 000000000000..13f6880f498a
--- /dev/null
+++ b/graphics/mrsidviewer/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: MrSID
+# Date created: 31 July 2002
+# Whom: Chris D. Faulhaber <jedgar@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mrsidviewer
+PORTVERSION= 2.0.32
+CATEGORIES= graphics linux
+MASTER_SITES= #
+DISTNAME= MrSID_linux${PORTVERSION}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= jedgar@FreeBSD.org
+
+DOWNLOAD_URL= http://www.lizardtech.com/includes/down.php?p=16&o=4
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/MrSID_linux${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE=You must manually fetch the MrSID ${PORTVERSION} tarball (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
+.endif
+
+do-install:
+ ${CP} -Rv ${WRKSRC} ${PREFIX}/lib
+ @${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/lib/MrSID_linux${PORTVERSION}
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|'
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/graphics/mrsidviewer/distinfo b/graphics/mrsidviewer/distinfo
new file mode 100644
index 000000000000..0024507c0cba
--- /dev/null
+++ b/graphics/mrsidviewer/distinfo
@@ -0,0 +1 @@
+MD5 (MrSID_linux2.0.32.tar.Z) = dc9cd24ce60e854c0ad3a90105a376f7
diff --git a/graphics/mrsidviewer/pkg-comment b/graphics/mrsidviewer/pkg-comment
new file mode 100644
index 000000000000..766ed35a5797
--- /dev/null
+++ b/graphics/mrsidviewer/pkg-comment
@@ -0,0 +1 @@
+MrSID Viewer displays images compressed into the MrSID format
diff --git a/graphics/mrsidviewer/pkg-descr b/graphics/mrsidviewer/pkg-descr
new file mode 100644
index 000000000000..219f879362e6
--- /dev/null
+++ b/graphics/mrsidviewer/pkg-descr
@@ -0,0 +1,6 @@
+MrSID Viewer displays images compressed using the proprietary MrSID format.
+
+WWW: http://www.lizardtech.com/
+
+- Chris D. Faulhaber
+ <jedgar@FreeBSD.org>
diff --git a/graphics/mrsidviewer/pkg-message b/graphics/mrsidviewer/pkg-message
new file mode 100644
index 000000000000..fe9aba2b32e7
--- /dev/null
+++ b/graphics/mrsidviewer/pkg-message
@@ -0,0 +1,8 @@
+To use MrSID, add the following to your environment:
+
+ MrSID_HOME=%%PREFIX%%/lib/MrSID_linux2.0.32
+ PATH=$PATH:$MrSID_HOME/bin
+
+and execute:
+
+ $ MrSID
diff --git a/graphics/mrsidviewer/pkg-plist b/graphics/mrsidviewer/pkg-plist
new file mode 100644
index 000000000000..1e9f3f26c6f9
--- /dev/null
+++ b/graphics/mrsidviewer/pkg-plist
@@ -0,0 +1,11 @@
+lib/MrSID_linux2.0.32/app-defaults/MrSID
+lib/MrSID_linux2.0.32/bin/MrSID
+lib/MrSID_linux2.0.32/help/About.doc
+lib/MrSID_linux2.0.32/help/License
+lib/MrSID_linux2.0.32/help/MrSIDview.hlp
+lib/MrSID_linux2.0.32/help/Overview.doc
+lib/MrSID_linux2.0.32/help/Readme
+@dirrm lib/MrSID_linux2.0.32/help
+@dirrm lib/MrSID_linux2.0.32/bin
+@dirrm lib/MrSID_linux2.0.32/app-defaults
+@dirrm lib/MrSID_linux2.0.32