aboutsummaryrefslogtreecommitdiff
path: root/graphics/mtpaint/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 21:42:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 21:42:32 +0000
commit9010280b855a8f663dc0899ba61ab950e6b515da (patch)
treeade0e2be591e771231576c7a69bfc8a5cf0bc252 /graphics/mtpaint/Makefile
parent06a3e062ca8655d412fd71bf237d2cbcb5d17726 (diff)
downloadports-9010280b855a8f663dc0899ba61ab950e6b515da.tar.gz
ports-9010280b855a8f663dc0899ba61ab950e6b515da.zip
Notes
Diffstat (limited to 'graphics/mtpaint/Makefile')
-rw-r--r--graphics/mtpaint/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/graphics/mtpaint/Makefile b/graphics/mtpaint/Makefile
index 49a29be102b9..dd44eca98392 100644
--- a/graphics/mtpaint/Makefile
+++ b/graphics/mtpaint/Makefile
@@ -23,9 +23,9 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
gif.5:${PORTSDIR}/graphics/giflib \
freetype.9:${PORTSDIR}/print/freetype2
-OPTIONS= LCMS2 "Enable ICC color management support" on \
- OPENJPEG "Enable OpenJPEG support" on \
- NLS "Enable Native Language support" on
+OPTIONS_DEFINE= LCMS2 OPENJPEG NLS
+OPTIONS_DEFAULT= LCMS2 OPENJPEG
+OPENJPEG_DESC= Enable OpenJPEG support
USE_BZIP2= yes
USE_GNOME= gtk20
@@ -40,27 +40,27 @@ MAN1= ${PORTNAME}.1
.include <bsd.port.options.mk>
-.if defined(WITHOUT_LCMS2)
-CONFIGURE_ARGS+=nolcms
-.else
+.if ${PORT_OPTIONS:MLCMS2}
LIB_DEPENDS+= lcms2.2:${PORTSDIR}/graphics/lcms2
CONFIGURE_ARGS+=lcms2
+.else
+CONFIGURE_ARGS+=nolcms
.endif
-.if defined(WITHOUT_OPENJPEG)
-LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
-CONFIGURE_ARGS+=jasper
-.else
+.if ${PORT_OPTIONS:MOPENJPEG}
LIB_DEPENDS+= openjpeg.2:${PORTSDIR}/graphics/openjpeg
CONFIGURE_ARGS+=jp2
+.else
+LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
+CONFIGURE_ARGS+=jasper
.endif
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=intl
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
do-install:
@@ -73,7 +73,7 @@ do-install:
${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.png \
${PREFIX}/share/pixmaps
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
.for lang in cs de es fr gl hu it ja nl pl pt pt_BR ru sk sv tl tr zh_CN zh_TW
@${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/po/${lang}.mo \