aboutsummaryrefslogtreecommitdiff
path: root/graphics/mtpaint
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-20 23:21:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-20 23:21:14 +0000
commit4c494ef7f329f89dbc048e6026692396de921dda (patch)
treed6e29209c0a32948a1d8ca9ab1b82ee232a9d259 /graphics/mtpaint
parentbae48bfc96a2ee6e9ff0c837eb59f383ed01d034 (diff)
downloadports-4c494ef7f329f89dbc048e6026692396de921dda.tar.gz
ports-4c494ef7f329f89dbc048e6026692396de921dda.zip
Notes
Diffstat (limited to 'graphics/mtpaint')
-rw-r--r--graphics/mtpaint/Makefile51
-rw-r--r--graphics/mtpaint/distinfo6
-rw-r--r--graphics/mtpaint/pkg-plist7
3 files changed, 43 insertions, 21 deletions
diff --git a/graphics/mtpaint/Makefile b/graphics/mtpaint/Makefile
index aa62e7466be1..6b093fc89a60 100644
--- a/graphics/mtpaint/Makefile
+++ b/graphics/mtpaint/Makefile
@@ -6,41 +6,62 @@
#
PORTNAME= mtpaint
-PORTVERSION= 3.21
+PORTVERSION= 3.30
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple painting program
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- ungif.5:${PORTSDIR}/graphics/libungif \
+LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
+ jasper.4:${PORTSDIR}/graphics/jasper \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- tiff.4:${PORTSDIR}/graphics/tiff \
openjpeg.2:${PORTSDIR}/graphics/openjpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_GNOME= gtk20
HAS_CONFIGURE= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MAN1PREFIX}/man/man1 \
- --locale=${PREFIX}/share/locale gif jpeg tiff slow \
- gtk2 intl man
-MAN1= ${PORTNAME}.1
+ --locale=${PREFIX}/share/locale \
+ gtk2 cflags slow asneeded gif jpeg jp2 tiff man
+
MANCOMPRESSED= yes
+MAN1= ${PORTNAME}.1
-.if !defined(WITHOUT_NLS)
+CFLAGS+= -DU_FREETYPE
+
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+.else
USE_GETTEXT= yes
+CONFIGURE_ARGS+=intl
PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-o /dev/null|-o `mktemp -t /tmp`|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|="/usr"|="${LOCALBASE}"|g ; \
+ s|/usr/X11R6|${LOCALBASE}|g ; \
+ s|GTK_LIB -s|GTK_LIB|g' ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \
+ ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1.gz \
+ ${MANPREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.desktop \
+ ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.png \
+ ${PREFIX}/share/pixmaps
+.if !defined(WITHOUT_NLS)
+.for lang in cs de es fr gl it ja nl pl pt pt_BR ru sk sv tr zh_CN zh_TW
+ @${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/po/${lang}.mo \
+ ${PREFIX}/share/locale/${lang}/LC_MESSAGES/mtpaint.mo
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/graphics/mtpaint/distinfo b/graphics/mtpaint/distinfo
index 9b3448ed054c..7179e42d449e 100644
--- a/graphics/mtpaint/distinfo
+++ b/graphics/mtpaint/distinfo
@@ -1,3 +1,3 @@
-MD5 (mtpaint-3.21.tar.bz2) = f685b6fbb16966dc5d343f0e63932027
-SHA256 (mtpaint-3.21.tar.bz2) = 381eadcf6e4ba7b2554fa527e9654c63153cf52650932d5e9e602c4706b62eb0
-SIZE (mtpaint-3.21.tar.bz2) = 415411
+MD5 (mtpaint-3.30.tar.bz2) = a796b96aca4aeafface5a534253084ca
+SHA256 (mtpaint-3.30.tar.bz2) = b02300ba819b416a38dff8f1bd2cfb673e41c99fc38ef38de6d0248d4cd35c04
+SIZE (mtpaint-3.30.tar.bz2) = 497876
diff --git a/graphics/mtpaint/pkg-plist b/graphics/mtpaint/pkg-plist
index 89df54ce954a..f0785c1d1676 100644
--- a/graphics/mtpaint/pkg-plist
+++ b/graphics/mtpaint/pkg-plist
@@ -1,20 +1,21 @@
bin/mtpaint
share/applications/mtpaint.desktop
%%NLS%%share/locale/cs/LC_MESSAGES/mtpaint.mo
-%%NLS%%share/locale/de_DE/LC_MESSAGES/mtpaint.mo
+%%NLS%%share/locale/de/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/es/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/fr/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/gl/LC_MESSAGES/mtpaint.mo
+%%NLS%%share/locale/it/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/ja/LC_MESSAGES/mtpaint.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/pl/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/pt/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/ru/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/sk/LC_MESSAGES/mtpaint.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/tr/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/mtpaint.mo
share/pixmaps/mtpaint.png
@dirrmtry share/applications
-@dirrmtry %%NLS%%share/locale/de_DE/LC_MESSAGES
-@dirrmtry %%NLS%%share/locale/de_DE