aboutsummaryrefslogtreecommitdiff
path: root/graphics/mtpaint
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-01-28 17:50:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-01-28 17:50:15 +0000
commit3f83242388d2cd2d5f2c7a0586bcc620aa376c2b (patch)
tree9d939670493318d95bc10cc14d1f36a47e8e3e83 /graphics/mtpaint
parentb79d551e9e7a7adabb1bcdc3e266d62510e8dca7 (diff)
downloadports-3f83242388d2cd2d5f2c7a0586bcc620aa376c2b.tar.gz
ports-3f83242388d2cd2d5f2c7a0586bcc620aa376c2b.zip
Notes
Diffstat (limited to 'graphics/mtpaint')
-rw-r--r--graphics/mtpaint/Makefile59
-rw-r--r--graphics/mtpaint/distinfo4
-rw-r--r--graphics/mtpaint/files/patch-configure19
-rw-r--r--graphics/mtpaint/pkg-plist2
4 files changed, 63 insertions, 21 deletions
diff --git a/graphics/mtpaint/Makefile b/graphics/mtpaint/Makefile
index 7e85d3c116c5..a0de96e4f46f 100644
--- a/graphics/mtpaint/Makefile
+++ b/graphics/mtpaint/Makefile
@@ -6,33 +6,61 @@
#
PORTNAME= mtpaint
-PORTVERSION= 3.31
-PORTREVISION= 5
+PORTVERSION= 3.40
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple painting program
-LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
- jasper.4:${PORTSDIR}/graphics/jasper \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- openjpeg.2:${PORTSDIR}/graphics/openjpeg \
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
freetype.9:${PORTSDIR}/print/freetype2
+OPTIONS= GIFLIB "Enable LZW-compressed GIF support" off \
+ LCMS2 "Enable ICC color management support" on \
+ OPENJPEG "Enable OpenJPEG support" on \
+ NLS "Enable Native Language support" on
+
USE_BZIP2= yes
USE_GNOME= gtk20
+USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MAN1PREFIX}/man/man1 \
- --locale=${PREFIX}/share/locale \
- gtk2 cflags slow asneeded GIF jpeg jp2 tiff man
+ --localedir=${PREFIX}/share/locale \
+ gtk2 cflags asneeded ft jpeg tiff man
+MAKE_JOBS_SAFE= yes
-MANCOMPRESSED= yes
MAN1= ${PORTNAME}.1
-CFLAGS+= -DU_FREETYPE
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GIFLIB)
+LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
+CONFIGURE_ARGS+=GIF
+.else
+LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+CONFIGURE_ARGS+=gif
+.endif
+
+.if defined(WITHOUT_LCMS2)
+CONFIGURE_ARGS+=nolcms
+.else
+LIB_DEPENDS+= lcms2.2:${PORTSDIR}/graphics/lcms2
+CONFIGURE_ARGS+=lcms2
+.endif
+
+.if defined(WITHOUT_OPENJPEG)
+LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
+CONFIGURE_ARGS+=jasper
+.else
+LIB_DEPENDS+= openjpeg.2:${PORTSDIR}/graphics/openjpeg
+CONFIGURE_ARGS+=jp2
+.endif
.if defined(WITHOUT_NLS)
PLIST_SUB+= NLS="@comment "
@@ -42,17 +70,10 @@ CONFIGURE_ARGS+=intl
PLIST_SUB+= NLS=""
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|="/usr"|="${LOCALBASE}"|g ; \
- s|/usr/X11R6|${LOCALBASE}|g ; \
- s|GTK_LIB -s|GTK_LIB|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/src/png.c
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \
${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1.gz \
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 \
${MANPREFIX}/man/man1
@${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.desktop \
@@ -60,7 +81,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.png \
${PREFIX}/share/pixmaps
.if !defined(WITHOUT_NLS)
-.for lang in cs de es fr gl it ja nl pl pt pt_BR ru sk sv tr zh_CN zh_TW
+.for lang in cs de es fr gl hu it ja nl pl pt pt_BR ru sk sv tl tr zh_CN zh_TW
@${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/po/${lang}.mo \
${PREFIX}/share/locale/${lang}/LC_MESSAGES/mtpaint.mo
diff --git a/graphics/mtpaint/distinfo b/graphics/mtpaint/distinfo
index e67c0622f6bd..9374f4db231f 100644
--- a/graphics/mtpaint/distinfo
+++ b/graphics/mtpaint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mtpaint-3.31.tar.bz2) = 6274c93c36ec5c1fdc68dcf9fbf7b43b81c443e0f1059907b6c6143ce0ba7284
-SIZE (mtpaint-3.31.tar.bz2) = 501744
+SHA256 (mtpaint-3.40.tar.bz2) = ef321d2b404839c7b909bdf5283eb22a37fbdd35b4cc9e380ddc400573d7c890
+SIZE (mtpaint-3.40.tar.bz2) = 600857
diff --git a/graphics/mtpaint/files/patch-configure b/graphics/mtpaint/files/patch-configure
new file mode 100644
index 000000000000..a0444859630d
--- /dev/null
+++ b/graphics/mtpaint/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.bak 2011-12-30 03:08:17.000000000 +0900
++++ configure 2012-01-06 05:25:11.000000000 +0900
+@@ -68,6 +68,7 @@
+ "tiff" ) NTIFF=YES;;
+ "notiff" ) NTIFF=NO;;
+ "statictiff" ) STATIC_TIFF=TIFF;;
++ "ft" ) NFT=YES;;
+ "noft" ) NFT=NO;;
+ "staticft" ) STATIC_FT=FreeType;;
+ "lcms" ) NCMS=LittleCMS;;
+@@ -471,7 +472,7 @@
+ MARCH=
+ # And leave CFLAGS alone
+ fi
+-[ "$OPTS" != DEBUG ] && LDFLAGS="-s $LDFLAGS" # Strip debug info
++# [ "$OPTS" != DEBUG ] && LDFLAGS="-s $LDFLAGS" # Strip debug info
+ # Set Windows-specific flags
+ if [ "$OS" != "${OS#MinGW/}" ]
+ then
diff --git a/graphics/mtpaint/pkg-plist b/graphics/mtpaint/pkg-plist
index f0785c1d1676..6db9cd2eb919 100644
--- a/graphics/mtpaint/pkg-plist
+++ b/graphics/mtpaint/pkg-plist
@@ -5,6 +5,7 @@ share/applications/mtpaint.desktop
%%NLS%%share/locale/es/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/fr/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/gl/LC_MESSAGES/mtpaint.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/it/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/ja/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/nl/LC_MESSAGES/mtpaint.mo
@@ -14,6 +15,7 @@ share/applications/mtpaint.desktop
%%NLS%%share/locale/ru/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/sk/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/sv/LC_MESSAGES/mtpaint.mo
+%%NLS%%share/locale/tl/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/tr/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/mtpaint.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/mtpaint.mo