aboutsummaryrefslogtreecommitdiff
path: root/graphics/multiraw
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-01-14 09:44:54 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-01-14 09:44:54 +0000
commitbee34da94c9944529cc95bd14a1789a11a67f39c (patch)
treed126ac0dc8f6a8f2ad072928dad5e7a04041497b /graphics/multiraw
parent22e13304f8a76a5e315adbb5d42c0f4aceb82bff (diff)
downloadports-bee34da94c9944529cc95bd14a1789a11a67f39c.tar.gz
ports-bee34da94c9944529cc95bd14a1789a11a67f39c.zip
Notes
Diffstat (limited to 'graphics/multiraw')
-rw-r--r--graphics/multiraw/Makefile55
-rw-r--r--graphics/multiraw/distinfo2
-rw-r--r--graphics/multiraw/pkg-descr23
3 files changed, 80 insertions, 0 deletions
diff --git a/graphics/multiraw/Makefile b/graphics/multiraw/Makefile
new file mode 100644
index 000000000000..e5b1ebe0d102
--- /dev/null
+++ b/graphics/multiraw/Makefile
@@ -0,0 +1,55 @@
+# Created by: "Waitman Gobble" <uzimac@da3m0n8t3r.com>
+# $FreeBSD$
+# New ports collection makefile for: multiraw
+# Date created: 29 March 2013
+
+PORTNAME= multiraw
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= GH
+DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-0-g${GH_COMMIT}
+
+MAINTAINER= waitman@waitman.net
+COMMENT= Parallel process Camera RAW files using pthreads
+
+LICENSE= MULTIRAW
+LICENSE_NAME= MULTIRAW BSD LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
+
+RUN_DEPENDS= ${LOCALBASE}/bin/dcraw:${PORTSDIR}/graphics/dcraw \
+ ${LOCALBASE}/bin/dcraw-m:${PORTSDIR}/graphics/dcraw-m
+
+USE_GITHUB= yes
+GH_ACCOUNT= waitman
+GH_PROJECT= multiraw
+GH_COMMIT= 71a7651
+GH_TAGNAME= ${GH_COMMIT}
+
+WRKSRC= ${WRKDIR}/waitman-multiraw-${GH_COMMIT}
+
+PLIST_FILES= bin/multiraw man/man7/multiraw.7.gz
+PORTDOCS= *
+
+WITH_PTHREAD= yes
+
+OPTIONS_DEFINE= OPTIMIZE_O3
+OPTIMIZE_O3_DESC= Use O3 Optimization
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MOPTIMIZE_O3}
+CFLAGS+= -O3
+.endif
+
+CFLAGS+= -std=c99 -pthread
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/multiraw ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/multiraw.7 ${STAGEDIR}${PREFIX}/man/man7/
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/multiraw/distinfo b/graphics/multiraw/distinfo
new file mode 100644
index 000000000000..2096a2d6a051
--- /dev/null
+++ b/graphics/multiraw/distinfo
@@ -0,0 +1,2 @@
+SHA256 (waitman-multiraw-1.0-0-g71a7651.tar.gz) = cc62eb00fa067d05f6853e578c68f1f6ade7eb9962c3cdb86187cd4889b89bb2
+SIZE (waitman-multiraw-1.0-0-g71a7651.tar.gz) = 4262
diff --git a/graphics/multiraw/pkg-descr b/graphics/multiraw/pkg-descr
new file mode 100644
index 000000000000..d6ec66e9de43
--- /dev/null
+++ b/graphics/multiraw/pkg-descr
@@ -0,0 +1,23 @@
+Processing Camera Raw files to JPEG, TIFF, or PPM formats is extremely time
+intensive. Utilizing multiple threads on multi-core systems can realize an
+increase of productivity and time savings of 60%.
+
+The multiraw.c program allows the user to batch convert Camera Raw format files
+in parallel using pthreads. The user may specify the number of threads to run,
+or they may use the Auto Thread switch which will cause the software to
+determine the appropriate number of threads based on the task requested.
+By default, multiraw.c calls dcraw-m, which is included. If the user wishes
+to use the unmodified dcraw program, it may be specified using the -o switch.
+
+Use the -n switch to specify number of threads, or use -a to instruct the
+software to automatically determine the optimal number of threads to use
+depending on the commanded task.
+
+multiraw uses dcraw-m, a modified version of dcraw which automatically
+rotates exported thumbnails and has a camera timezone offset adjustment
+variable.
+
+WWW:
+https://dx.burplex.com/bin/multiraw.html
+https://dx.burplex.com/bin/autorot.html
+https://dx.burplex.com/bin/photohack.html