aboutsummaryrefslogtreecommitdiff
path: root/graphics/multivideo/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-11-09 22:37:56 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-11-09 22:37:56 +0000
commitd97b9ad7423beee883fb8b82c26469bb10a57d56 (patch)
treea3eb308d36c0ae8ff1acddb92d5fcebdbc0352e9 /graphics/multivideo/Makefile
parentf35f3b69bdbee62ecca392bcbb480713ca2bdc0d (diff)
downloadports-d97b9ad7423beee883fb8b82c26469bb10a57d56.tar.gz
ports-d97b9ad7423beee883fb8b82c26469bb10a57d56.zip
Notes
Diffstat (limited to 'graphics/multivideo/Makefile')
-rw-r--r--graphics/multivideo/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/multivideo/Makefile b/graphics/multivideo/Makefile
index ef1c3ebaec02..f365d85573ef 100644
--- a/graphics/multivideo/Makefile
+++ b/graphics/multivideo/Makefile
@@ -16,7 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= An image sequence viewer
-LIB_DEPENDS= wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk
+LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -26,11 +26,15 @@ USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
ALL_TARGET= default
+WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.4-config
+
post-patch:
@${REINPLACE_CMD} -e 's|g++|\$$\(CXX)|g ; \
s|-O2 -g -Wall -W|\$$\(CXXFLAGS\)|g ; \
s|[(]CC[)]|\(CXX\)|g ; \
- s|gcc|\$$\(CXX\)|g' ${WRKSRC}/Makefile
+ s|gcc|\$$\(CXX\)|g ; \
+ s|wx-config|${WX_CONFIG}|g' \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/multivideo ${PREFIX}/bin