aboutsummaryrefslogtreecommitdiff
path: root/graphics/multivideo
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-19 06:59:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-19 06:59:02 +0000
commitbf9582b9bd9e0c78c5f980d238f849dfbb448b8d (patch)
tree20122567ec7b37e0673879296220cbcc34db237d /graphics/multivideo
parentab8820a78b30cd3bf50c1d7aa4f59e046bbe6680 (diff)
downloadports-bf9582b9bd9e0c78c5f980d238f849dfbb448b8d.tar.gz
ports-bf9582b9bd9e0c78c5f980d238f849dfbb448b8d.zip
Notes
Diffstat (limited to 'graphics/multivideo')
-rw-r--r--graphics/multivideo/Makefile25
-rw-r--r--graphics/multivideo/distinfo1
-rw-r--r--graphics/multivideo/pkg-comment1
-rw-r--r--graphics/multivideo/pkg-descr21
-rw-r--r--graphics/multivideo/pkg-plist1
5 files changed, 49 insertions, 0 deletions
diff --git a/graphics/multivideo/Makefile b/graphics/multivideo/Makefile
new file mode 100644
index 000000000000..a2a3cb53196a
--- /dev/null
+++ b/graphics/multivideo/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: multivideo
+# Date created: Oct 18, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= multivideo
+PORTVERSION= 0.1.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.lis.inpg.fr/scientifique/bonnaud/multivideo/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+ALL_TARGET= # empty
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/multivideo ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/multivideo/distinfo b/graphics/multivideo/distinfo
new file mode 100644
index 000000000000..ac56347af684
--- /dev/null
+++ b/graphics/multivideo/distinfo
@@ -0,0 +1 @@
+MD5 (multivideo-0.1.0-src.tar.bz2) = eca90f55614a217a553e70b3836a8989
diff --git a/graphics/multivideo/pkg-comment b/graphics/multivideo/pkg-comment
new file mode 100644
index 000000000000..ab23ba70c202
--- /dev/null
+++ b/graphics/multivideo/pkg-comment
@@ -0,0 +1 @@
+An image sequence viewer
diff --git a/graphics/multivideo/pkg-descr b/graphics/multivideo/pkg-descr
new file mode 100644
index 000000000000..0eaa9f6be625
--- /dev/null
+++ b/graphics/multivideo/pkg-descr
@@ -0,0 +1,21 @@
+MultiVideo is an image sequence viewer that is targeted to researchers in the
+image processing field. It has the following features:
+ * Display of several sequences simultaneously in multiple synchronized views.
+ * Support of many sequence formats, including formats without compression
+ that are very useful for researchers:
+ o single file YUV 4:2:0 sequence
+ o sequences made of several files (one file per image).
+ o easy extension by C++ class derivation
+ * Display very long image sequences without loading them in memory.
+ * Gobal slider for random access in sequences.
+ * Local sliders in each sequence frame for temporal adjustment with respect
+ to other sequences.
+ * Multithreaded design to allow for efficient image preloading.
+ * On the fly zooming of images.
+ * Repetitive display of the sequence in loop or ping-pong mode.
+ * Choice of sequences to display on the command line or in a GUI file
+ browser.
+ * Adjustment of the display frame rate.
+ * Saving an image of the sequence in PGM, PPM, PNG or JPEG format.
+
+WWW: http://www.lis.inpg.fr/scientifique/bonnaud/multivideo/
diff --git a/graphics/multivideo/pkg-plist b/graphics/multivideo/pkg-plist
new file mode 100644
index 000000000000..fd2f8c87cbad
--- /dev/null
+++ b/graphics/multivideo/pkg-plist
@@ -0,0 +1 @@
+bin/multivideo