aboutsummaryrefslogtreecommitdiff
path: root/graphics/mupdf/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-04 20:19:28 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-04 20:19:28 +0000
commitd9d7c9a7b90be0f595d929bd412006b76c98fb16 (patch)
tree774d839d5d044c66a5331014fbe3be10add31f54 /graphics/mupdf/Makefile
parente59577307d1d2e6edbd1470ffe5ddc10e5ef458f (diff)
downloadports-d9d7c9a7b90be0f595d929bd412006b76c98fb16.tar.gz
ports-d9d7c9a7b90be0f595d929bd412006b76c98fb16.zip
Notes
Diffstat (limited to 'graphics/mupdf/Makefile')
-rw-r--r--graphics/mupdf/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index c472c7d01920..79fb2a72cb6e 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -2,15 +2,14 @@
# $FreeBSD$
PORTNAME= mupdf
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.5
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE \
http://www.mupdf.com/download/
-EXTRACT_SUFX= -source.zip
+EXTRACT_SUFX= -source.tar.gz
-MAINTAINER= lichray@gmail.com
+MAINTAINER= udvzsolt@gmail.com
COMMENT= Lightweight PDF viewer and toolkit
LICENSE= AGPLv3
@@ -18,11 +17,13 @@ LICENSE= AGPLv3
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libjbig2dec.so:${PORTSDIR}/graphics/jbig2dec \
- libopenjpeg.so:${PORTSDIR}/graphics/openjpeg15
+ libopenjp2.so:${PORTSDIR}/graphics/openjpeg
MAKE_ARGS+= build=release prefix=${PREFIX} verbose=1 mandir=${PREFIX}/man \
- XCFLAGS=-I${LOCALBASE}/include
-USES= pkgconfig gmake zip
+ HAVE_X11=yes \
+ XCFLAGS="`pkg-config --cflags freetype2` -I ${LOCALBASE}/include" \
+ XLIBS="`pkg-config --libs freetype2 libopenjp2 x11 xext` -ljpeg -ljbig2dec"
+USES= pkgconfig gmake
USE_XORG= x11 xext
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
@@ -42,7 +43,7 @@ CFLAGS+= -mfpmath=sse
.endif
.if ${PORT_OPTIONS:MSCROLL}
-EXTRA_PATCHES+= ${FILESDIR}/scroll_hack-apps_pdfapp.c
+EXTRA_PATCHES+= ${FILESDIR}/scroll_hack-platform__x11__pdfapp.c
.endif
.if ${PORT_OPTIONS:MJS}
@@ -50,17 +51,16 @@ LIB_DEPENDS+= libv8.so:${PORTSDIR}/lang/v8
MAKE_ARGS+= V8_PRESENT=1 V8LIBS=-lv8
.endif
-post-patch: .SILENT
- ${REINPLACE_CMD} \
- -e '/install:/,/^$$/ { /-d/d; }' \
- -e '/install.*bindir)$$/s/install/$$(BSD_INSTALL_PROGRAM)/' \
- -e '/install.*libdir)$$/s/install/$$(BSD_INSTALL_DATA)/' \
- -e '/install.*incdir)$$/s/install/$$(BSD_INSTALL_DATA)/' \
- -e '/install.*man1$$/s/install/$$(BSD_INSTALL_MAN)/' \
- ${WRKSRC}/Makefile
+post-patch:
${REINPLACE_CMD} -e 's/-pipe -O2 //' \
-e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/Makerules
${RM} -r ${WRKSRC}/thirdparty/*
+post-install:
+ ${MV} ${STAGEDIR}${PREFIX}/bin/mupdf-x11 ${STAGEDIR}${PREFIX}/bin/mupdf
+.for binary in mudraw mutool mujstest mupdf
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${binary}
+.endfor
+
.include <bsd.port.mk>