aboutsummaryrefslogtreecommitdiff
path: root/graphics/mupdf
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-09-20 11:06:56 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-09-20 11:06:56 +0000
commitfc065deb34d9e044eb6528530b38a282a4a3b984 (patch)
tree6a81adf93600a69c49a3720fa8a124a5013bba5d /graphics/mupdf
parent3f4f160e3bd2a9bb6bb57e99fa979f8a6509a3ad (diff)
downloadports-fc065deb34d9e044eb6528530b38a282a4a3b984.tar.gz
ports-fc065deb34d9e044eb6528530b38a282a4a3b984.zip
Notes
Diffstat (limited to 'graphics/mupdf')
-rw-r--r--graphics/mupdf/Makefile19
-rw-r--r--graphics/mupdf/distinfo4
-rw-r--r--graphics/mupdf/pkg-descr6
-rw-r--r--graphics/mupdf/pkg-plist5
4 files changed, 13 insertions, 21 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index 1642d0d09a64..401f79be40b1 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -1,11 +1,8 @@
-# New ports collection makefile for: mupdf
-# Date created: 2009-08-07
-# Whom: Martin Dieringer <martin.dieringer@gmx.de>
-#
+# Created by: Martin Dieringer <martin.dieringer@gmx.de>
# $FreeBSD$
PORTNAME= mupdf
-PORTVERSION= 1.0
+PORTVERSION= 1.1
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE \
@@ -16,7 +13,6 @@ MAINTAINER= lichray@gmail.com
COMMENT= Lightweight PDF viewer and toolkit
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
jpeg:${PORTSDIR}/graphics/jpeg \
@@ -26,8 +22,8 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
USE_GMAKE= yes
MAKE_ARGS+= build=release prefix=${PREFIX} verbose=1 mandir=${PREFIX}/man
USE_XORG= x11 xext
-USE_GNOME= pkgconfig
-MAN1= mupdf.1 mupdfclean.1 mudraw.1 mupdfshow.1
+USE_PKGCONFIG= build
+MAN1= mupdf.1 mubusy.1 mudraw.1
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
@@ -35,7 +31,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
OPTIONS_DEFINE= SCROLL
OPTIONS_DEFAULT=SCROLL
-SCROLL_DESC= "Build with scroll hacks"
+SCROLL_DESC= Build with scroll hacks
.include <bsd.port.options.mk>
@@ -53,7 +49,7 @@ post-patch: .SILENT
${REINPLACE_CMD} \
-e '/install:/,/^$$/ { /-d/d; }' \
-e '/install.*bindir)$$/s/install/$$(BSD_INSTALL_PROGRAM)/' \
- -e '/install.*libdir)$$/s/install/$$(BSD_INSTALL_LIB)/' \
+ -e '/install.*libdir)$$/s/install/$$(BSD_INSTALL_DATA)/' \
-e '/install.*incdir)$$/s/install/$$(BSD_INSTALL_DATA)/' \
-e '/install.*man1$$/s/install/$$(BSD_INSTALL_MAN)/' \
${WRKSRC}/Makefile
@@ -61,5 +57,4 @@ post-patch: .SILENT
-e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/Makerules
-.include <bsd.port.pre.mk>
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/mupdf/distinfo b/graphics/mupdf/distinfo
index c7420c78ae53..6b9ac4917a6e 100644
--- a/graphics/mupdf/distinfo
+++ b/graphics/mupdf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mupdf-1.0-source.tar.gz) = 4f5e12625f7f827f6eb5606026c9a7a7dbdeaf935fcea3bc173ed8d469698ec2
-SIZE (mupdf-1.0-source.tar.gz) = 4208530
+SHA256 (mupdf-1.1-source.tar.gz) = e54666bbe1d9f0a5464349bfbeffcf676c4a0fcad3efb89eba1f20d4ac991f34
+SIZE (mupdf-1.1-source.tar.gz) = 4281735
diff --git a/graphics/mupdf/pkg-descr b/graphics/mupdf/pkg-descr
index 4c6d243c6c9e..15e42ff3dc96 100644
--- a/graphics/mupdf/pkg-descr
+++ b/graphics/mupdf/pkg-descr
@@ -1,13 +1,13 @@
-MuPDF is a lightweight PDF viewer and toolkit written in portable C.
+MuPDF is a lightweight PDF viewer and toolkit written in portable C.
The renderer in MuPDF is tailored for high quality anti-aliased graphics. It
renders text with metrics and spacing accurate to within fractions of a
pixel for the highest fidelity in reproducing the look of a printed page on
-screen.
+screen.
MuPDF has a small footprint. A binary that includes the standard Roman fonts
is only one megabyte. A build with full CJK support (including an Asian
-font) is approximately five megabytes.
+font) is approximately five megabytes.
MuPDF has support for all non-interactive PDF 1.7 features, and the toolkit
provides a simple API for accessing the internal structures of the PDF
diff --git a/graphics/mupdf/pkg-plist b/graphics/mupdf/pkg-plist
index 02ca45e80996..f569c835520a 100644
--- a/graphics/mupdf/pkg-plist
+++ b/graphics/mupdf/pkg-plist
@@ -1,9 +1,6 @@
+bin/mubusy
bin/mupdf
-bin/mupdfclean
bin/mudraw
-bin/mupdfextract
-bin/mupdfinfo
-bin/mupdfshow
include/fitz.h
include/memento.h
include/mucbz.h