aboutsummaryrefslogtreecommitdiff
path: root/graphics/mxp/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-21 13:19:18 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-21 13:19:18 +0000
commit418ee4a320006247af00c04a257483a97be3d758 (patch)
treea3d97cc0609c97650013d7e0850bf1c439542619 /graphics/mxp/Makefile
parent196611c2f87f04be865f158d047a361a4f66949a (diff)
Notes
Diffstat (limited to 'graphics/mxp/Makefile')
-rw-r--r--graphics/mxp/Makefile50
1 files changed, 29 insertions, 21 deletions
diff --git a/graphics/mxp/Makefile b/graphics/mxp/Makefile
index 05425938c7cd..30f059b18ddb 100644
--- a/graphics/mxp/Makefile
+++ b/graphics/mxp/Makefile
@@ -3,41 +3,49 @@
PORTNAME= mxp
PORTVERSION= 1.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
-MASTER_SITES= SUNSITE
-MASTER_SITE_SUBDIR=apps/math/fractals
+MASTER_SITES= SUNSITE/apps/math/fractals
MAINTAINER= ports@FreeBSD.org
COMMENT= Application for computing/exploring Mandelbrot set
+LICENSE= GPLv2
+
WRKSRC= ${WRKDIR}/${PORTNAME}
-ALL_TARGET=
+
USE_XORG= xaw xbitmaps xpm
+ALL_TARGET= ${PORTNAME}
MAKE_JOBS_UNSAFE= yes
-PLIST_FILES= bin/${PORTNAME} \
- %%PORTDOCS%%%%DOCSDIR%%/README
-PLIST_DIRS= %%PORTDOCS%%%%DOCSDIR%%
+CFLAGS+= -Wno-error=return-type
+CPPFLAGS+= -I${LOCALBASE}/include -DXPM
+LDFLAGS+= -L${LOCALBASE}/lib -lXpm
-NO_STAGE= yes
+PORTDOCS= README
+PLIST_FILES= bin/${PORTNAME} share/pixmaps/${PORTNAME}.xpm
-OPTIONS_DEFINE= DOCS
+DESKTOP_ENTRIES="Mxp" "Mandelbrot Explorer" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.xpm" "${PORTNAME}" \
+ "" ""
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
-post-extract:
- @${CP} ${WRKSRC}/Makefile.noimake ${WRKSRC}/Makefile
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g; \
- s|%%LOCALBASE%%|${LOCALBASE}|g; \
- s|%%CFLAGS%%|${CFLAGS}|g; \
- s|%%CC%%|${CC}|g' ${WRKSRC}/Makefile
+ @(cd ${WRKSRC} && ${SED} -e \
+ 's|$$(XINC)|$$(CPPFLAGS)| ; \
+ s|-L/X/X11/lib|$$(LDFLAGS)|' Makefile.noimake > Makefile)
+
+post-build:
+ @${LN} -sf icon.xpm ${WRKSRC}/${PORTNAME}.xpm
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTNAME}.xpm \
+ ${STAGEDIR}${PREFIX}/share/pixmaps)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} \
+ ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>