aboutsummaryrefslogtreecommitdiff
path: root/graphics/mypaint
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-10-07 19:03:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-10-07 19:03:57 +0000
commit007426d8eab4ad6c63570c3bcccae527b5ed8a4a (patch)
treea3e87b9c35eb4e0c0c7f210d098ad8bbdc66ee60 /graphics/mypaint
parentf1cfd38116d27d7066b5fcb3622fa095d82a6341 (diff)
downloadports-007426d8eab4ad6c63570c3bcccae527b5ed8a4a.tar.gz
ports-007426d8eab4ad6c63570c3bcccae527b5ed8a4a.zip
Notes
Diffstat (limited to 'graphics/mypaint')
-rw-r--r--graphics/mypaint/Makefile10
-rw-r--r--graphics/mypaint/files/patch-SConstruct5
2 files changed, 8 insertions, 7 deletions
diff --git a/graphics/mypaint/Makefile b/graphics/mypaint/Makefile
index ea9bc3b41e21..26ac94641f90 100644
--- a/graphics/mypaint/Makefile
+++ b/graphics/mypaint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mypaint
PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= https://github.com/mypaint/mypaint/releases/download/${PORTVERSION:S/^/v/}/
@@ -21,6 +21,9 @@ LIB_DEPENDS= libjson-c.so:devel/json-c \
liblcms2.so:graphics/lcms2
RUN_DEPENDS= ${PYNUMPY}
+# XXX Embed RPATH via USES=fortran for py-numpy to load libgcc_s.so from ports
+USES= desktop-file-utils fortran gettext gnome localbase \
+ pkgconfig python:2.7 scons tar:xz
BINARY_ALIAS= swig=swig3.0
USE_GNOME= gtk30 pygobject3 librsvg2:run
CFLAGS+= ${CFLAGS_${CHOSEN_COMPILER_TYPE}}
@@ -30,9 +33,6 @@ MAKE_ARGS= prefix=${PREFIX} \
use_sharedlib=True \
python_binary="${PYTHON_CMD}" \
python_config="${PYTHON_CMD}-config"
-# XXX Embed RPATH via USES=fortran for py-numpy to load libgcc_s.so from ports
-USES= desktop-file-utils fortran gettext localbase \
- pkgconfig python:2.7 scons tar:xz
INSTALL_TARGET= ${STAGEDIR} --install-sandbox=${STAGEDIR}
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -42,7 +42,7 @@ OPTIONS_DEFAULT= OPENMP
OPTIONS_SUB= yes
GEGL_DESC= Graph based image processing framework support
-GEGL_LIB_DEPENDS= libgegl-0.3.so:graphics/gegl3
+GEGL_LIB_DEPENDS= libgegl-0.4.so:graphics/gegl
GEGL_MAKE_ARGS= enable_gegl=True
OPENMP_USES= compiler:openmp
diff --git a/graphics/mypaint/files/patch-SConstruct b/graphics/mypaint/files/patch-SConstruct
index dddcd49e4594..e1d2a7851129 100644
--- a/graphics/mypaint/files/patch-SConstruct
+++ b/graphics/mypaint/files/patch-SConstruct
@@ -1,4 +1,4 @@
---- SConstruct.orig 2016-01-15 19:42:54 UTC
+--- SConstruct.orig 2017-01-21 17:51:52 UTC
+++ SConstruct
@@ -95,14 +95,14 @@ if "$CCFLAGS" in env['CXXCOM']:
@@ -11,7 +11,8 @@
+#env.Append(CCFLAGS='-Wall')
+#env.Append(CFLAGS='-std=c99')
- env['GEGL_VERSION'] = 0.3
+-env['GEGL_VERSION'] = 0.3
++env['GEGL_VERSION'] = 0.4
# Define strdup() in string.h under glibc >= 2.10 (POSIX.1-2008)
-env.Append(CFLAGS='-D_POSIX_C_SOURCE=200809L')