aboutsummaryrefslogtreecommitdiff
path: root/graphics/netpbm/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-05-12 11:39:23 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2014-05-12 11:39:23 +0000
commit6788c685587517902c6010a67a3cb3b1a4b87886 (patch)
tree27b078ed626a662375925bd12bb3c629fada397c /graphics/netpbm/Makefile
parent8f6b583fe99f5b402e94f04981aab6fd7062fdb3 (diff)
downloadports-6788c685587517902c6010a67a3cb3b1a4b87886.tar.gz
ports-6788c685587517902c6010a67a3cb3b1a4b87886.zip
Notes
Diffstat (limited to 'graphics/netpbm/Makefile')
-rw-r--r--graphics/netpbm/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index e4b41b67d32a..191755653549 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= netpbm
-PORTVERSION= 10.35.89
-PORTREVISION= 1
+PORTVERSION= 10.35.92
CATEGORIES= graphics
MASTER_SITES= SF/netpbm/super_stable/${PORTVERSION} \
${MASTER_SITE_LOCAL:S/$/:man/}
@@ -20,7 +19,7 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libjasper.so:${PORTSDIR}/graphics/jasper \
libxml2.so:${PORTSDIR}/textproc/libxml2
-USES= gmake perl5
+USES= gmake perl5 shebangfix
CFLAGS+= -DPNG_DEPSTRUCT= -Iutil
MAKE_ENV= LN="${LN}" RANLIB="${RANLIB}"
MAKEFILE= GNUmakefile
@@ -28,6 +27,9 @@ MAKEFILE2= Makefile
INSTALL_TARGET= install.bin install.lib install.data install-dev
USE_LDCONFIG= yes
+SHEBANG_FILES= editor/pnmflip editor/pnmquant editor/ppmfade \
+ editor/ppmquant editor/ppmshadow generator/ppmrainbow
+
OPTIONS_DEFINE= X11 MANPAGES
OPTIONS_SUB= yes