aboutsummaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-05-25 20:13:48 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-05-25 20:13:48 +0000
commit7009583ffbcfe410c9ea89cbe422b7ee19529960 (patch)
treeca7ad93a433a1ca7574557a1a16cd848213e5a76 /graphics/netpbm
parent28d4c2a7be41a939a6c6ef008e53708d03228cbf (diff)
downloadports-7009583ffbcfe410c9ea89cbe422b7ee19529960.tar.gz
ports-7009583ffbcfe410c9ea89cbe422b7ee19529960.zip
Notes
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile17
-rw-r--r--graphics/netpbm/distinfo3
-rw-r--r--graphics/netpbm/files/converter-other-cameratopam-identify.patch26
-rw-r--r--graphics/netpbm/files/converter-other-pstopnm.patch (renamed from graphics/netpbm/files/patch-converter-other-pstopnm.c)0
-rw-r--r--graphics/netpbm/files/editor-pnmquant-devel.patch20
-rw-r--r--graphics/netpbm/files/editor-pnmquant-stable.patch (renamed from graphics/netpbm/files/patch-editor-pnmquant)0
-rw-r--r--graphics/netpbm/pkg-plist13
7 files changed, 79 insertions, 0 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 9609486c7573..67265629c110 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -6,11 +6,18 @@
#
PORTNAME= netpbm
+.if defined(WITH_NETPBM_DEVEL)
+PORTVERSION= 10.30
+.else
PORTVERSION= 10.26.28
+.endif
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .tgz
+.if defined(WITH_NETPBM_DEVEL)
+PKGNAMESUFFIX= -devel${PKGNAMESUFFIX2}
+.endif
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A toolkit for conversion of images between different formats
@@ -42,6 +49,16 @@ CFLAGS+= -O0
.endif
.endif
+.if defined(WITH_NETPBM_DEVEL)
+EXTRA_PATCHES+= ${FILESDIR}/editor-pnmquant-devel.patch
+EXTRA_PATCHES+= ${FILESDIR}/converter-other-cameratopam-identify.patch
+PLIST_SUB+= DEVEL=""
+.else
+EXTRA_PATCHES+= ${FILESDIR}/editor-pnmquant-stable.patch
+EXTRA_PATCHES+= ${FILESDIR}/converter-other-pstopnm.patch
+PLIST_SUB+= DEVEL="@comment "
+.endif
+
pre-configure:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
diff --git a/graphics/netpbm/distinfo b/graphics/netpbm/distinfo
index b2dbb912310e..f3b847ffe313 100644
--- a/graphics/netpbm/distinfo
+++ b/graphics/netpbm/distinfo
@@ -1,3 +1,6 @@
MD5 (netpbm-10.26.28.tgz) = e5675ab49b164517f2eac679f1ff0119
SHA256 (netpbm-10.26.28.tgz) = b442a26fcd7691120b062ca8807b44a3877056577e923654a5474a389c4f87ad
SIZE (netpbm-10.26.28.tgz) = 2540748
+MD5 (netpbm-10.30.tgz) = f84620e2733fb13eebe1394948077342
+SHA256 (netpbm-10.30.tgz) = cf682d5cbe185d535c12f65067c7ce991601d16595125c502cf4f8c15a6f801c
+SIZE (netpbm-10.30.tgz) = 2370761
diff --git a/graphics/netpbm/files/converter-other-cameratopam-identify.patch b/graphics/netpbm/files/converter-other-cameratopam-identify.patch
new file mode 100644
index 000000000000..283a2480b9b6
--- /dev/null
+++ b/graphics/netpbm/files/converter-other-cameratopam-identify.patch
@@ -0,0 +1,26 @@
+
+
+19 Mai 06:06 2006 diff -u -l converter/other/cameratopam/identify.c.orig converter/other/cameratopam/identify.c Page 1
+
+
+--- converter/other/cameratopam/identify.c.orig Sat Aug 27 19:29:58 2005
++++ converter/other/cameratopam/identify.c Fri May 19 06:06:28 2006
+@@ -25,7 +25,7 @@
+
+
+ /* This does the same as the function of the same name in the GNU C library */
+-static const char *memmem (const char *haystack, size_t haystacklen,
++static const char *memmem_old (const char *haystack, size_t haystacklen,
+ const char *needle, size_t needlelen)
+ {
+ const char *c;
+@@ -316,7 +316,7 @@
+ fread (head, 1, 32, ifp);
+ fseek (ifp, 0, SEEK_END);
+ fsize = ftell(ifp);
+- if ((c = (char*)memmem (head, 32, "MMMMRawT", 8))) {
++ if ((c = (char*)memmem_old (head, 32, "MMMMRawT", 8))) {
+ strcpy (make, "Phase One");
+ data_offset = c - head;
+ fseek (ifp, data_offset + 8, SEEK_SET);
+
diff --git a/graphics/netpbm/files/patch-converter-other-pstopnm.c b/graphics/netpbm/files/converter-other-pstopnm.patch
index 23626cd1a634..23626cd1a634 100644
--- a/graphics/netpbm/files/patch-converter-other-pstopnm.c
+++ b/graphics/netpbm/files/converter-other-pstopnm.patch
diff --git a/graphics/netpbm/files/editor-pnmquant-devel.patch b/graphics/netpbm/files/editor-pnmquant-devel.patch
new file mode 100644
index 000000000000..60019a46e93f
--- /dev/null
+++ b/graphics/netpbm/files/editor-pnmquant-devel.patch
@@ -0,0 +1,20 @@
+--- editor/pnmquant.orig Sun Feb 19 22:03:42 2006
++++ editor/pnmquant Mon Feb 20 09:41:57 2006
+@@ -116,7 +118,7 @@
+ tell(INFH); # Avoids bogus "INFH is not referenced" warning
+ }
+ } else {
+- open(STDIN, "<", $infile)
++ open(STDIN, "<" . $infile)
+ or die("Unable to open input file '$infile'. Errno=$ERRNO");
+ }
+ }
+@@ -157,7 +159,7 @@
+ $spreadOpt = "-spreadbrightness";
+ }
+
+- open(STDOUT, ">", $mapfileSpec);
++ open(STDOUT, ">" . $mapfileSpec);
+
+ my $maprc = system("pnmcolormap", $ncolors, $averageOpt, $spreadOpt);
+
diff --git a/graphics/netpbm/files/patch-editor-pnmquant b/graphics/netpbm/files/editor-pnmquant-stable.patch
index f61ca961c530..f61ca961c530 100644
--- a/graphics/netpbm/files/patch-editor-pnmquant
+++ b/graphics/netpbm/files/editor-pnmquant-stable.patch
diff --git a/graphics/netpbm/pkg-plist b/graphics/netpbm/pkg-plist
index ff36e6fac44f..087429f2dd32 100644
--- a/graphics/netpbm/pkg-plist
+++ b/graphics/netpbm/pkg-plist
@@ -6,6 +6,7 @@ bin/bioradtopgm
bin/bmptopnm
bin/bmptoppm
bin/brushtopbm
+%%DEVEL%%bin/cameratopam
bin/cmuwmtopbm
bin/ddbugtopbm
bin/escp2topbm
@@ -37,7 +38,9 @@ bin/mrftopbm
bin/mtvtoppm
bin/neotoppm
bin/palmtopnm
+%%DEVEL%%bin/pamaddnoise
bin/pamarith
+%%DEVEL%%bin/pambayer
bin/pamchannel
bin/pamcomp
bin/pamcut
@@ -53,9 +56,11 @@ bin/pamfunc
bin/pamgauss
bin/pamlookup
bin/pammasksharpen
+%%DEVEL%%bin/pammixinterlace
bin/pamoil
bin/pamperspective
bin/pampop9
+%%DEVEL%%bin/pamrgbatopng
bin/pamscale
bin/pamseq
bin/pamsharpmap
@@ -67,12 +72,15 @@ bin/pamstretch
bin/pamstretch-gen
bin/pamsumm
bin/pamsummcol
+%%DEVEL%%bin/pamtilt
bin/pamtodjvurle
+%%DEVEL%%bin/pamtofits
bin/pamtohdiff
bin/pamtohtmltbl
bin/pamtopfm
bin/pamtopnm
bin/pamtotga
+%%DEVEL%%bin/pamtotiff
bin/pamtouil
bin/pbmclean
bin/pbmlife
@@ -139,6 +147,7 @@ bin/pgmramp
bin/pgmslice
bin/pgmtexture
bin/pgmtofs
+%%DEVEL%%bin/pgmmedian
bin/pgmtolispm
bin/pgmtopbm
bin/pgmtopgm
@@ -209,9 +218,13 @@ bin/ppmchange
bin/ppmcie
bin/ppmcolormask
bin/ppmcolors
+%%DEVEL%%bin/ppmdcfont
+%%DEVEL%%bin/ppmddumpfont
bin/ppmdim
bin/ppmdist
bin/ppmdither
+%%DEVEL%%bin/ppmdmkfont
+%%DEVEL%%bin/ppmdraw
bin/ppmfade
bin/ppmflash
bin/ppmforge