aboutsummaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2011-05-11 04:19:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2011-05-11 04:19:52 +0000
commitd96e84a01a894290f6275938d163d296e8164a5b (patch)
tree4cabaf17abf74c570b0914874b9e5a89f6b86369 /graphics/netpbm
parentc38d260b49a4cd6edf6972f834944c438c062b8e (diff)
downloadports-d96e84a01a894290f6275938d163d296e8164a5b.tar.gz
ports-d96e84a01a894290f6275938d163d296e8164a5b.zip
Notes
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile4
-rw-r--r--graphics/netpbm/files/patch-Makefile.common15
-rw-r--r--graphics/netpbm/files/patch-ppmtompeg-Makefile12
3 files changed, 25 insertions, 6 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 2109b9b1e17a..e825442e92c2 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -29,6 +29,7 @@ USE_GMAKE= yes
CFLAGS+= -DPNG_DEPSTRUCT= -Iutil
MAKE_ENV= LN="${LN}" RANLIB="${RANLIB}"
MAKEFILE= GNUmakefile
+MAKEFILE2= Makefile
INSTALL_TARGET= install.bin install.lib install.data install-dev
USE_LDCONFIG= yes
@@ -43,9 +44,6 @@ PLIST_SUB+= X11='@comment '
.endif
pre-configure:
- @if [ -e ${DESTDIR}/${LOCALBASE}/include/pm.h ]; then \
- (${ECHO_MSG} "===> Cannot build with netpbm installed, please deinstall first"; exit 1) \
- fi
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/pm_config.in.h
diff --git a/graphics/netpbm/files/patch-Makefile.common b/graphics/netpbm/files/patch-Makefile.common
index 5664fdf7850c..baf05c36c665 100644
--- a/graphics/netpbm/files/patch-Makefile.common
+++ b/graphics/netpbm/files/patch-Makefile.common
@@ -1,6 +1,15 @@
---- Makefile.common.orig Wed Oct 9 11:17:24 2002
-+++ Makefile.common Sat Oct 12 00:00:00 2002
-@@ -231,19 +231,19 @@
+--- ./Makefile.common.orig 2006-11-13 05:14:19.000000000 +0100
++++ ./Makefile.common 2011-05-10 15:44:47.000000000 +0200
+@@ -68,7 +68,7 @@
+
+ include $(SRCDIR)/Makefile.version
+
+-INCLUDES2 := $(INCLUDES) -I$(SRCDIR)/$(SUBDIR) -I. -I importinc
++INCLUDES2 := $(PREINCLUDES) -I$(SRCDIR)/$(SUBDIR) -I. -Iimportinc $(INCLUDES)
+
+ ifeq ($(NETPBMLIBTYPE),unixstatic)
+ NETPBMLIBFNAME = libnetpbm.$(STATICLIBSUFFIX)
+@@ -408,19 +408,19 @@
INSTALLBIN_TARGETS = $(BINARIES:%=%_installbin) netpbm_installbin
.PHONY: $(INSTALLBIN_TARGETS)
$(INSTALLBIN_TARGETS): $(PKGDIR)/bin
diff --git a/graphics/netpbm/files/patch-ppmtompeg-Makefile b/graphics/netpbm/files/patch-ppmtompeg-Makefile
new file mode 100644
index 000000000000..88b671f0c15d
--- /dev/null
+++ b/graphics/netpbm/files/patch-ppmtompeg-Makefile
@@ -0,0 +1,12 @@
+--- converter/ppm/ppmtompeg/Makefile.orig 2008-12-07 02:58:20.000000000 +0100
++++ converter/ppm/ppmtompeg/Makefile 2011-05-11 06:01:02.000000000 +0200
+@@ -18,7 +18,8 @@
+ JPEGLIBX = $(JPEGLIB)
+ endif
+
+-INCLUDES = -I$(SRCDIR)/$(SUBDIR)/headers
++INCLUDES =
++PREINCLUDES = -I$(SRCDIR)/$(SUBDIR)/headers
+
+ ifneq ($(JPEGHDR_DIR),NONE)
+ ifneq ($(JPEGHDR_DIR)x,x)