aboutsummaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/netpbm
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
Notes
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile4
-rw-r--r--graphics/netpbm/files/patch-pamrgbatopng.c8
-rw-r--r--graphics/netpbm/files/patch-pngtopnm.c24
-rw-r--r--graphics/netpbm/files/patch-pngtxt.c10
4 files changed, 36 insertions, 10 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 8b642412b05c..9bff4e837de5 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= netpbm
PORTVERSION= 10.35.84
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/netpbm/super_stable/${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -17,7 +17,7 @@ COMMENT= A toolkit for conversion of images between different formats
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
jbig.1:${PORTSDIR}/graphics/jbigkit \
jasper.4:${PORTSDIR}/graphics/jasper \
xml2.5:${PORTSDIR}/textproc/libxml2
diff --git a/graphics/netpbm/files/patch-pamrgbatopng.c b/graphics/netpbm/files/patch-pamrgbatopng.c
new file mode 100644
index 000000000000..92e7590cf59b
--- /dev/null
+++ b/graphics/netpbm/files/patch-pamrgbatopng.c
@@ -0,0 +1,8 @@
+--- converter/other/pamrgbatopng.c.orig 2006-08-19 05:12:28.000000000 +0200
++++ converter/other/pamrgbatopng.c 2012-04-24 22:20:00.000000000 +0200
+@@ -1,4 +1,5 @@
+ #include <png.h>
++#include <pngpriv.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <setjmp.h>
diff --git a/graphics/netpbm/files/patch-pngtopnm.c b/graphics/netpbm/files/patch-pngtopnm.c
index b5387857e1b2..8c4615530bbe 100644
--- a/graphics/netpbm/files/patch-pngtopnm.c
+++ b/graphics/netpbm/files/patch-pngtopnm.c
@@ -1,6 +1,14 @@
---- converter/other/pngtopnm.c.orig 2009-09-03 17:34:36.000000000 +0200
-+++ converter/other/pngtopnm.c 2010-05-21 11:24:05.000000000 +0200
-@@ -44,7 +44,7 @@
+--- converter/other/pngtopnm.c.orig 2011-11-25 01:15:46.000000000 +0100
++++ converter/other/pngtopnm.c 2012-04-24 22:15:14.000000000 +0200
+@@ -37,6 +37,7 @@
+ #include <math.h>
+ #include <float.h>
+ #include <png.h> /* includes zlib.h and setjmp.h */
++#include <pngpriv.h>
+ #define VERSION "2.37.4 (5 December 1999) +netpbm"
+
+ #include "pnm.h"
+@@ -44,7 +45,7 @@
#include "nstring.h"
#include "shhopt.h"
@@ -9,7 +17,7 @@
#error Your PNG library (<png.h>) is incompatible with this Netpbm source code.
#error You need either an older PNG library (older than 1.4)
#error newer Netpbm source code (at least 10.48)
-@@ -482,7 +482,7 @@
+@@ -489,7 +490,7 @@
bool retval;
if (info_ptr->valid & PNG_INFO_tRNS) {
@@ -18,7 +26,7 @@
/* There seems to be a problem here: you can't compare real
-@@ -575,8 +575,8 @@
+@@ -582,8 +583,8 @@
for (i = 0, foundGray = FALSE;
i < info_ptr->num_trans && !foundGray;
++i) {
@@ -29,7 +37,7 @@
foundGray = TRUE;
}
}
-@@ -647,7 +647,7 @@
+@@ -654,7 +655,7 @@
unsigned int i;
trans_mix = TRUE;
for (i = 0; i < info_ptr->num_trans; ++i)
@@ -38,7 +46,7 @@
trans_mix = FALSE;
break;
}
-@@ -885,7 +885,7 @@
+@@ -892,7 +893,7 @@
setXel(&xelrow[col], fgColor, bgColor, alpha_handling,
((info_ptr->valid & PNG_INFO_tRNS) &&
(fgColor.r ==
@@ -47,7 +55,7 @@
totalgamma))) ?
0 : maxval);
}
-@@ -914,7 +914,7 @@
+@@ -921,7 +922,7 @@
setXel(&xelrow[col], fgColor, bgColor, alpha_handling,
(info_ptr->valid & PNG_INFO_tRNS) &&
index < info_ptr->num_trans ?
diff --git a/graphics/netpbm/files/patch-pngtxt.c b/graphics/netpbm/files/patch-pngtxt.c
new file mode 100644
index 000000000000..b3ae8ad5a51f
--- /dev/null
+++ b/graphics/netpbm/files/patch-pngtxt.c
@@ -0,0 +1,10 @@
+--- converter/other/pngtxt.c.orig 2006-08-19 05:12:28.000000000 +0200
++++ converter/other/pngtxt.c 2012-04-24 22:12:39.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <string.h>
+ #include <stdio.h>
+ #include <png.h>
++#include <pngpriv.h>
+
+ #include "nstring.h"
+ #include "pngtxt.h"