aboutsummaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorHidetoshi Shimokawa <simokawa@FreeBSD.org>1999-01-07 11:12:30 +0000
committerHidetoshi Shimokawa <simokawa@FreeBSD.org>1999-01-07 11:12:30 +0000
commite57e614386594575d32ca841d679ac2829e48daf (patch)
tree4d864783005b74f5ac1bb2e05dea588d88844f8d /graphics/netpbm
parent6a187e06e92d35be66e4ea1e632addbfba32b295 (diff)
downloadports-e57e614386594575d32ca841d679ac2829e48daf.tar.gz
ports-e57e614386594575d32ca841d679ac2829e48daf.zip
Notes
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile6
-rw-r--r--graphics/netpbm/files/patch-aj36
2 files changed, 39 insertions, 3 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 9a5dca3cf293..7ab67bf3d9d6 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -3,7 +3,7 @@
# Date created: ?
# Whom: jmz (original)
#
-# $Id: Makefile,v 1.14 1998/11/25 09:01:19 asami Exp $
+# $Id: Makefile,v 1.15 1999/01/02 15:58:19 smace Exp $
#
DISTNAME= netpbm
@@ -14,8 +14,8 @@ DISTFILES= netpbm-1mar1994.tar.gz
MAINTAINER= ports@FreeBSD.ORG
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff34
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff34
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_IMAKE= yes
MAN1= anytopnm.1 asciitopgm.1 atktopbm.1 bioradtopgm.1 bmptoppm.1 \
diff --git a/graphics/netpbm/files/patch-aj b/graphics/netpbm/files/patch-aj
new file mode 100644
index 000000000000..79cf5347a783
--- /dev/null
+++ b/graphics/netpbm/files/patch-aj
@@ -0,0 +1,36 @@
+--- pbmplus.h.orig Tue Mar 1 18:46:36 1994
++++ pbmplus.h Thu Jan 7 19:23:15 1999
+@@ -20,6 +20,9 @@
+ #include <perror.h>
+ #include <errno.h>
+ #endif
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
+
+ #if defined(USG) || defined(SVR4) || defined(VMS)
+ #define SYSV
+@@ -30,7 +33,9 @@
+ ** and if you run on an Amiga, set AMIGA. If your compiler is ANSI C, you're
+ ** probably better off setting SYSV - all it affects is string handling.
+ */
+-#define BSD
++#ifndef BSD
++#define BSD 1
++#endif
+ /* #define SYSV */
+ /* #define MSDOS */
+ /* #define AMIGA */
+@@ -119,10 +124,12 @@
+ #ifndef VMS
+ #include <unistd.h>
+ #endif
++#if !(defined(BSD) && (BSD >= 199306))
+ extern int atoi();
+ extern void exit();
+ extern long time();
+ extern int write();
++#endif
+ #endif
+
+ /* CONFIGURE: On most BSD systems, malloc() gets declared in stdlib.h, on