aboutsummaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-06-27 11:28:01 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-06-27 11:28:01 +0000
commit0a810b6e63a91593b7bea701e83ee94926a5eb78 (patch)
treecd50aed408497708229fba6b9be9cdc367ac1807 /graphics/netpbm
parentf68083f3282adaef19c87efd3ae9ee80f7eeb225 (diff)
downloadports-0a810b6e63a91593b7bea701e83ee94926a5eb78.tar.gz
ports-0a810b6e63a91593b7bea701e83ee94926a5eb78.zip
Notes
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile9
-rw-r--r--graphics/netpbm/distinfo2
-rw-r--r--graphics/netpbm/files/Makefile.config.FreeBSD1
-rw-r--r--graphics/netpbm/files/patch-aj32
-rw-r--r--graphics/netpbm/files/patch-ba10
-rw-r--r--graphics/netpbm/files/patch-bb41
-rw-r--r--graphics/netpbm/files/patch-bd15
-rw-r--r--graphics/netpbm/files/patch-ct11
-rw-r--r--graphics/netpbm/pkg-plist4
9 files changed, 61 insertions, 64 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index da5b82953c6f..2bf7afae292e 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= netpbm
-PORTVERSION= 9.14
+PORTVERSION= 9.15
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,6 +19,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.4:${PORTSDIR}/graphics/png
USE_GMAKE= yes
+MAKE_ENV= LN="${LN}"
MAKEFILE= GNUmakefile
ALL_TARGET= merge
INSTALL_TARGET= install-merge install-dev
@@ -29,8 +30,10 @@ INSTALLS_SHLIB= yes
.include "${FILESDIR}/manpages"
post-patch:
- @${PERL} -pi -e "s|%%X11BASE%%|${X11BASE}|g" ${WRKSRC}/pbmplus.h
+ @${PERL} -pi -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/pm_config.h
+ @${PERL} -pi -e 's|<shhopt.h>|<pm_shhopt.h>|g' ${WRKSRC}/pbm/pm.h
+ @${ECHO} '#include "pm.h"' > ${WRKSRC}/pbmplus.h
@${CP} ${FILESDIR}/Makefile.config.FreeBSD ${WRKSRC}/Makefile.config
- @${LN} -sf ${WRKSRC}/shhopt/shhopt.h ${WRKSRC}/shhopt/pbmshhopt.h
+ @${LN} -sf ${WRKSRC}/shhopt/shhopt.h ${WRKSRC}/shhopt/pm_shhopt.h
.include <bsd.port.post.mk>
diff --git a/graphics/netpbm/distinfo b/graphics/netpbm/distinfo
index c937c0f39a7a..952acdee0b79 100644
--- a/graphics/netpbm/distinfo
+++ b/graphics/netpbm/distinfo
@@ -1 +1 @@
-MD5 (netpbm-9.14.tgz) = e77b5efa08bc0efb6d8ea2e7ddeb0005
+MD5 (netpbm-9.15.tgz) = 198ab871d4093777a8825459ce181e05
diff --git a/graphics/netpbm/files/Makefile.config.FreeBSD b/graphics/netpbm/files/Makefile.config.FreeBSD
index 5acab4bfede7..453e30a6f44c 100644
--- a/graphics/netpbm/files/Makefile.config.FreeBSD
+++ b/graphics/netpbm/files/Makefile.config.FreeBSD
@@ -1,6 +1,7 @@
BUILD_FIASCO = Y
STATICLIB = N
LD = ${CC}
+SYMLINK = ${LN} -sf
MANCP = ${BSD_INSTALL_MAN}
LDFLAGS = -Wl,--rpath,$(INSTALLLIBS)
LDSHLIB = -shared -Wl,-soname,$(SONAME)
diff --git a/graphics/netpbm/files/patch-aj b/graphics/netpbm/files/patch-aj
index 3dfdb6132438..9e8f76ce0a68 100644
--- a/graphics/netpbm/files/patch-aj
+++ b/graphics/netpbm/files/patch-aj
@@ -1,16 +1,17 @@
---- pbmplus.h.orig Mon May 14 13:53:10 2001
-+++ pbmplus.h Tue May 15 00:00:00 2001
-@@ -18,6 +18,9 @@
- #include <stdio.h>
- #include <errno.h>
- #include <sys/stat.h>
+--- pm_config.h.orig Mon Jun 11 08:37:08 2001
++++ pm_config.h Mon Tue Jun 26 00:00:00 2001
+@@ -19,6 +19,10 @@
+
+ **************************************************************************/
+
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
-
- #ifdef VMS
- #include <perror.h>
-@@ -32,7 +35,7 @@
++
+ #if defined(USG) || defined(SVR4) || defined(VMS) || defined(__SVR4)
+ #define SYSV
+ #endif
+@@ -28,7 +32,7 @@
** and if you run on an Amiga, set AMIGA. If your compiler is ANSI C, you're
** probably better off setting SYSV - all it affects is string handling.
*/
@@ -19,7 +20,7 @@
/* #define SYSV */
/* #define MSDOS */
/* #define AMIGA */
-@@ -52,9 +55,9 @@
+@@ -48,9 +52,9 @@
#define RGB_DB2 "PBMplus_Dir:RGB.TXT"
#define RGB_DB3 "PBMplus_Dir:RGB.TXT"
#else
@@ -32,12 +33,3 @@
#endif
/* CONFIGURE: This is the name of an environment variable that tells
-@@ -339,7 +342,7 @@
- /* By making this <> instead of "", we avoid making shhopt.h a dependency
- of every program in the package when we do make dep.
- */
--#include <shhopt.h>
-+#include <pbmshhopt.h>
-
- /* Use pm_optParseOptions instead of optParseOptions in order to use the
- shared Netpbm libraries
diff --git a/graphics/netpbm/files/patch-ba b/graphics/netpbm/files/patch-ba
index 6025b42fc89b..76b7164e2fd5 100644
--- a/graphics/netpbm/files/patch-ba
+++ b/graphics/netpbm/files/patch-ba
@@ -1,6 +1,6 @@
---- GNUmakefile.orig Mon Apr 9 11:10:10 2001
-+++ GNUmakefile Tue May 15 00:00:00 2001
-@@ -150,10 +150,10 @@
+--- GNUmakefile.orig Sat Jun 2 11:42:02 2001
++++ GNUmakefile Tue Jun 26 00:00:00 2001
+@@ -153,10 +153,12 @@
.PHONY: install.hdr
install.hdr:
$(SRCDIR)/mkinstalldirs $(INSTALLHDRS)
@@ -10,7 +10,9 @@
- $(INSTALL) -c -m$(INSTALL_PERM_HDR) \
- $(SRCDIR)/shhopt/shhopt.h $(INSTALLHDRS)
+ ${BSD_INSTALL_DATA} \
-+ $(SRCDIR)/shhopt/pbmshhopt.h $(INSTALLHDRS)
++ $(SRCDIR)/pm_config.h $(INSTALLHDRS)
++ ${BSD_INSTALL_DATA} \
++ $(SRCDIR)/shhopt/pm_shhopt.h $(INSTALLHDRS)
for i in $(SUBDIRS) ; do \
$(MAKE) -C $$i -f $(SRCDIR)/$$i/Makefile install.hdr ; \
done
diff --git a/graphics/netpbm/files/patch-bb b/graphics/netpbm/files/patch-bb
index 5f0a5e1e43e8..e020136d8d95 100644
--- a/graphics/netpbm/files/patch-bb
+++ b/graphics/netpbm/files/patch-bb
@@ -1,6 +1,6 @@
---- Makefile.common.orig Tue May 1 00:45:34 2001
-+++ Makefile.common Tue May 15 00:00:00 2001
-@@ -155,24 +155,20 @@
+--- Makefile.common.orig Sun Jun 17 09:58:41 2001
++++ Makefile.common Tue Jun 26 00:00:00 2001
+@@ -157,24 +157,21 @@
$(LIBOBJECTS): %.o: $(SRCSUBDIR)/%.c $(HEADERLINKS)
# Note that the user may have configured -I options into CFLAGS.
@@ -15,24 +15,25 @@
# The libxxx.so link is needed to link the executables.
lib$(LIBROOT).so: $(SONAME)
rm -f $@
- ln -s $< $@
+ $(SYMLINK) $< $@
-# The $(SONAME) link is only needed to test the programs without
-# installing the libraries (in that case, you also need to direct the
-# dynamic linker to the source directories, e.g. set LD_LIBRARY_PATH).
-$(SONAME): lib$(LIBROOT).so.$(MAJ).$(MIN)
- rm -f $@
-- ln -s $< $@
+- $(SYMLINK) $< $@
-lib$(LIBROOT).so.$(MAJ).$(MIN): $(LIBOBJECTS) $(LIBOBJECTS_X) $(LIBLIBS) \
- $(LIBOPT)
- $(LD) $(LDSHLIB) -o $@ $(LIBOBJECTS) $(LIBOBJECTS_X) \
- `$(LIBOPT) $(LIBLIBS)` -lc $(CDEBUG)
-+$(SONAME): $(SHLIBOBJECTS) $(LIBOBJECTS_X) $(LIBLIBS) $(LIBOPT) lib$(LIBROOT).a
++$(SONAME): $(SHLIBOBJECTS) $(LIBOBJECTS_X) $(LIBLIBS) \
++ $(LIBOPT) lib$(LIBROOT).a
+ $(LD) $(LDSHLIB) -o $@ $(SHLIBOBJECTS) $(LIBOBJECTS_X) \
+ `$(LIBOPT) $(LIBLIBS)` $(LDFLAGS) $(CDEBUG)
- # Static library. Unused by default, but with a small change to make files...
+ # Static library.
lib$(LIBROOT).a: $(LIBOBJECTS) $(LIBOBJECTS_X)
-@@ -204,7 +200,7 @@
+@@ -215,7 +212,7 @@
install.merge.common: $(MERGENAME) $(NOMERGEBINARIES) install.script
cd $(INSTALLBINARIES) ; rm -f $(BINARIES) $(MERGE_ALIASES)
ifneq ($(MERGENAME)x,x)
@@ -41,7 +42,7 @@
$(MERGENAME) $(INSTALLBINARIES)
cd $(INSTALLBINARIES) ; \
for i in $(MERGEBINARIES) $(MERGE_ALIASES) ; \
-@@ -214,7 +210,7 @@
+@@ -225,7 +222,7 @@
ifneq ($(NOMERGEBINARIES)x,x)
for x in $(NOMERGEBINARIES); \
do \
@@ -50,7 +51,7 @@
$$x $(INSTALLBINARIES); \
done
endif
-@@ -225,7 +221,7 @@
+@@ -236,7 +233,7 @@
# Make and Install know that pbmmake.exe counts as pbmmake.
for x in $(BINARIES); \
do \
@@ -59,7 +60,7 @@
$$x $(INSTALLBINARIES); \
done
-@@ -234,7 +230,7 @@
+@@ -245,7 +242,7 @@
ifneq ($(SCRIPTS)x,x)
for x in $(SCRIPTS); \
do \
@@ -68,7 +69,7 @@
$(INSTALLSCRIPTS); \
done
endif
-@@ -271,7 +267,7 @@
+@@ -282,7 +279,7 @@
# directory when you compile your programs.
for x in $(INTERFACE_HEADERS); \
do \
@@ -77,7 +78,7 @@
$(INSTALLHDRS); \
done
-@@ -279,15 +275,14 @@
+@@ -290,17 +287,16 @@
#
.PHONY: install.staticlib
install.staticlib: lib$(LIBROOT).a
@@ -85,15 +86,17 @@
+ ${BSD_INSTALL_DATA} $< $(INSTALLLIBS)/$<
.PHONY: install.lib.common
- # install a shared library
+ ifeq ($(NETPBMLIBSUFFIX),so)
+ # install a Unix-style shared library
-install.lib.common: lib$(LIBROOT).so.$(MAJ).$(MIN)
- cd $(INSTALLLIBS) ; rm -f lib$(LIBROOT).so.$(MAJ).*
- $(INSTALL) -c -m $(INSTALL_PERM_LIBD) $< $(INSTALLLIBS)
+install.lib.common: $(SONAME)
+ cd $(INSTALLLIBS) ; rm -f lib$(LIBROOT).so.*
+ ${BSD_INSTALL_DATA} $< $(INSTALLLIBS)
- cd $(INSTALLLIBS) ; rm -f lib$(LIBROOT).so; ln -s $< lib$(LIBROOT).so
-- cd $(INSTALLLIBS) ; rm -f $(SONAME); ln -s $< $(SONAME)
-
- .PHONY: clean.common
- clean.common:
+ cd $(INSTALLLIBS) ; \
+ rm -f lib$(LIBROOT).so; $(SYMLINK) $< lib$(LIBROOT).so
+- cd $(INSTALLLIBS) ; rm -f $(SONAME); $(SYMLINK) $< $(SONAME)
+ endif
+ ifeq ($(NETPBMLIBSUFFIX),dll)
+ #install a Windows DLL shared library
diff --git a/graphics/netpbm/files/patch-bd b/graphics/netpbm/files/patch-bd
index 8757b931f370..0e1faf43d814 100644
--- a/graphics/netpbm/files/patch-bd
+++ b/graphics/netpbm/files/patch-bd
@@ -1,14 +1,19 @@
---- pbm/Makefile.orig Fri May 4 12:39:43 2001
-+++ pbm/Makefile Tue May 15 00:00:00 2001
+--- pbm/Makefile.orig Wed May 30 14:59:56 2001
++++ pbm/Makefile Tue Jun 26 00:00:00 2001
@@ -47,6 +47,7 @@
# Library objects to be built and linked by Makefile.common:
- LIBOBJECTS = libpbm1.o libpbm2.o libpbm3.o libpbm4.o libpbm5.o
+ LIBOBJECTS = libpm.o libpbm1.o libpbm2.o libpbm3.o libpbm4.o libpbm5.o
+SHLIBOBJECTS = $(patsubst %.o, %.lo, $(LIBOBJECTS))
ifneq (${VMS}x,x)
LIBOBJECTS += libpbmvms.o
endif
-@@ -63,26 +64,21 @@
+@@ -59,30 +60,25 @@
+
+ MERGENAME = pbmmerge
+
+-INTERFACE_HEADERS = pbm.h
++INTERFACE_HEADERS = pbm.h pm.h
.PHONY: all
all: $(BINARIES)
@@ -33,7 +38,7 @@
install.man: install.man.common
- $(MAKE) -C pbmtoppa install.man
- HEADERLINKS = pbmplus.h version.h compile.h
+ HEADERLINKS = pm_config.h version.h compile.h
@@ -104,6 +100,5 @@
.PHONY: clean
diff --git a/graphics/netpbm/files/patch-ct b/graphics/netpbm/files/patch-ct
deleted file mode 100644
index 0861c85581c7..000000000000
--- a/graphics/netpbm/files/patch-ct
+++ /dev/null
@@ -1,11 +0,0 @@
---- ppm/411toppm.c.orig Sun Mar 4 08:23:20 2001
-+++ ppm/411toppm.c Tue May 15 00:00:00 2001
-@@ -56,8 +56,6 @@
- * HEADER FILES *
- *==============*/
- #include <stdio.h>
--#include <stdlib.h>
--#include <malloc.h>
-
- #include "ppm.h"
-
diff --git a/graphics/netpbm/pkg-plist b/graphics/netpbm/pkg-plist
index b90110e4cf60..03ca82e45497 100644
--- a/graphics/netpbm/pkg-plist
+++ b/graphics/netpbm/pkg-plist
@@ -227,8 +227,10 @@ bin/yuvtoppm
bin/zeisstopnm
include/pbm.h
include/pbmplus.h
-include/pbmshhopt.h
include/pgm.h
+include/pm.h
+include/pm_config.h
+include/pm_shhopt.h
include/pnm.h
include/ppm.h
include/ppmcmap.h