aboutsummaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-01-17 10:11:56 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-01-17 10:11:56 +0000
commit54cfaadd9eeccd11833fa1abe5be556b7d24528c (patch)
treec2eb7cdb85141db90d8ee6c4728ae6c41d7b7192 /graphics/netpbm
parent9a6ee9c3b4047ffa9f6ea5b6f2245817dae39758 (diff)
Notes
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile20
-rw-r--r--graphics/netpbm/files/converter-other-cameratopam-identify.patch26
-rw-r--r--graphics/netpbm/files/editor-pnmquant-devel.patch20
-rw-r--r--graphics/netpbm/files/patch-converter-other-pstopnm (renamed from graphics/netpbm/files/converter-other-pstopnm.patch)0
-rw-r--r--graphics/netpbm/files/patch-editor-pnmquant (renamed from graphics/netpbm/files/editor-pnmquant-stable.patch)0
-rw-r--r--graphics/netpbm/files/patch-util-wordaccess.h (renamed from graphics/netpbm/files/patch-lib-util-wordaccess.h)0
6 files changed, 10 insertions, 56 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 93b53cae4c47..8e1755064264 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -31,6 +31,9 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png \
jbig.1:${PORTSDIR}/graphics/jbigkit
# jasper.4:${PORTSDIR}/graphics/jasper
+.if defined(WITH_NETPBM_DEVEL)
+LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
+.endif
USE_PERL5= yes
USE_GMAKE= yes
@@ -46,6 +49,13 @@ PORTSCOUT= limit:^10\.26\.
MAN1= netpbm.1
DEVEL_PORTVERSION= 10.31
+.if defined(WITH_NETPBM_DEVEL)
+PATCHDIR?= ${MASTERDIR}/../netpbm-devel/files
+CFLAGS+= -Iutil
+PLIST_SUB+= DEVEL=""
+.else
+PLIST_SUB+= DEVEL="@comment "
+.endif
.include <bsd.port.pre.mk>
@@ -54,16 +64,6 @@ DEVEL_PORTVERSION= 10.31
CFLAGS+= -O0
.endif
-.if defined(WITH_NETPBM_DEVEL)
-EXTRA_PATCHES+= ${FILESDIR}/editor-pnmquant-devel.patch
-EXTRA_PATCHES+= ${FILESDIR}/converter-other-cameratopam-identify.patch
-PLIST_SUB+= DEVEL=""
-.else
-EXTRA_PATCHES+= ${FILESDIR}/editor-pnmquant-stable.patch
-EXTRA_PATCHES+= ${FILESDIR}/converter-other-pstopnm.patch
-PLIST_SUB+= DEVEL="@comment "
-.endif
-
pre-configure:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
diff --git a/graphics/netpbm/files/converter-other-cameratopam-identify.patch b/graphics/netpbm/files/converter-other-cameratopam-identify.patch
deleted file mode 100644
index 283a2480b9b6..000000000000
--- a/graphics/netpbm/files/converter-other-cameratopam-identify.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-
-
-19 Mai 06:06 2006 diff -u -l converter/other/cameratopam/identify.c.orig converter/other/cameratopam/identify.c Page 1
-
-
---- converter/other/cameratopam/identify.c.orig Sat Aug 27 19:29:58 2005
-+++ converter/other/cameratopam/identify.c Fri May 19 06:06:28 2006
-@@ -25,7 +25,7 @@
-
-
- /* This does the same as the function of the same name in the GNU C library */
--static const char *memmem (const char *haystack, size_t haystacklen,
-+static const char *memmem_old (const char *haystack, size_t haystacklen,
- const char *needle, size_t needlelen)
- {
- const char *c;
-@@ -316,7 +316,7 @@
- fread (head, 1, 32, ifp);
- fseek (ifp, 0, SEEK_END);
- fsize = ftell(ifp);
-- if ((c = (char*)memmem (head, 32, "MMMMRawT", 8))) {
-+ if ((c = (char*)memmem_old (head, 32, "MMMMRawT", 8))) {
- strcpy (make, "Phase One");
- data_offset = c - head;
- fseek (ifp, data_offset + 8, SEEK_SET);
-
diff --git a/graphics/netpbm/files/editor-pnmquant-devel.patch b/graphics/netpbm/files/editor-pnmquant-devel.patch
deleted file mode 100644
index 60019a46e93f..000000000000
--- a/graphics/netpbm/files/editor-pnmquant-devel.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- editor/pnmquant.orig Sun Feb 19 22:03:42 2006
-+++ editor/pnmquant Mon Feb 20 09:41:57 2006
-@@ -116,7 +118,7 @@
- tell(INFH); # Avoids bogus "INFH is not referenced" warning
- }
- } else {
-- open(STDIN, "<", $infile)
-+ open(STDIN, "<" . $infile)
- or die("Unable to open input file '$infile'. Errno=$ERRNO");
- }
- }
-@@ -157,7 +159,7 @@
- $spreadOpt = "-spreadbrightness";
- }
-
-- open(STDOUT, ">", $mapfileSpec);
-+ open(STDOUT, ">" . $mapfileSpec);
-
- my $maprc = system("pnmcolormap", $ncolors, $averageOpt, $spreadOpt);
-
diff --git a/graphics/netpbm/files/converter-other-pstopnm.patch b/graphics/netpbm/files/patch-converter-other-pstopnm
index 23626cd1a634..23626cd1a634 100644
--- a/graphics/netpbm/files/converter-other-pstopnm.patch
+++ b/graphics/netpbm/files/patch-converter-other-pstopnm
diff --git a/graphics/netpbm/files/editor-pnmquant-stable.patch b/graphics/netpbm/files/patch-editor-pnmquant
index f61ca961c530..f61ca961c530 100644
--- a/graphics/netpbm/files/editor-pnmquant-stable.patch
+++ b/graphics/netpbm/files/patch-editor-pnmquant
diff --git a/graphics/netpbm/files/patch-lib-util-wordaccess.h b/graphics/netpbm/files/patch-util-wordaccess.h
index d6aa282f7c9d..d6aa282f7c9d 100644
--- a/graphics/netpbm/files/patch-lib-util-wordaccess.h
+++ b/graphics/netpbm/files/patch-util-wordaccess.h