aboutsummaryrefslogtreecommitdiff
path: root/graphics/nomacs
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-06-30 14:49:55 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-06-30 14:49:55 +0000
commit2cc5471a3bd279177e4ae61b92b8a3d72d5539ba (patch)
tree489a51d147cedc04a17d7bad7029c1a25d0553db /graphics/nomacs
parentc606c07468a896af6477b3afc184168a2ca07940 (diff)
downloadports-2cc5471a3bd279177e4ae61b92b8a3d72d5539ba.tar.gz
ports-2cc5471a3bd279177e4ae61b92b8a3d72d5539ba.zip
Notes
Diffstat (limited to 'graphics/nomacs')
-rw-r--r--graphics/nomacs/Makefile26
-rw-r--r--graphics/nomacs/distinfo4
-rw-r--r--graphics/nomacs/pkg-plist7
3 files changed, 25 insertions, 12 deletions
diff --git a/graphics/nomacs/Makefile b/graphics/nomacs/Makefile
index 29c037460168..62a28280eff4 100644
--- a/graphics/nomacs/Makefile
+++ b/graphics/nomacs/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= nomacs
-PORTVERSION= 1.0.0
+PORTVERSION= 1.2.0
CATEGORIES= graphics
MASTER_SITES= SF/nomacs/nomacs-${PORTVERSION}/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= bsd@tuxproject.de
COMMENT= Small, fast and free image viewer
@@ -15,19 +15,29 @@ LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2 \
sysinfo:${PORTSDIR}/devel/libsysinfo
USE_BZIP2= yes
-USES= cmake
+USES= cmake desktop-file-utils
USE_QT4= gui network linguist_build moc_build \
qmake_build rcc_build uic_build
LDFLAGS+= -lsysinfo -lkvm
WRKTOP= ${WRKDIR}
-WRKSUBDIR= ${PORTNAME}-${PORTVERSION}
+WRKSUBDIR= ${DISTNAME:S,-source,,}
WRKSRC= ${WRKTOP}/${WRKSUBDIR}
-CMAKE_ARGS+= -DENABLE_RAW=0
MAN1= nomacs.1
+OPTIONS_DEFINE= RAW
+OPTIONS_DEFAULT= RAW
+RAW_DESC= RAW images support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MRAW}
+LIB_DEPENDS+= raw:${PORTSDIR}/graphics/libraw \
+ opencv_legacy:${PORTSDIR}/graphics/opencv
+.else
+CMAKE_ARGS+= -DENABLE_RAW=0
+.endif
+
post-extract:
- @cd ${WRKSRC}/ &&\
- ${REINPLACE_CMD} -e 's|share/man/man1|man/man1|' \
- CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|share/man/man1|man/man1|' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/graphics/nomacs/distinfo b/graphics/nomacs/distinfo
index 27002342ef90..4a6684987483 100644
--- a/graphics/nomacs/distinfo
+++ b/graphics/nomacs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nomacs-1.0.0.tar.bz2) = bf2a0a9ecb35551dc8ed25c0db95c1183b3771a2ce9e2a41d7e1d230bac2c5f2
-SIZE (nomacs-1.0.0.tar.bz2) = 803404
+SHA256 (nomacs-1.2.0-source.tar.bz2) = 0c60e5d17a7f3d17f33344b59440dad2bac0358fd1fae85b48574f2c61674259
+SIZE (nomacs-1.2.0-source.tar.bz2) = 859335
diff --git a/graphics/nomacs/pkg-plist b/graphics/nomacs/pkg-plist
index ccd8cda901bd..5fb66f3fe703 100644
--- a/graphics/nomacs/pkg-plist
+++ b/graphics/nomacs/pkg-plist
@@ -2,16 +2,19 @@ bin/nomacs
share/applications/nomacs.desktop
%%DATADIR%%/translations/nomacs_als.qm
%%DATADIR%%/translations/nomacs_az.qm
+%%DATADIR%%/translations/nomacs_cs.qm
%%DATADIR%%/translations/nomacs_de.qm
%%DATADIR%%/translations/nomacs_en.qm
%%DATADIR%%/translations/nomacs_es.qm
+%%DATADIR%%/translations/nomacs_it.qm
%%DATADIR%%/translations/nomacs_pl.qm
+%%DATADIR%%/translations/nomacs_pt.qm
%%DATADIR%%/translations/nomacs_ru.qm
+%%DATADIR%%/translations/nomacs_sl.qm
%%DATADIR%%/translations/nomacs_sk.qm
+%%DATADIR%%/translations/nomacs_sr.qm
%%DATADIR%%/translations/nomacs_zh.qm
share/pixmaps/nomacs.png
@dirrm %%DATADIR%%/translations
@dirrm %%DATADIR%%
@dirrmtry share/applications
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true