aboutsummaryrefslogtreecommitdiff
path: root/graphics/nplot
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-10-06 20:11:18 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-10-06 20:11:18 +0000
commita33febfb763141d47b3b8c483c9e4f5c9ba4993c (patch)
treeac652a193916d1dad2d6e8900551ff3967de5e67 /graphics/nplot
parent0596259cb64bfe759a59989c5cb7af0037cc8171 (diff)
Notes
Diffstat (limited to 'graphics/nplot')
-rw-r--r--graphics/nplot/Makefile29
-rw-r--r--graphics/nplot/distinfo6
-rw-r--r--graphics/nplot/files/Dynamic.key13
-rw-r--r--graphics/nplot/files/NPlot.pc.in8
-rw-r--r--graphics/nplot/pkg-descr2
5 files changed, 47 insertions, 11 deletions
diff --git a/graphics/nplot/Makefile b/graphics/nplot/Makefile
index 4fd6a3b2eda9..4afc26b98e15 100644
--- a/graphics/nplot/Makefile
+++ b/graphics/nplot/Makefile
@@ -1,27 +1,42 @@
# $FreeBSD$
PORTNAME= nplot
-PORTVERSION= 0.9.10
+PORTVERSION= 0.9.11
CATEGORIES= graphics
-MASTER_SITES= http://suyai.innolan.net/
-DISTNAME= nplot-0.9.10.1
MAINTAINER= cs@innolan.dk
COMMENT= Charting library for .NET
-LICENSE= BSD3CLAUSE
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdiplus.so:x11-toolkits/libgdiplus \
libcairo.so:graphics/cairo
RUN_DEPENDS= webfonts>=0:x11-fonts/webfonts
+USE_GITHUB= yes
+GH_ACCOUNT= mhowlett
+GH_TAGNAME= 9a92e78
+
+USE_OPENSSL= yes
+SUB_FILES= NPlot.pc
USES= mono
-WRKSRC= ${WRKDIR}/anguist-nplot-bed1ca9c4048
-PLIST_FILES= lib/mono/gac/NPlot/0.9.10.1__4eda430eb4395eb1/NPlot.dll
+PLIST_FILES= lib/mono/NPlot/NPlot.dll \
+ lib/mono/gac/NPlot/0.9.11.0__1d82a50c5d01c44e/NPlot.dll \
+ libdata/pkgconfig/NPlot.pc
+
+pre-build:
+ openssl enc -base64 -d <${PATCHDIR}/Dynamic.key >${WRKSRC}/src/Dynamic.snk
+
+do-build:
+ (cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} xbuild NPlot.csproj \
+ /p:Configuration=Release /p:SignAssembly=true \
+ /p:AssemblyOriginatorKeyFile=Dynamic.snk)
do-install:
- ${LOCALBASE}/bin/gacutil -root ${STAGEDIR}${PREFIX}/lib/ -gacdir ${STAGEDIR}${PREFIX}/lib -i ${WRKSRC}/bin/NPlot.dll
+ (cd ${WRKSRC}/src && ${SETENV} MONO_SHARED_DIR=${WRKDIR} ${LOCALBASE}/bin/gacutil \
+ -root ${STAGEDIR}${PREFIX}/lib/ -package NPlot -i bin/NPlot.dll)
+ (cd ${WRKDIR} && ${INSTALL_DATA} NPlot.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig)
.include <bsd.port.mk>
diff --git a/graphics/nplot/distinfo b/graphics/nplot/distinfo
index 3d4763fb9ed3..f2e53b0ca27a 100644
--- a/graphics/nplot/distinfo
+++ b/graphics/nplot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1470568912
-SHA256 (nplot-0.9.10.1.tar.gz) = 12a6b76594eb34e27a25b575e848b4082afb4ad42630f3180e13893111971ba8
-SIZE (nplot-0.9.10.1.tar.gz) = 107708
+TIMESTAMP = 1474125901
+SHA256 (mhowlett-nplot-0.9.11-9a92e78_GH0.tar.gz) = 92fdbdece0e72ea7c1f7bb681a6e7aa61ce7bbca4f704f3aacc84d0f269cbcb1
+SIZE (mhowlett-nplot-0.9.11-9a92e78_GH0.tar.gz) = 267792
diff --git a/graphics/nplot/files/Dynamic.key b/graphics/nplot/files/Dynamic.key
new file mode 100644
index 000000000000..2c3114ed4a0d
--- /dev/null
+++ b/graphics/nplot/files/Dynamic.key
@@ -0,0 +1,13 @@
+BwIAAAAkAABSU0EyAAQAABEAAAAjMJU7PvCTLrqOGkGIWmu3RrUbBCceEoCcKmUG
+S7ejoqi9ANJzOJaJI73+IAA+Vrp0ekVfJasnCyN0NIATNwXGtDDdFqrFuxdiu+27
+IVLF1VSdIq2kTY1OSa4r4BukFVlPVKXgrEm5MTZgLHbn+BNFFJOPev6JfhYdhXjP
+oXSohiU1j0fHet8p++Y9MpPWpM5g1r2apRp2FBQGTIF8fpw69x9GjvSf0JzcymP6
+3Ip6G13C4wLZ+TztHPxIS5ljTryn4WQpbkVYkWCzDS5hNYqvoGt9UNaIfoVtOKEY
+O8AXL0frBeb7KGU3bH/5qMONkv8egllMf0dqrTlODw1n4hC3nUUZhX3on0Mdg6HM
+7DQ76OM01qKG1xR89OKFy+isKt1nyXVzdlisG1SrIB1F3FF9H/XraURZoe3XhrJ2
+hAI7ISFbEaoGexr5tJ8znQ8KQfilMmitNxPDL9ll00eUeFZD5ZvVAu+4TVac4e24
+AY7bDoeIk8kdmsh+dcqdfjAQJlaRcLLGtNB+C/CMHUO67BKwGKkWUx0QBkm9xKgQ
+yAq/44MwPo/EDJU9mcnP0UPQAIHaR54SUauGJOHOL77PpAdSYYciaEEcGIAo+bX8
+Vkz2bN1Szzv7GtX/POWgErEKul0glrXN1H38tY9Dqg0aNFgDVrbmgVpcHjNp6+qP
+VhXabFrRNtEnVlBo7iLXufXVN/ZAEclW2VqPiJR13YMuBlglp0BhwHRJuJXUdHQ2
+l78LkrGDY5N3nHdJPj+hEEHqNU8=
diff --git a/graphics/nplot/files/NPlot.pc.in b/graphics/nplot/files/NPlot.pc.in
new file mode 100644
index 000000000000..d9c781e744d1
--- /dev/null
+++ b/graphics/nplot/files/NPlot.pc.in
@@ -0,0 +1,8 @@
+prefix=%%LOCALBASE%%
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+
+Name: NPlot
+Description: Charting library for .NET.
+Version: 0.9.11
+Libs: -r:${libdir}/mono/NPlot/NPlot.dll
diff --git a/graphics/nplot/pkg-descr b/graphics/nplot/pkg-descr
index a3941debe6ed..bb4661efaf27 100644
--- a/graphics/nplot/pkg-descr
+++ b/graphics/nplot/pkg-descr
@@ -2,4 +2,4 @@ NPlot is a free charting library for .NET. It boasts an elegant,
flexible API and includes controls for Windows.Forms, ASP.NET
and a class for creating Bitmaps.
-WWW: http://netcontrols.org/nplot/wiki/
+WWW: http://nplot.com