aboutsummaryrefslogtreecommitdiff
path: root/graphics/npretty/Makefile
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2006-12-12 20:24:58 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2006-12-12 20:24:58 +0000
commit23d54503820d5452afe1772ea84499e3fa841d41 (patch)
treea7a24caa8748b0179ec72be56c1f255666e253b5 /graphics/npretty/Makefile
parent17b586f38a1614a5df906ad2483acbcc43dd56de (diff)
Notes
Diffstat (limited to 'graphics/npretty/Makefile')
-rw-r--r--graphics/npretty/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/graphics/npretty/Makefile b/graphics/npretty/Makefile
index 74fa1cf1a293..e47de047e89d 100644
--- a/graphics/npretty/Makefile
+++ b/graphics/npretty/Makefile
@@ -1,23 +1,24 @@
# New ports collection makefile for: npretty
# Date created: 11 October 2006
-# Whom: uchman
+# Whom: Peter Ankerstal <peter@pean.org>
#
# $FreeBSD$
#
PORTNAME= npretty
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://bbb.pean.org/junk/npretty/
+MASTER_SITES= http://www.pulia.nu/code/projects/npretty/
MAINTAINER= peter@pean.org
-COMMENT= A simple web-gallery ganerator written in perl
+COMMENT= A simple web-gallery generator written in perl
RUN_DEPENDS= ${SITE_PERL}/Image/ExifTool.pm:${PORTSDIR}/graphics/p5-Image-ExifTool \
${SITE_PERL}/mach/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
${SITE_PERL}/mach/forks.pm:${PORTSDIR}/devel/p5-forks
-LIB_DEPENDS+= Magick.10:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS+= Magick.*:${PORTSDIR}/graphics/ImageMagick
NO_BUILD= yes
USE_PERL5_RUN= yes
@@ -31,5 +32,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/novideo.gif ${PREFIX}/etc/npretty
${INSTALL_DATA} ${WRKSRC}/npretty_template.tpl ${PREFIX}/etc/npretty
${INSTALL_DATA} ${WRKSRC}/npretty.conf ${PREFIX}/etc/npretty
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in BUGS COPYING README
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>